You are not logged in.

#1 2018-12-07 12:46:51

elmaster
Member
Registered: 2018-12-07
Posts: 7

i deleted libalpm.so.11 and my pacman is broken dead

i few months ago i had problems with pacman and the quoted library so i decided the best option was to deleted it and reinstall pacman ,
how wrong i was when i retry to install pacman, get me the issue that it could not create the library so  since then i dont have pacman  o pkgbuild to do it manually

so my question is i can  re-built that library or i do reinstall arch?

this is the main error

$ pacman -Ss telegram
error: no se pudo iniciar la biblioteca alpm
(no se pudo crear la base de datos: /usr/local/var/lib/pacman/)

Offline

#2 2018-12-07 13:07:35

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,461

Re: i deleted libalpm.so.11 and my pacman is broken dead

Boot with the archlinux install iso. Mount your partition and reinstall pacman with the --root option

Offline

#3 2018-12-07 13:16:38

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 115

Re: i deleted libalpm.so.11 and my pacman is broken dead

This should be the broad hint to you, that randomly deleting library files is not a good idea to fix problems.
Follow @olive's instructions to fix your pacman installation.
Also please enclose posted console output in code tags and provide the output of programs in English by prepending the respective command with LANG=C.

Offline

#4 2018-12-07 14:32:27

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 113

Re: i deleted libalpm.so.11 and my pacman is broken dead

read the sticky: "How to reinstall pacman when pacman is broken"

Offline

#5 2018-12-09 04:20:27

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,535

Re: i deleted libalpm.so.11 and my pacman is broken dead

Actually, my primary advice would be to use the AUR package "pacman-static": https://aur.archlinux.org/packages/pacman-static

I'm the maintainer, and I provide precompiled binaries signed with my Trusted User signing key. Since they're statically linked, they work without any sort of installation...

...

Maybe this advice could be added to the relevant sticky?

Last edited by eschwartz (2018-12-09 04:21:56)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#6 2018-12-09 08:31:02

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

schard wrote:

This should be the broad hint to you, that randomly deleting library files is not a good idea to fix problems.
Follow @olive's instructions to fix your pacman installation.
Also please enclose posted console output in code tags and provide the output of programs in English by prepending the respective command with LANG=C.


thanks for the lesson, basicaly this my output every time y try to install anything via pacman or manual try

$makepkg PKGBUILD LANG=C

<samp>==> Making package: pacman-static 5.1.1-6 (Sun Dec  9 02:04:10 2018)
==> Checking runtime dependencies...
error: failed to initialize alpm library
(could not create database: /usr/local/var/lib/pacman/)
==> ERROR: 'pacman' returned a fatal error (255): </samp>

i love @elischwartz propousal but this is the main issue i can't install anything

Last edited by elmaster (2018-12-09 09:03:22)

Offline

#7 2018-12-09 08:59:50

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

eschwartz wrote:

Actually, my primary advice would be to use the AUR package "pacman-static": https://aur.archlinux.org/packages/pacman-static

I'm the maintainer, and I provide precompiled binaries signed with my Trusted User signing key. Since they're statically linked, they work without any sort of installation...

...

Maybe this advice could be added to the relevant sticky?

this what happens whe try to check how to veryfy the gpg provided 

LANG=C pacman-key -v pacman-static

[samp]==> Checking pacman-static...
gpg: no valid OpenPGP data found.
gpg: the signature could not be verified.
Please remember that the signature file (.sig or .asc)
should be the first file given on the command line.
==> ERROR: The signature identified by pacman-static could not be verified.[/samp]

  LANG=C ./build-packages.sh 

[samp] ./build-packages.sh: line 14: extra-x86_64-build: command not found
xz: artifacts/x86_64-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
./build-packages.sh: line 14: extra-i686-build: command not found
xz: artifacts/i686-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
[/samp]

Offline

#8 2018-12-09 09:20:07

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,535

Re: i deleted libalpm.so.11 and my pacman is broken dead

elmaster wrote:
$makepkg PKGBUILD LANG=C

<samp>==> Making package: pacman-static 5.1.1-6 (Sun Dec  9 02:04:10 2018)
==> Checking runtime dependencies...
error: failed to initialize alpm library
(could not create database: /usr/local/var/lib/pacman/)
==> ERROR: 'pacman' returned a fatal error (255): </samp>

i love @elischwartz propousal but this is the main issue i can't install anything

The problem here is that you are attempting to use a pacman which was built by yourself, I suspect by downloading the sources and running ./configure && make && sudo make install, by hand.

This is wrong. You got the wrong ./configure arguments, so pacman is looking in the wrong place to find its configuration files. The official package, or my pacman-static binary, does not have this problem and will allow you to reinstall pacman cleanly. An alternative would be to compile it using --prefix=/usr --sysconfdir=/etc --localstatedir=/var, but at that point you might as well go the initial tar xf route mentioned in the sticky that a821 suggested.

elmaster wrote:

this what happens whe try to check how to veryfy the gpg provided 

LANG=C pacman-key -v pacman-static

[samp]==> Checking pacman-static...
gpg: no valid OpenPGP data found.
gpg: the signature could not be verified.
Please remember that the signature file (.sig or .asc)
should be the first file given on the command line.
==> ERROR: The signature identified by pacman-static could not be verified.[/samp]

The error message states that you must download the .sig file as well, and that you must use the .sig file to perform the verification. Your command line is wrong.

You need to download the pacman-static file, and the pacman-static.sig file, and use the second file with pacman-key -v to prove that it really comes from an official staff member.

Then you can run the pacman-static binary without installing it:

sudo ./pacman-static -Syu pacman
  LANG=C ./build-packages.sh 

[samp] ./build-packages.sh: line 14: extra-x86_64-build: command not found
xz: artifacts/x86_64-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
./build-packages.sh: line 14: extra-i686-build: command not found
xz: artifacts/i686-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
[/samp]

Who told you to run the build-packages.sh script? That is not how you build a package, you are supposed to use makepkg. That script is there because I use it myself to spin up a 32-bit container in order to compile binaries for the https://www.archlinux32.org/ port of Arch Linux to 32-bit systems, then sign the resulting artifacts and upload them via ssh to a hosting server.

It depends on a working pacman, and a working makepkg, in addition to the devtools builder for building in containers *and* the devtools fork which is not available on Arch Linux at all, which has the 32-bit components.

Last edited by eschwartz (2018-12-09 09:27:59)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#9 2018-12-09 11:03:11

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

eschwartz wrote:
elmaster wrote:
$makepkg PKGBUILD LANG=C

<samp>==> Making package: pacman-static 5.1.1-6 (Sun Dec  9 02:04:10 2018)
==> Checking runtime dependencies...
error: failed to initialize alpm library
(could not create database: /usr/local/var/lib/pacman/)
==> ERROR: 'pacman' returned a fatal error (255): </samp>

i love @elischwartz propousal but this is the main issue i can't install anything

The problem here is that you are attempting to use a pacman which was built by yourself, I suspect by downloading the sources and running ./configure && make && sudo make install, by hand.

This is wrong. You got the wrong ./configure arguments, so pacman is looking in the wrong place to find its configuration files. The official package, or my pacman-static binary, does not have this problem and will allow you to reinstall pacman cleanly. An alternative would be to compile it using --prefix=/usr --sysconfdir=/etc --localstatedir=/var, but at that point you might as well go the initial tar xf route mentioned in the sticky that a821 suggested.

elmaster wrote:

this what happens whe try to check how to veryfy the gpg provided 

LANG=C pacman-key -v pacman-static

[samp]==> Checking pacman-static...
gpg: no valid OpenPGP data found.
gpg: the signature could not be verified.
Please remember that the signature file (.sig or .asc)
should be the first file given on the command line.
==> ERROR: The signature identified by pacman-static could not be verified.[/samp]

The error message states that you must download the .sig file as well, and that you must use the .sig file to perform the verification. Your command line is wrong.

You need to download the pacman-static file, and the pacman-static.sig file, and use the second file with pacman-key -v to prove that it really comes from an official staff member.

Then you can run the pacman-static binary without installing it:

sudo ./pacman-static -Syu pacman
  LANG=C ./build-packages.sh 

[samp] ./build-packages.sh: line 14: extra-x86_64-build: command not found
xz: artifacts/x86_64-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/x86_64-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
./build-packages.sh: line 14: extra-i686-build: command not found
xz: artifacts/i686-extracted/pacman-static: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static': No such file or directory
gpg: signing failed: No such file or directory
gpg: can't open 'artifacts/i686-extracted/pacman-static.xz': No such file or directory
gpg: signing failed: No such file or directory
[/samp]

Who told you to run the build-packages.sh script? That is not how you build a package, you are supposed to use makepkg. That script is there because I use it myself to spin up a 32-bit container in order to compile binaries for the https://www.archlinux32.org/ port of Arch Linux to 32-bit systems, then sign the resulting artifacts and upload them via ssh to a hosting server.

It depends on a working pacman, and a working makepkg, in addition to the devtools builder for building in containers *and* the devtools fork which is not available on Arch Linux at all, which has the 32-bit components.

well it tries but, i think could  -f it ,but it may be one of my bad ideas

$ LANG=C sudo ./pacman-static -Syu pacman
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
warning: pacman-5.1.1-1 is up to date -- reinstalling
:: Starting full system upgrade...
:: Replace ca-certificates-cacert with core/ca-certificates? [Y/n] 
:: Replace libx264 with extra/x264? [Y/n] 
:: Replace libx264-all with extra/x264? [Y/n] 
:: Replace qca-qt5 with extra/qca? [Y/n] 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: x264 will be installed before its ffmpeg dependency
warning: dependency cycle detected:
warning: phonon-qt5-gstreamer will be installed before its phonon-qt5 dependency
warning: dependency cycle detected:
warning: python2-twisted will be installed before its python2-incremental dependency

Packages (535) accountsservice-0.6.54-1  adwaita-icon-theme-3.30.0-1  alembic-1.7.9-1  apache-2.4.35-1
               appstream-glib-0.7.12-1  archlinux-keyring-20180808-1  aribb24-1.0.3-2  at-spi2-atk-2.30.0-1
               at-spi2-core-2.30.0-2  atk-2.30.0-1  attica-5.50.0-1  audit-2.8.4-1  automake-1.16.1-1
               avahi-0.7+16+g1cc2b8e-2  babl-0.1.56-1  baobab-3.30.0-1  binutils-2.31.1-3  blosc-1.14.4-1
               brltty-5.6-4  brotli-1.0.6-1  btrfs-progs-4.17.1-1  bubblewrap-0.3.0-1  bzip2-1.0.6-8
               ca-certificates-20180821-1  ca-certificates-cacert-20140824-4 [removal]
               ca-certificates-mozilla-3.39-1  ca-certificates-utils-20180821-1  cairo-1.15.14-1
               cantarell-fonts-1:0.111-1  ceph-libs-13.2.1-2  cheese-3.30.0-1  cmake-3.12.2-1  colord-1.4.3-2
               colord-sane-1.4.3-2  composer-1.7.2-1  confuse-3.2.2-1  coreutils-8.30-1  cryptsetup-2.0.4-1
               curl-7.61.1-3  dbus-1.12.10-2  dconf-0.30.0-1  device-mapper-2.02.181-1  dhcpcd-7.0.8-1
               discount-2.2.4-1  dmidecode-3.2-1  dolphin-emu-1:5.0.r7309.10d230a512-6  double-conversion-3.1.1-1
               e2fsprogs-1.44.4-1  electron-2.0.9-1  eog-3.28.4-1  epiphany-3.30.1-1  evince-3.30.1-1
               evolution-3.30.1-1  evolution-data-server-3.30.1-1  expat-2.2.6-1  feh-2.28-1  ffmpeg-1:4.0.2-3
               file-5.34-1  file-roller-3.30.0-1  filesystem-2018.8-1  firefox-62.0.2-1
               folks-0.11.4+42+g5520ed9a-1  fontconfig-2:2.13.0+15+gc60ed9e-1  freerdp-1:2.0.0_rc3-1
               fribidi-1.0.5-1  fuse-common-3.2.5-1  fuse2-2.9.8-1  gc-7.6.8-1  gcc-8.2.1+20180831-1
               gcc-libs-8.2.1+20180831-1  gcr-3.28.0-4  gdbm-1.18-1  gdk-pixbuf2-2.38.0-1  gdm-3.30.1-1
               gedit-3.30.1-1  gegl-0.4.8-1  geoclue2-2.4.12-1  ghostscript-9.25-3  git-2.19.0-1  gjs-2:1.54.1-1
               glib-networking-2.58.0-1  glib2-2.58.0+31+g2a7d4d2dc-1  glibc-2.28-4  glusterfs-1:4.1.5-1
               gmime3-3.2.0-3  gnome-backgrounds-3.30.0-1  gnome-bluetooth-3.28.2-1  gnome-boxes-3.30.1-1
               gnome-calculator-3.30.1-1  gnome-calendar-3.30.0-1  gnome-characters-3.29.91-1
               gnome-clocks-3.30.0-1  gnome-color-manager-3.30.0-1  gnome-contacts-3.30.1-1
               gnome-control-center-3.30.1-1  gnome-desktop-1:3.30.1-1  gnome-disk-utility-3.30.1-1
               gnome-documents-3.30.0-1  gnome-font-viewer-3.30.0-1  gnome-getting-started-docs-3.30.0-1
               gnome-logs-3.30.0-1  gnome-maps-3.30.1-1  gnome-music-1:3.30.1-1  gnome-online-accounts-3.30.0-1
               gnome-online-miners-3.30.0-1  gnome-photos-3.30.1-1  gnome-screenshot-3.30.0-1
               gnome-session-3.30.1-1  gnome-settings-daemon-3.30.1.1-1  gnome-shell-3.30.0+37+g969eecb88-1
               gnome-shell-extensions-3.30.0-1  gnome-software-3.30.1-1  gnome-system-monitor-3.30.0-1
               gnome-terminal-3.30.1-1  gnome-todo-3.28.1-3  gnome-user-docs-3.30.1-1  gnupg-2.2.10-1
               gnutls-3.5.19-2  go-2:1.11-1  gobject-introspection-runtime-1.58.0+2+g1f1dd7f4-2  gom-0.3.3-2
               gpgme-1.11.1-2  gpm-1.20.7.r27.g1fd1941-1  graphite-1:1.3.12-1  grilo-0.3.6-1
               grilo-plugins-0.3.8-1  gsettings-desktop-schemas-3.28.1-1  gsfonts-20180524-1
               gst-plugins-bad-1.14.3-1  gst-plugins-base-1.14.3-1  gst-plugins-base-libs-1.14.3-1
               gst-plugins-good-1.14.3-1  gstreamer-1.14.3-1  gtk-update-icon-cache-3.24.1+2+ged57e564a9-1
               gtk-vnc-0.9.0-1  gtk3-3.24.1+2+ged57e564a9-1  gtksourceview3-3.24.9-2  gupnp-1.0.3-1  gvfs-1.38.1-1
               gvfs-afc-1.38.1-1  gvfs-goa-1.38.1-1  gvfs-google-1.38.1-1  gvfs-gphoto2-1.38.1-1
               gvfs-mtp-1.38.1-1  gvfs-nfs-1.38.1-1  gvfs-smb-1.38.1-1  harfbuzz-1.9.0-1  harfbuzz-icu-1.9.0-1
               hdf5-1.10.3-2  hunspell-en_US-2018.04.16-5  ibus-1.5.19-1  ibus-anthy-1.5.10-2  icu-62.1-1
               ilmbase-2.3.0-1  inkscape-0.92.3-4  intel-tbb-2019-1  iproute2-4.18.0-1  iptables-1:1.6.2-3
               iputils-20180629.f6aac8d-2  jack-0.125.0-5  jfsutils-1.1.15-6  js60-60.2.1-1  json-c-0.13.1-2
               json-glib-1.4.4-1  kaccounts-integration-18.08.1-1  kactivities-5.50.0-1  karchive-5.50.0-1
               kauth-5.50.0-1  kbookmarks-5.50.0-1  kcmutils-5.50.0-1  kcodecs-5.50.0-1  kcompletion-5.50.0-1
               kconfig-5.50.0-1  kconfigwidgets-5.50.0-1  kcoreaddons-5.50.0-1  kcrash-5.50.0-1
               kdbusaddons-5.50.0-1  kdeclarative-5.50.0-1  keyutils-1.5.11-1  kglobalaccel-5.50.0-1
               kguiaddons-5.50.0-1  ki18n-5.50.0-1  kiconthemes-5.50.0-1  kio-5.50.0-1  kitemviews-5.50.0-1
               kjobwidgets-5.50.0-1  kjs-5.50.0-1  knotifications-5.50.0-1  kpackage-5.50.0-1  kparts-5.50.0-1
               kpty-5.50.0-1  kservice-5.50.0-1  ktextwidgets-5.50.0-1  kwallet-5.50.0-1  kwidgetsaddons-5.50.0-1
               kwindowsystem-5.50.0-1  kxmlgui-5.50.0-1  l-smash-2.14.5-1  ldb-1:1.3.6-1  lensfun-0.3.2-7
               lib32-gcc-libs-8.2.1+20180831-1  lib32-glibc-2.28-4  libaccounts-glib-1.23-3  libarchive-3.3.3-1
               libatomic_ops-7.6.6-1  libblockdev-2.20-1  libbluray-1.0.2-2  libbytesize-1.4-1  libcacard-2.6.1-1
               libcdr-0.1.4-4  libcmis-0.5.1-10  libcurl-compat-7.61.1-1  libcurl-gnutls-7.61.1-1
               libdazzle-3.30.1-1  libdrm-2.4.94-1  libe-book-0.1.3-3  libelf-0.174-1  libgdm-3.30.1-1
               libgexiv2-0.10.8-2  libglvnd-1.1.0-1  libgphoto2-2.5.19-1  libgsf-1.14.44-1  libibus-1.5.19-1
               libical-3.0.4-1  libidn-1.35-1  libimobiledevice-1.2.0+66+g5a85432-2  libinput-1.12.0-2
               libixion-0.13.0-4  libjpeg-turbo-2.0.0-1  libkexiv2-18.08.1-1  libldap-2.4.46-2  liblouis-3.7.0-1
               libmagick6-6.9.10.12-1  libmariadbclient-10.1.36-1  libmm-glib-1.8.2-1  libmspub-0.1.4-3
               libnautilus-extension-3.30.0+20+gce52f6493-1  libndp-1.7-1  libnewt-0.52.20-2  libnghttp2-1.33.0-1
               libnm-1.14.1dev+13+g0d3234478-1  libnm-glib-1.14.1dev+13+g0d3234478-1  libnm-gtk-1.8.18-2
               libnma-1.8.18-2  libnumbertext-1.0-1  liborcus-0.13.4-4  libpackagekit-glib-1.1.11-1
               libpcap-1.9.0-1  libpeas-1.22.0-3  libphonenumber-8.9.12-2  libplist-2.0.0+11+gec9ba8b-2
               libpng-1.6.35-1  libproxy-0.4.15-8  libpst-0.6.71-4  libpulse-12.2-2  libqxp-0.0.1-3
               libraw-0.19.0-1  libreoffice-fresh-6.1.1-3  librsvg-2:2.44.6-1  libsoup-2.64.1-1
               libspeechd-0.8.8-2  libssh-0.8.3-1  libsystemd-239.2-1  libteam-1.27-2  libthai-0.1.28-1
               libtirpc-1.1.4-1  libtool-2.4.6+42+gb88cebd5-2  libtorrent-rasterbar-1:1.1.9-2
               libutil-linux-2.32.1-2  libuv-1.23.1-1  libva-2.3.0-1  libvirt-4.7.0-1  libvisio-0.1.6-4
               libvoikko-4.1.1-2  libwacom-0.31-1  libwbclient-4.8.5-1  libwps-0.4.10-1  libx11-1.6.6-1
               libx264-2:152.20171224-2 [removal]  libx264-all-2:152.20171224-2 [removal]  libxkbcommon-0.8.2-1
               libxkbcommon-x11-0.8.2-1  libxml2-2.9.8-5  libxss-1.2.3-1  libyaml-0.2.1-1
               libytnef-1.9.3+7+g24fe30e-1  libzmf-0.0.2-4  links-2.17-1  linux-4.18.10.arch1-1
               linux-api-headers-4.17.11-1  linux-firmware-20180825.fea76a0-1  llvm-libs-7.0.0-1
               lm_sensors-3.4.0+5176+dcf23676-1  log4cplus-2.0.2-1  lvm2-2.02.181-1  lxc-1:3.0.2-1  lz4-1:1.8.3-1
               man-db-2.8.4-1  man-pages-4.16-2  mbedtls-2.13.0-1  mesa-18.2.1-2  minizip-1:1.2.11-3
               mkinitcpio-busybox-1.29.3-1  mongodb-4.0.2-1  mono-5.14.0.177-1  mosh-1.3.2-6  mumble-1.2.19-11
               murmur-1.2.19-12  mutter-3.30.0+13+g2fb3db765-1  nano-3.1-1  nautilus-sendto-3.8.6+14+ge8a3604-1
               ndctl-62-2  net-snmp-5.7.3-9  netctl-1.18-1  network-manager-applet-1.8.18-2
               networkmanager-1.14.1dev+13+g0d3234478-1  nm-connection-editor-1.8.18-2  node-gyp-3.8.0-1
               nodejs-10.11.0-1  npm-6.4.1-1  nspr-4.20-1  nss-3.39-1  ntfs-3g-2017.3.23-3  numactl-2.0.12-1
               oath-toolkit-2.6.2-4  obs-studio-22.0.2-1  okular-18.08.1-4  openal-1.19.0-2
               opencollada-1:1.6.63-1  opencolorio-1.1.0-3  openexr-2.3.0-1  openimageio-1.8.14-2
               openjpeg2-2.3.0-3  openshadinglanguage-1.9.10-3  openssh-7.8p1-1  openssl-1.1.1-1
               openssl-1.0-1.0.2.p-1  opensubdiv-3.3.3-1  openvdb-5.2.0-1  orca-3.30.0-1  osinfo-db-20180903-1
               p11-kit-0.23.14-1  pacman-mirrorlist-20180912-1  pango-1.42.4-1  pcre2-10.32-1  perl-5.28.0-1
               perl-error-0.17026-2  perl-mailtools-2.20-2  perl-timedate-2.30-5  perl-uri-1.74-2
               perl-xml-parser-2.44-7  phonon-qt5-4.10.1-2  phonon-qt5-gstreamer-4.9.0-5  php-7.2.10-1
               pipewire-0.2.3-1  pkgconf-1.5.3-1  polkit-0.115+3+g8638ec5-1  polkit-qt5-0.112.0+git20180107-2
               poppler-0.67.0-1  poppler-glib-0.67.0-1  poppler-qt5-0.67.0-1  protobuf-3.6.1-1  protobuf-c-1.3.1-1
               ptex-2.3.0-1  pulseaudio-12.2-2  pulseaudio-bluetooth-12.2-2  purpose-5.50.0-1  pyalpm-0.8.4-2
               pygobject-devel-3.30.1-3  pygobject2-devel-2.28.7-2  python-3.7.0-4  python-appdirs-1.4.3-2
               python-atspi-2.30.0-1  python-cairo-1.17.0-2  python-chardet-3.0.4-2  python-click-7.0-1
               python-dateutil-2.7.3-2  python-dbus-1.2.8-2  python-dbus-common-1.2.8-2  python-feedparser-5.2.1-3
               python-flask-1.0.2-2  python-gobject-3.30.1-3  python-idna-2.7-3  python-itsdangerous-0.24-4
               python-jinja-2.10-2  python-markupsafe-1.0-2  python-numpy-1.15.2-1  python-packaging-17.1-2
               python-pyparsing-2.2.2-1  python-pytoml-0.1.19-1  python-regex-2018.08.29-1
               python-requests-2.19.1-2  python-setuptools-1:40.4.3-1  python-sgmllib-5.2.1-3
               python-sip-4.19.12-5  python-six-1.11.0-3  python-urllib3-1.23-2  python-werkzeug-0.14.1-3
               python-xdg-0.26-2  python2-appdirs-1.4.3-2  python2-asn1crypto-0.24.0-2  python2-attrs-18.2.0-1
               python2-automat-0.7.0-2  python2-cairo-1.17.0-2  python2-cffi-1.11.5-2  python2-chardet-3.0.4-2
               python2-click-7.0-1  python2-constantly-15.1.0-3  python2-cryptography-2.3.1-1
               python2-dbus-1.2.8-2  python2-gobject-3.30.1-3  python2-gobject2-2.28.7-2
               python2-hyperlink-18.0.0-2  python2-idna-2.7-3  python2-incremental-17.5.0-2
               python2-numpy-1.15.2-1  python2-packaging-17.1-2  python2-pillow-5.2.0-3  python2-ply-3.11-2
               python2-psutil-5.4.7-1  python2-pycparser-2.19-1  python2-pyhamcrest-1.9.0-3
               python2-pyopenssl-18.0.0-2  python2-pyparsing-2.2.2-1  python2-setuptools-1:40.4.3-1
               python2-simplejson-3.16.0-2  python2-sip-4.19.12-5  python2-six-1.11.0-3  python2-twisted-18.7.0-2
               python2-xdg-0.26-2  python2-zope-interface-4.5.0-2  qca-2.1.3-1  qca-qt5-2.1.3-11 [removal]
               qemu-3.0.0-2  qt4-4.8.7-25  qt5-base-5.11.2-1  qt5-declarative-5.11.2-1  qt5-location-5.11.2-1
               qt5-multimedia-5.11.2-1  qt5-script-5.11.2-1  qt5-sensors-5.11.2-1  qt5-speech-5.11.2-1
               qt5-svg-5.11.2-1  qt5-webchannel-5.11.2-1  qt5-webkit-5.212.0alpha2-20  qt5-x11extras-5.11.2-1
               qt5-xmlpatterns-5.11.2-1  raptor-2.0.15-9  re2-20180901-1  riot-desktop-0.16.4-1  riot-web-0.16.4-1
               rpcbind-1.2.5-1  rygel-0.36.2-1  s-nail-14.9.11-1  sakura-3.6.0-2  semver-5.5.1-1  shadow-4.6-1
               shared-mime-info-1.10-1  signon-kwallet-extension-18.08.1-1  signond-8.60-1  simple-scan-3.30.1.1-1
               sip-4.19.12-5  smbclient-4.8.5-1  solid-5.50.0-1  sonnet-5.50.0-1  soundtouch-2.1.0-1
               speech-dispatcher-0.8.8-2  spice-gtk-0.35-1  sqlite-3.25.2-1  sudo-1.8.25.p1-1  sushi-3.30.0-2
               systemd-239.2-1  systemd-sysvcompat-239.2-1  talloc-2.1.14-1  tdb-1.3.16-1  tevent-1:0.9.37-1
               threadweaver-5.50.0-1  thunar-1.8.2-1  thunderbird-60.0-4  thunderbird-i18n-en-us-60.0-2
               thunderbird-i18n-es-es-60.0-2  thunderbird-i18n-ja-60.0-2  thunderbird-i18n-zh-cn-60.0-2
               tor-0.3.4.8-1  totem-3.26.2-1  totem-plparser-3.26.1+2+gb7f36dd-1  tracker-2.1.5-1
               tracker-miners-2.1.5-1  tslib-1.17-1  tumbler-0.2.3-1  tzdata-2018e-2  udisks2-2.8.1-1
               uglify-js-3.4.9-1  umurmur-0.2.17-12  unrar-1:5.6.7-1  upower-0.99.8-2  util-linux-2.32.1-2
               valgrind-3.13.0+290+2b0aa0a5-1  vde2-2.3.2-11  vim-8.1.0374-1  vim-runtime-8.1.0374-1
               vino-3.22.0+19+g15eb3c5-1  virglrenderer-0.7.0-1  virtualbox-5.2.18-1
               virtualbox-guest-modules-arch-5.2.18-12  virtualbox-guest-utils-5.2.18-1
               virtualbox-host-modules-arch-5.2.18-12  vlc-3.0.4-4  volume_key-0.3.11-2  vte-common-0.54.1-1
               vte3-0.54.1-1  vulkan-icd-loader-1.1.82+2958+1f9a54573-1  wayland-1.16.0-1
               wayland-protocols-1.16-1  webkit2gtk-2.22.2-1  webrtc-audio-processing-0.3.1-1
               wiredtiger-3.0.0.20180814-1  wpa_supplicant-1:2.6-12  wxgtk-common-3.0.4-2  wxgtk2-3.0.4-2
               x264-2:155.r0a84d986-2  xcb-proto-1.13-2  xdg-utils-1.1.3-3  xfconf-4.12.1-5  xorg-server-1.20.1-1
               xorg-server-common-1.20.1-1  xorg-server-xwayland-1.20.1-1  yarn-1.10.1-1  yelp-3.30.0-1
               yelp-xsl-3.30.1-1  zita-alsa-pcmi-0.3.2-1  zita-resampler-1.6.2-1  zlib-1:1.2.11-3  zvbi-0.2.35-3
               pacman-5.1.1-1

Total Installed Size:  6057.54 MiB
Net Upgrade Size:       207.39 MiB

:: Proceed with installation? [Y/n] 
(531/531) checking keys in keyring                                    [######################################] 100%
(531/531) checking package integrity                                  [######################################] 100%
(531/531) loading package files                                       [######################################] 100%
(531/531) checking for file conflicts                                 [######################################] 100%
error: failed to commit transaction (conflicting files)
python-six: /usr/lib/python3.7/site-packages/__pycache__/six.cpython-37.pyc exists in filesystem
python-six: /usr/lib/python3.7/site-packages/six.py exists in filesystem
python-setuptools: /usr/bin/easy_install-3.7 exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/__pycache__/easy_install.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/easy_install.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/pkg_resources/__init__.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/pkg_resources/__pycache__/__init__.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/pkg_resources/__pycache__/py31compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/pkg_resources/py31compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__init__.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/__init__.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/archive_util.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/build_meta.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/config.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/dep_util.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/depends.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/dist.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/extension.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/glibc.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/glob.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/launch.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/lib2to3_ex.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/monkey.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/msvc.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/namespaces.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/package_index.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/pep425tags.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/py27compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/py31compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/py33compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/py36compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/sandbox.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/site-patch.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/ssl_support.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/unicode_utils.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/version.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/wheel.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/__pycache__/windows_support.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/archive_util.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/build_meta.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__init__.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/__init__.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/alias.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/bdist_egg.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/bdist_rpm.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/bdist_wininst.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/build_clib.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/build_ext.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/build_py.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/develop.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/dist_info.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/easy_install.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/egg_info.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/install.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/install_egg_info.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/install_lib.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/install_scripts.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/py36compat.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/register.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/rotate.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/saveopts.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/sdist.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/setopt.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/test.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/upload.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/__pycache__/upload_docs.cpython-37.pyc exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/alias.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/bdist_egg.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/bdist_rpm.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/bdist_wininst.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/build_clib.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/build_ext.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/build_py.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/develop.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/dist_info.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/easy_install.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/egg_info.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/install.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/install_egg_info.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/install_lib.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/install_scripts.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/py36compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/register.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/rotate.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/saveopts.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/sdist.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/setopt.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/test.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/upload.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/command/upload_docs.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/config.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/dep_util.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/depends.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/dist.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/extension.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/glibc.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/glob.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/launch.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/lib2to3_ex.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/monkey.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/msvc.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/namespaces.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/package_index.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/pep425tags.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/py27compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/py31compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/py33compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/py36compat.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/sandbox.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/script (dev).tmpl exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/script.tmpl exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/site-patch.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/ssl_support.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/unicode_utils.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/version.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/wheel.py exists in filesystem
python-setuptools: /usr/lib/python3.7/site-packages/setuptools/windows_support.py exists in filesystem
Errors occurred, no packages were upgraded.
[ultramster@archlinux pacman-static]$

Last edited by elmaster (Today 06:47:37)

Offline

#10 2018-12-09 11:21:48

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

and i could't find the pacman-static.sig download file , i try here :

https://pgp.mit.edu/pks/lookup?op=vinde … 6819AF4A9B

https://aur.archlinux.org/packages/pacman-static/

i think i solved it with this but im not sure

 sudo pacman-key --init

Offline

#11 2018-12-09 12:59:17

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,404
Website

Re: i deleted libalpm.so.11 and my pacman is broken dead

Please edit your post to encapsulate the entire output in code tags, not just the command.

https://wiki.archlinux.org/index.php/Co … s_and_code


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#12 2018-12-09 13:13:09

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,535

Re: i deleted libalpm.so.11 and my pacman is broken dead

elmaster wrote:

well it tries but, i think could  -f it ,but it may be one of my bad ideas

The output you described shows that pacman-static worked fine. However, you have a lot of updates and you've also, coincidentally, broken your system with respect to the python modules "six" and "setuptools".

Have you ever installed things using "sudo pip"? Don't do that.

P.S. Start putting the whole command + output in the code tags.

elmaster wrote:

and i could't find the pacman-static.sig download file , i try here :

https://pgp.mit.edu/pks/lookup?op=vinde … 6819AF4A9B

https://aur.archlinux.org/packages/pacman-static/

i think i solved it with this but im not sure

 sudo pacman-key --init

I have no idea why you'd look on a totally unrelated thing like a keyserver for a *signature*.

And the sig file is right there on the pacman-static page, so I've got no clue how you could miss it and won't even try to guess.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#13 2018-12-09 17:54:25

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,461

Re: i deleted libalpm.so.11 and my pacman is broken dead

eschwartz wrote:

Actually, my primary advice would be to use the AUR package "pacman-static": https://aur.archlinux.org/packages/pacman-static

I'm the maintainer, and I provide precompiled binaries signed with my Trusted User signing key. Since they're statically linked, they work without any sort of installation...

...

Maybe this advice could be added to the relevant sticky?

But you still need to have a sufficiently working installation to build the package in the first place (which take a rather long time, by the way); moreover I see that your package depends on pacman; but if pacman is correctly installed, your package is not needed. Also, without a working pacman, your package cannot be installed.

Can the binary even be used alone? Or does it still need /etc/pacman.conf /etc/pacman.d/mirrorlist, etc.

Honestly booting with the archlinux iso seems much easier and will work for really broken systems.

Last edited by olive (2018-12-09 17:57:53)

Offline

#14 2018-12-09 22:30:49

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,535

Re: i deleted libalpm.so.11 and my pacman is broken dead

olive wrote:

But you still need to have a sufficiently working installation to build the package in the first place (which take a rather long time, by the way); moreover I see that your package depends on pacman; but if pacman is correctly installed, your package is not needed. Also, without a working pacman, your package cannot be installed.

So, you've clearly taken a non-trivial look at said AUR package. But somehow you overlooked the pinned comment where I link the extracted, standalone binary and advise people to download it and use it purely to repair their broken systems which may not have a working pacman and may not even have a working glibc.

Can the binary even be used alone? Or does it still need /etc/pacman.conf /etc/pacman.d/mirrorlist, etc.

Honestly booting with the archlinux iso seems much easier and will work for really broken systems.

Well, uh, sure it needs pacman.conf. How else do you configure things like oh, the root directory to use, the directory containing the package database, the configured mirrors, and in fact, general pacman configuration in general?

The mirrorlist isn't needed by core/pacman regardless. Although it is needed by the default pacman.conf, this is totally different.

...

The purpose of the pacman-static package is to serve as documentation for how I build the official recovery binaries. I don't actually expect anyone other than me to build it, not after I've done all the hard work...

Either way, it is certainly correct for me to depend on core/pacman. There's absolutely no need for the binaries it ships, but, well, you do sort of definitely need the directory /var/lib/pacman/local/ and the file /etc/pacman.conf, both of which are provided by pacman, and both of which you also need for recovering from the ISO.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#15 Today 08:09:02

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

olive wrote:
eschwartz wrote:

Actually, my primary advice would be to use the AUR package "pacman-static": https://aur.archlinux.org/packages/pacman-static

I'm the maintainer, and I provide precompiled binaries signed with my Trusted User signing key. Since they're statically linked, they work without any sort of installation...

...

Maybe this advice could be added to the relevant sticky?

But you still need to have a sufficiently working installation to build the package in the first place (which take a rather long time, by the way); moreover I see that your package depends on pacman; but if pacman is correctly installed, your package is not needed. Also, without a working pacman, your package cannot be installed.

Can the binary even be used alone? Or does it still need /etc/pacman.conf /etc/pacman.d/mirrorlist, etc.

Honestly booting with the archlinux iso seems much easier and will work for really broken systems.

probably true, but the libalpm problem get a better solution with this package. And thats what i ask in the first place

Actually have you tried to use the package, it does what it promises, runs without instalation, solve the the missing lib problem and without it i couldn't guess that since i deleted that lib,  i been screewd more my SO and where , and return some use of my pacman. Having more than one way to install stuff is always welcome .

Offline

#16 Today 08:14:07

elmaster
Member
Registered: 2018-12-07
Posts: 7

Re: i deleted libalpm.so.11 and my pacman is broken dead

i think the stuff i ask is solved,so i will left it open 48 for better sugestion for the stiky , because is my first time in this kind of forums. so thanks to all the the ones who lend a piece of your knowledge...

[SOLVED] i deleted libalpm.so.11 and my pacman is broken dead, solved pacman-static library

Offline

#17 Today 17:44:57

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,535

Re: i deleted libalpm.so.11 and my pacman is broken dead

Please edit your first post and prepend "[Solved]" to the thread title. smile

Also happy to help w.r.t. pacman-static, good to hear it is being useful to people. big_smile


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB