You are not logged in.

#1 2018-12-08 22:04:03

squilter
Member
Registered: 2015-10-05
Posts: 9

[SOLVED] Gnome reverts to X11 without external monitor plugged in

This problem showed up in the last few weeks, but I was not able to trace it down to a specific package upgrade.

I use gdm and gnome. I have been using wayland for the past few months without any problems. Now, I sometimes boot and find that X11 is running. I don't want that. I always want to be using wayland. I realized that this only occurs when I boot my laptop when it is not plugged into my external monitor. If my second monitor is plugged in when I boot, I get wayland. If my laptop is not plugged into the monitor when I boot, I get X11. Any ideas?

/etc/gdm/custom.conf has WaylandEnable=True

Last edited by squilter (2018-12-14 18:31:00)

Offline

#2 2018-12-13 08:10:29

the_deep
Member
Registered: 2018-12-13
Posts: 2

Re: [SOLVED] Gnome reverts to X11 without external monitor plugged in

Hello squilter,

I have a similar problem since a couple of days my GNOME does not use wayland anymore. I actually only noticed it because I wasn't able to switch workspaces via four finger touchpad gesture anymore. Then I noticed that I had a /usr/lib/Xorg process and so here I am.

Have you seen the Troubleshooting section of the GNOME wiki page? https://wiki.archlinux.org/index.php/GN … _available.

For me I'm not sure if wayland is even crashing or it's just stupidly using Xorg. Although I tried what you did and enabled /etc/gdm/custom.conf WaylandEnable=true and also with this it was still running Xorg. Also when setting the environment variable suggested in that wiki page it's still running Xorg.

Maybe a few words regarding my setup: I have a thinkpad T470p, so embedded Intel graphics and a "discrete" Nvidia GPU for which I've set up bumblebee, but I'm barely using it. I haven't tried booting with an external monitor yet.

Wayland used to work fine and I would really like to get it back not only because not only for the gestures but also when watching netflix the image is not fully opaque and when there's black parts in the scene I can see my desktop wallpaper through it.

Last edited by the_deep (2018-12-13 08:12:53)

Offline

#3 2018-12-14 08:38:53

the_deep
Member
Registered: 2018-12-13
Posts: 2

Re: [SOLVED] Gnome reverts to X11 without external monitor plugged in

Hello squilter, sorry for the double post.

I managed to figure out the problem: Mutter cannot find a drm KMS device.

Dec 14 09:17:54 Leonidas gnome-shell[647]: Failed to create backend: Could not find a primary drm kms device
Dec 14 09:17:54 Leonidas gnome-session[639]: gnome-session-binary[639]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Dec 14 09:17:54 Leonidas gnome-session-binary[639]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Dec 14 09:17:54 Leonidas gnome-session-binary[639]: Unrecoverable failure in required component org.gnome.Shell.desktop

I figured it out via this thread: https://bbs.archlinux.org/viewtopic.php?id=225690

The solution for me was to enable an early kms start of the intel card as explained in the wiki: https://wiki.archlinux.org/index.php/ke … _KMS_start

Maybe this solves your problem, too?

Offline

#4 2018-12-14 16:58:04

squilter
Member
Registered: 2015-10-05
Posts: 9

Re: [SOLVED] Gnome reverts to X11 without external monitor plugged in

That fixed it, thanks!

(If anybody finds this in the future, I probably should have mentioned that this is on a thinkpad x1 carbon, gen 5. The GPU is an intel HD620)

Offline

#5 2018-12-14 17:29:58

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,386

Re: [SOLVED] Gnome reverts to X11 without external monitor plugged in

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Offline

Board footer

Powered by FluxBB