You are not logged in.

#1 2018-12-25 05:12:05

LiveLM
Member
Registered: 2018-12-25
Posts: 2

[SOLVED] Crash when launching Steam Runtime

Steam used to work fine on my machine, then one day I redeemed a steam gift card. Steam crashed, and now every time I try to launch Steam, I get this error.
I reinstalled Steam and deleted the '~/.steam' and '~/.local/share/Steam/' folders multiple times, and the issue persists.

Is this an issue with my system, or should I report the bug to Valve?

Last edited by LiveLM (2018-12-25 19:52:07)

Offline

#2 2018-12-25 11:53:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,284

Re: [SOLVED] Crash when launching Steam Runtime

https://wiki.archlinux.org/index.php/Steam#Installation

Generate an en-US.UTF-8 locale make sure that in general your locale points to a valid locale (doesn't have to be the generated en-US.UTF-8 locale, can be any other valid UTF-8 locale) If it doesn't work or you're still not sure on what to do, repost the new resulting log after having minimally fixed that, as well as

locale
locale -a

Offline

#3 2018-12-25 18:11:54

LiveLM
Member
Registered: 2018-12-25
Posts: 2

Re: [SOLVED] Crash when launching Steam Runtime

Interesting. I ran locale and this came back:

locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME=pt_BR.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

So, out of curiosity I went to the KDE Control Panel and toggled off the "Detailed Settings" option, so everything on my system uses en_US.UTF-8 instead of having LC_TIME using pt_BR.UTF-8
Launched Steam again, and it opened right up. Weird, this has never been an issue before.
Anyways, thank you for the help!

Offline

#4 2018-12-25 18:24:54

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,387

Re: [SOLVED] Crash when launching Steam Runtime

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Online

Board footer

Powered by FluxBB