You are not logged in.

#1 2018-12-26 00:59:42

natrix
Member
Registered: 2018-01-10
Posts: 10

Wireless does not work after update [SOLVED]

Hi everybody!

I have the following problem, my wireless connection stopped working after a linux-firmware update.
The latest linux-firmware update (20181218) still does not work.

I temporarily made a downgrade to lxfw-20180825 (with wire) and I ‘ignore’ it in pacman.

How can I fix the problem?

Info:

$lspci -k
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)
Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

Thank you!!

Last edited by natrix (2018-12-30 22:51:52)

Offline

#2 2018-12-26 09:07:44

seth
Member
Registered: 2012-09-03
Posts: 12,655

Re: Wireless does not work after update [SOLVED]

Check which firmware is loaded when it works and when it doesn't and file a bug against the firmware providing some "minor" details like eg. dmesg?

Offline

#3 2018-12-27 00:26:58

natrix
Member
Registered: 2018-01-10
Posts: 10

Re: Wireless does not work after update [SOLVED]

Hi Seth:
Thank you very much for your help!
These are some outputs:

linux-firmware-20181218 (not work):

dmesg | grep ath
[   18.308116] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   18.960291] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
[   18.960312] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   19.062492] ath10k_pci 0000:03:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 17aa:4035
[   19.062497] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[   19.063649] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[   22.130007] ath10k_pci 0000:03:00.0: unable to read from the device
[   22.130010] ath10k_pci 0000:03:00.0: could not execute otp for board id check: -110
[   22.130013] ath10k_pci 0000:03:00.0: failed to get board id from otp: -110
[   22.130038] ath10k_pci 0000:03:00.0: could not probe fw (-110)

linux-firmware- 20180825 (work!):

 dmesg | grep ath
[   17.082912] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   17.631352] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
[   17.631374] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   17.746231] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
[   17.904141] ath10k_pci 0000:03:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 17aa:4035
[   17.904150] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[   17.906097] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[   18.066528] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[   20.352768] ath10k_pci 0000:03:00.0: htt-ver 3.44 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   20.359738] ath: EEPROM regdomain: 0x6c
[   20.359740] ath: EEPROM indicates we should expect a direct regpair map
[   20.359742] ath: Country alpha2 being used: 00
[   20.359743] ath: Regpair used: 0x6c
[   20.475582] ath10k_pci 0000:03:00.0 wlp3s0: renamed from wlan0

what is the issue?

Offline

#4 2018-12-27 08:00:32

seth
Member
Registered: 2012-09-03
Posts: 12,655

Re: Wireless does not work after update [SOLVED]

ath10k/QCA9377/hw1.0/firmware-6.bin doesn't exist in the older package, but in the newer one. It's then loaded and apparently spoils your device.
So you can delete that file, see whether things work again, noextract it ("man 5 pacman.conf") and if thing s work again, complain to the author, https://git.kernel.org/pub/scm/linux/ke … 2be48c73b1

(I've no idea about the proper approach here, the guy works for qualcomm and provided all firmwares, so in doubt just dm him)

Offline

#5 2018-12-27 11:42:46

loqs
Member
Registered: 2014-03-06
Posts: 8,755

Re: Wireless does not work after update [SOLVED]

I would suggest ath10k@lists.infradead.org or linux-wireless@vger.kernel.org with a CC to valo@qca.qualcomm.com.
Would also suggest trying linux 4.20 with linux-firmware-20181218.

Offline

#6 2018-12-30 22:51:28

natrix
Member
Registered: 2018-01-10
Posts: 10

Re: Wireless does not work after update [SOLVED]

Hi Seth!. I replaced the file firmware-6.bin with the firmware-5.bin  and now it Works!!

Hi logs! Is probably that in kernel-4.20 this problem is already fixed, but I prefer to continue using LTS versions.

Thank you very much everybody!!!

Offline

#7 2018-12-30 22:57:42

loqs
Member
Registered: 2014-03-06
Posts: 8,755

Re: Wireless does not work after update [SOLVED]

linux-lts is moving to 4.19.13 hopefully it should be fixed there for you as well as in linux which is now on 4.20.

Offline

Board footer

Powered by FluxBB