You are not logged in.

#1 2018-12-11 10:31:42

qlem
Member
Registered: 2017-05-09
Posts: 24

[solved] lenovo x1 carbon 6th - static noise through headphone

Hi,

The last upgrade of the kernel breaks the system sound in my laptop lenovo x1 carbon 6th generation,
The sound have constant noise and pollution, i had to downgrade with pacman the linux package to linux 4.19.2 to fix it,

Some other guys have that problem ?

Last edited by qlem (2019-01-04 14:16:14)

Offline

#2 2018-12-11 15:45:50

pggbee
Member
Registered: 2015-07-29
Posts: 4

Re: [solved] lenovo x1 carbon 6th - static noise through headphone

Just to corroborate: I have the same laptop (X1C6) and experiencing the same issue on 4.19.8

Offline

#3 2018-12-19 22:50:24

qlem
Member
Registered: 2017-05-09
Posts: 24

Re: [solved] lenovo x1 carbon 6th - static noise through headphone

Same issue on linux-4.19.9.arch1-1

Offline

#4 2018-12-31 15:50:35

pggbee
Member
Registered: 2015-07-29
Posts: 4

Re: [solved] lenovo x1 carbon 6th - static noise through headphone

I'm seeing improvements on 4.20.0 -- there is still a bit of audio static, however, it isn't as bad as it was w/ the last few 4.19 kernels.

Offline

#5 2019-01-03 18:48:21

pggbee
Member
Registered: 2015-07-29
Posts: 4

Re: [solved] lenovo x1 carbon 6th - static noise through headphone

@qlem checkout this comment in a launchpad bug issue: https://bugs.launchpad.net/ubuntu/+sour … omments/20

Issuing that hda-verb command has eliminated the static I've been hearing since 4.19.2 -- I haven't fully grokked that thread, but wanted to share the only helpful thing I've been able to find in weeks

Offline

#6 2019-01-04 14:04:52

qlem
Member
Registered: 2017-05-09
Posts: 24

Re: [solved] lenovo x1 carbon 6th - static noise through headphone

Hi, thank you pggbee, this fixed the static noise through headphone on my laptop. For guys that have the same issue:

sudo pacman -S alsa-tools
sudo hda-verb /dev/snd/hwC0D0 0x1d SET_PIN_WIDGET_CONTROL 0x0

You have to execute this command at each boot. So create an autostart or something else.

The original thread with a partial explanation of the issue / solution: https://www.reddit.com/r/thinkpad/comme … _jack_and/

Happy new year smile

Offline

Board footer

Powered by FluxBB