You are not logged in.

#1 2018-12-08 19:53:19

Registered: 2018-11-30
Posts: 2

Filesystem create/modify freezes with an NVMe SSD on an Intel NUC i5

hi! I've been trying to install Arch on an Intel NUC (7th gen, i5 BNK) from USB media, and the NVMe SSD (an ADATA SX6000PNP) has been giving me issues. The NUC formerly had Windows 10 installed on it and multiple partitions, which neither fdisk nor parted could apparently touch: both would freeze a matter of seconds after beginning to persist changes. I was only able to remove the partitions with the Microsoft Windows Media Creation Tool, leaving in theory a blank slate. However, I'm still not able to create the new EFI boot and ordinary Linux partitions.

I did see this NUC topic, which points to graphics drivers as the possible culprit, although that poster's system has a discrete graphics card and mine only has the integrated Iris graphics.

There's also this thread on the Manjaro forums, which also turns to graphics drivers. The official repositories no longer have inxi and I couldn't build it on a USB key to see if I got a similar result, but I wouldn't know what to do if I did based on the limited information in that thread.

I'm a bit out of my element here so this may be a bit scattershot, and all output is transcribed by hand since, for obvious reasons, I'm writing this on a different non-NUC computer I did successfully install Arch on. Any suggestions are appreciated! I'm hoping not to have to get an enclosure and pull the disk out, but at this point I'm out of other ideas.


The only mention of the disk on startup:

[ 5.207911] nvme nvme0: allocated 64 MiB host memory buffer
[ 5.259763]   nvme0n1:
nvme0n1 259:0   0   238.5G  0   disk

Sometimes nvme0n1 does not appear, usually after I've tried something weird. It reappears if I start the NUC without the live USB media and allow Intel Boot Agent to try to run, then restart it with the USB media.


fdisk -l:

Disk /dev/nvme0n1: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x79344dbd

My goal is to have an EFI boot partition in the front of the disk and use the rest for Arch: partition 1 is type 1, 1048575 sectors, and partition 2 takes up the remaining space with whatever type "Linux Filesystem" is. fdisk alerts on write that "Partition #1 contains an NTFS signature. Do you want to remove the signature?". No matter which option I choose, all I get out of it is a blinking cursor for ~10 seconds, followed by the system freezing (I cannot Ctrl-C or open/change sessions with alt+arrow keys and have to hold the physical power button to reboot). It's the same story with parted.

nvme0n1 0x1fe         dos
nvme0n1 0x200         gpt
nvme0n1 0x3b9e655e00  gpt

This seems a little suspicious -- are there multiple partition tables? Possibly overlapping since 1fe is pretty close to 200? What could be going on here?


I've tried zeroing the whole thing out:

dd if=/dev/zero of=/dev/nvme0n1 bs=1M status=progress

It freezes almost immediately, in a fraction of a second.

partprobe -s

/dev/nvme0n1: msdos partitions

I didn't have high hopes for this but figured it'd be worth a shot:

mkfs.ext4 /dev/nvme0n1

/dev/nvme0n1 contains `DOS/MBR boot sector' data. Proceed anyway? (y, N)
[ 622.860132] nvme nvme0: Device not ready; aborting reset
[ 643.466803] nvme nvme0: Device not ready; aborting reset
[ 643.469907] print_req_error: I/O error, dev nvme0n1, sector 0
Warning: could not erase sector 2: invalid argument
Creating filesystem with 62514774 4k blocks and 15630336 inodes
Filesystem UUID: (some UUID)
Superblock backups stored on blocks:
  32768, 98304, 163840, ...

Allocating group tables: done
Warning: could not read block 0: Attempt to read block from filesystem resulted in short read
Warning: could not erase sector 0: No space left on device
mkfs.ext4: Invalid argument while zeroing block 62514752 at end of filesystem
Writing inode tables: done
Creating journal (262144 blocks): mkfs.ext4: Invalid argument
  while trying to create journal
[ 643.546837] nvme nvme0: failed to set APST feature (-19)

In the spirit of "why not?", I tried mounting the disk to see what it'd make of it: "wrong fs type, bad option, bad superblock on /dev/nvme0n1, missing codepage or helper program, or other error."


I noticed something odd flicker by and had to take video to capture this:

  Starting Power-Off...
/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.150 (2018-08-01) and kernel driver (unknown version).
Command failed.
umount: can't unmount /dev/loop0: Invalid argument
umount: can't unmount /oldrun/archiso/cowspace: Invalid argument

Last edited by dmfay (2018-12-12 23:34:38)


#2 2019-01-05 22:41:33

Registered: 2018-11-30
Posts: 2

Re: Filesystem create/modify freezes with an NVMe SSD on an Intel NUC i5

Because somebody will inevitably discover in this thread the only prior example of an issue they're staring down months or years hence: I gave up and replaced the SSD. The new drive works fine, and an enclosure would've cost almost as much so it wasn't worth trying to figure out what was going on with the ADATA.


Board footer

Powered by FluxBB