You are not logged in.

#1 2006-08-03 12:38:35

kriga
Member
Registered: 2005-04-04
Posts: 27

Ugly fonts after Gnome/KDE update [solved]

Just a few minutes ago I've updated my Gnome/KDE packages:

[08/03/06 13:54] starting full system upgrade
[08/03/06 14:01] upgraded kde-common (3.5.3-3 -> 3.5.4-1)
[08/03/06 14:01] upgraded arts (1.5.3-2 -> 1.5.4-1)
[08/03/06 14:01] upgraded libgnomeui (2.14.1-1 -> 2.14.1-2)
[08/03/06 14:01] upgraded gnome-desktop (2.14.2-1 -> 2.14.3-1)
[08/03/06 14:01] upgraded eel (2.14.1-1 -> 2.14.3-1)
[08/03/06 14:02] upgraded gtkhtml (3.10.2-1 -> 3.10.3-1)
[08/03/06 14:02] upgraded libsoup (2.2.93-1 -> 2.2.96-1)
[08/03/06 14:02] installed libldap (2.3.25-2)
[08/03/06 14:02] upgraded evolution-data-server (1.6.2-2 -> 1.6.3-2)
[08/03/06 14:02] upgraded evolution (2.6.2-1 -> 2.6.3-1)
[08/03/06 14:02] upgraded nautilus (2.14.1-2 -> 2.14.3-1)
[08/03/06 14:03] upgraded file-roller (2.14.3-1 -> 2.14.4-1)
[08/03/06 14:03] upgraded gail (1.8.11-1 -> 1.8.11-2)
[08/03/06 14:03] upgraded gnome-menus (2.14.0-1 -> 2.14.3-1)
[08/03/06 14:03] upgraded gnome-terminal (2.14.1-1 -> 2.14.2-1)
[08/03/06 14:03] upgraded jre (1_5_0_07-1 -> 1_5_0_07-2)
[08/03/06 14:03] upgraded kdelibs (3.5.3-3 -> 3.5.4-1)
[08/03/06 14:04] upgraded kdebase (3.5.3-4 -> 3.5.4-2)
[08/03/06 14:04] upgraded openldap (2.3.24-1 -> 2.3.25-1)

I'm normally using Gnome as my DE but after the upgrade I tried to login into KDE using gdm.
Running KDE I had ugly (=unaliased) fonts. After that I switched back to Gnome session and had the same ugly fonts there, too.

The funny thing is that the fonts in gdm are clean and aliased. I've run fc-cache, but it didn't help. I also have restarted X.

Any suggestion?!?

Offline

#2 2006-08-03 12:45:49

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: Ugly fonts after Gnome/KDE update [solved]

Try updating to kdebase 3.5.4-3 and kde-common 3.5.4-2. KDE 3.5.4 sets anti-aliasing to non-KDE applications disabled by default, you have to turn off AA in KDE and turn it on again to get it working. We've updated kde-common to enable AA by default, so this should be fixed now.

Offline

#3 2006-08-03 13:10:36

kriga
Member
Registered: 2005-04-04
Posts: 27

Re: Ugly fonts after Gnome/KDE update [solved]

Thanks, this hint worked!

Offline

#4 2006-08-04 01:16:15

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: Ugly fonts after Gnome/KDE update [solved]

Holy crap, it works!! My Cairo ill has finally come to an end!!

Thank You!!!!

Offline

Board footer

Powered by FluxBB