You are not logged in.

#1 2019-01-06 00:40:31

justdanyul
Member
Registered: 2011-09-29
Posts: 75

[solved] QEMU/KVM guest resolution

Hi everyone,

I'm having some problems with QEMU/KVM, more specifically, I'm struggling getting to set resolutions higher than 1280x768 on the guests. According to https://wiki.archlinux.org/index.php/QEMU#Graphics , I should be able to go far higher, up to 2560x1600 just using the standard graphics devlice. Now, I've tried starting the VM using different vga devices as follows

qemu-system-x86_64 --enable-kvm -m 4096 -vga std -drive file=filesystem,format=raw
qemu-system-x86_64 --enable-kvm -m 4096 -vga qxl -drive file=filesystem,format=raw

and I tried giving more video memory using the following command

qemu-system-x86_64 --enable-kvm -m 4096 -vga qxl -device qxl,vgamem_mb=64 -drive file=filesystem,format=raw

But in all cases, I am limited to 1280x768.  I can see the modules are loaded as they should be on the guest, for example, lsmod on the guest shows the qxl module is loaded in the last two examples. I'm a bit stuck where to go with this at this stage, as it seems all is ok, and the guide insinuates that it is as simple as just using the standard device, with no additional configuration of the standard device.


Unfortunately, it doesn't seem to be the case for me, I'd really welcome any suggestion as to how I could approach this issue?

Last edited by justdanyul (2019-01-06 03:46:58)

Offline

#2 2019-01-06 01:00:12

loqs
Member
Registered: 2014-03-06
Posts: 6,661

Offline

#3 2019-01-06 01:04:17

justdanyul
Member
Registered: 2011-09-29
Posts: 75

Re: [solved] QEMU/KVM guest resolution

Hi, thanks for your answer. 

I believe this is what I'm doing in the third command I posted above. That is, manually giving it more video memory. It doesn't resolve the problem though :-( Also, the fact that the standard driver, with no additional configuration or guest drivers loaded, should give us up to 2560x1600 makes me think something more basic is wrong with my setup. Just not sure where to look. First time I've picked up QEMU.

Thanks again for linking the SE post above though, but I did do a bit of googling before coming here to disturb you, good people :-D

I'm quietly suspecting it got something todo with my nvidia graphics is running the binary, closed source drivers from nvidia.

Last edited by justdanyul (2019-01-06 01:15:55)

Offline

#4 2019-01-06 01:18:18

loqs
Member
Registered: 2014-03-06
Posts: 6,661

Re: [solved] QEMU/KVM guest resolution

I would not have posted the links if I did not read your original post as using ram_size_mb in the third example instead of vgamem_mb but the third example is using vgamem_mb now.

Offline

#5 2019-01-06 01:36:13

justdanyul
Member
Registered: 2011-09-29
Posts: 75

Re: [solved] QEMU/KVM guest resolution

loqs wrote:

I would not have posted the links if I did not read your original post as using ram_size_mb in the third example instead of vgamem_mb but the third example is using vgamem_mb now.

Ah sorry!! My mistake. Your eyes did in fact not deceive you when you read the post at first, I had copy and pasted the wrong command in the third example (I tried quite a few different permutations of the parameters in the SO posts), so I updated it. The one I posted originally literally does nothing (as 64mb is the default for that parameter).

Last edited by justdanyul (2019-01-06 01:37:01)

Offline

#6 2019-01-06 03:46:43

justdanyul
Member
Registered: 2011-09-29
Posts: 75

Re: [solved] QEMU/KVM guest resolution

Hi everyone,  marking this as solved. As it apparently is an issue with the guest OS.

Basically, I tried doing a fresh install of manjaro in a VM and saw the above behavior. I tried creating two other VMs one using Arch+XFCE, and one using ubuntu (just to check) and the two new VMs where fine using the QXL driver with default settings, they both where able to give me higher resolutions straight out of the box.

Offline

Board footer

Powered by FluxBB