You are not logged in.

#1 2019-01-08 04:39:34

rassawyer
Member
From: Pennsylvania, USA
Registered: 2015-03-26
Posts: 20
Website

System hanging, log stopped

Hi all, if this isn't the right forum, tell me.

I have an arch environment, with i3 wm. The machine is a custom built Ryzen 1700x on an Asus ROG Crosshair mobo. I built it a little over a year ago, and have been running the same installation ever since. The entire time that I've had this machine, it has been prone to intermittent hangs. It never does it while in use, but say I'm working in something, and leave for work. When I would come back, it would never wake up. I would have to force it to power off. I mostly just ignored it for awhile; it didn't happen all that often, and even stopped entirely for awhile. However, I recently started digging into it again, and noticed something interesting. The journactl log stops, apparently at the same time that it hangs. Tonight is a good example. I tried to wake it up at about 11:20, EST. When it wouldn't wake up after a few minutes of mouse and keyboard activity, I powered it off, then rebooted. Journactl -b-1 showed that the log from the previous boot ended at Jan 06 01:09:27, with an entry of "systemd[1]: Started cleanup of Temporary Directories". I'm not sure where to go from here, with no real logs of of what happens during or causes the issue.
Full output of journalctl -b-1 is here: Https://ptpb.pw/tj0P

Last edited by rassawyer (2019-01-08 04:40:21)

Offline

#2 2019-01-08 08:39:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,893

Re: System hanging, log stopped

Try updating your UEFI firmware. There are some known issues with a few AGESA versions and newer kernels. You might also want to check and disable/modify idle power saving controls, as that matches with what you're seeing and there are a few threads where changing that helped, see e.g. here

Offline

Board footer

Powered by FluxBB