You are not logged in.

#1 2019-01-11 12:08:39

kurt
Member
Registered: 2009-09-06
Posts: 119

[Solved] Trouble with new install (UEFI & Grub)

below are the commands I have entered to build my system. However on the reboot it goes into GRUB OK and then start a boot. I then get the following:

starting version 240
ERROR: device 'UUID=a5047a18-4d9c-4337-acf0-11b146c16adb' not found. Skipping fsck.
mount: /new_root: can't find UUID=a5047a18-4d9c-4337-acf0-11b146c16adb.
You are nbow being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

But my keyboard doesnt work so all I can do is power off/on.

That UUID refers to /dev/sda2

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

loadkeys uk

Checked ls /sys/firmware/efi/efivars - Its there and has 78 files in it.

ping archlinux.org - Success

timedatectl set-ntp true

fdisk /dev/sda
Command (m for help): g
Command (m for help): n
Partition number (1-128, default 1): <default>
First sector: <default>
Last sector: +550M
Command (m for help): t
Partition type: 1 (EFI System)
Command (m for help): n
Partition number (1-128, default 2): <default>
First sector: <default>
Last sector: <default>
Command (m for help): w

fdisk -l /dev/sda
Device        Size    Type
/dev/sda1    550M    EFI System
/dev/sda2    111.3G    Linux filesystem

mkfs.ext4 /dev/sda2
mkfs.fat -F32 /dev/sda1

mount /dev/sda2 /mnt
mkdir /mnt/home
mount /dev/sdb1 /mnt/home
mkdir /mnt/efi
mount /dev/sda1 /mnt/efi

pacstrap /mnt base base-devel

genfstab -L /mnt >> /mnt/etc/fstab

cat /mnt/etc/fstab
/dev/sda2    /    ext4    rw,relatime    0 1
/dev/sdb1    /home    ext4    rw,relatime    0 2
/dev/sda1    /efi    vfat    rw,relatime,fmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro    0 2

arch-chroot /mnt

ln -sf /usr/share/zoneinfo/Europe/London /etc/localtime

hwclock --systohc

vi /etc/locale.gen - Uncommented en_US.UTF-8 UTF-8 & en_GB.UTF-8 UTF-8
locale-gen

/etc/locale.conf
LANG=en_GB.UTF-8

/etc/vconsole.conf
KEYMAP=uk

/etc/hostname
Desktop-PC

/etc/hosts

127.0.0.1    localhost
::1        localhost
127.0.1.1    Desktop-PC.localdomain    Desktop-PC

mkinitcpio -p linux

passwd

pacman -S grub efibootmgr
grub-install --target=x86_64-efi --efi-directory=/efi --bootloader-id=GRUB
grub-mkconfig -o /boot/grub/grub.cfg

pacman -S intel-ucode
grub-mkconfig -o /boot/grub/grub.cfg

exit

umount -R /mnt

reboot

Last edited by kurt (2019-01-11 14:48:20)

Offline

#2 2019-01-11 12:29:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,277

Re: [Solved] Trouble with new install (UEFI & Grub)

Please use [ code ] tags for pasting command outputs.

Right now is a bit of a turbulent time, as there are several issues with the current version of systemd and how it invokes udev to detect devices, see this thread as well

FWIW something you can try is replacing the udev hook with systemd in your mkinitcpio.conf and regenerating the image. That should help with the currently problematic race condition.

Last edited by V1del (2019-01-11 13:20:53)

Offline

#3 2019-01-11 14:47:49

kurt
Member
Registered: 2009-09-06
Posts: 119

Re: [Solved] Trouble with new install (UEFI & Grub)

V1del wrote:

Please use [ code ] tags for pasting command outputs.

Right now is a bit of a turbulent time, as there are several issues with the current version of systemd and how it invokes udev to detect devices, see this thread as well

FWIW something you can try is replacing the udev hook with systemd in your mkinitcpio.conf and regenerating the image. That should help with the currently problematic race condition.

Apologies for not using tags.

Replacing udev with systemd did the trick. Thanks.

Is it OK to leave it like this?

Offline

#4 2019-01-12 03:49:13

dmartins
Member
Registered: 2006-09-23
Posts: 360

Re: [Solved] Trouble with new install (UEFI & Grub)

Yes, you can continue to use systemd in your initramfs. It is somewhat less well tested than the default setup, but seems to work fine in most cases.
Here's what mkinitcpio currently says about the systemd hook:

$ mkinitcpio -H systemd
==> Help for hook 'systemd':
This will install a basic systemd setup in your initramfs, and is meant to
replace the 'base', 'usr', 'udev' and 'resume' hooks. Other hooks with runtime
components will need to be ported, and will not work as intended. You also may
wish to still include the 'base' hook (before this hook) to ensure that a
rescue shell exists on your initramfs.

With that said, there is a new systemd version 240.34-2 in the testing repo that fixes the problem you had. Once that is moved to the core repo, you could switch back to your previous initramfs settings if you want.

Offline

Board footer

Powered by FluxBB