You are not logged in.

#1 2019-01-11 19:54:27

Registered: 2019-01-11
Posts: 2

[SOLVED]"exit_boot() failed! efi_main() failed!" after switching cable

Today I swapped a monitor cable from a dual-link DVI-I to a DP 1.2 to solve a (presumably unrelated) refresh-rate related issue. On power-up, I got through the systemd-boot screen, but instead of booting it displayed the error:

exit_boot() failed!
efi_main() failed!

This error is repeated every time I try to boot now.

I had an issue with this during the install as well. Booting the live USB produced the same errors. After formatting and remaking the USB, it worked fine-- every other reboot. But it worked well enough to get Arch up and running with KDE. Once the install was complete, I noticed booting off the main drive would produce the same error unless the live USB was unplugged, so I chalked it up to a bad USB drive. Currently I am able to boot from the (very same) live USB, mount the filesystem and chroot in without any difficulty. The strange every-other-boot failure that was happening with the USB before seems to be entirely gone.

I found a similar thread elsewhere that recommended running

uname -r


pacman -Q linux

These are their respective outputs while chrooted in. Could it be a version mismatch?

#uname -r

#pacman -Q linux
linux 4.20.arch1-1

As far as I can tell, there don't seem to be any issues with the fstab.
/dev/sda is partitioned into a main, a 1 GiB swap, and a 300M EFI partition mounted to /mnt/boot. dev/sdb is a single main partition mounted to /home/archv.

Any advice would be greatly appreciated!

Last edited by avionix (2019-01-12 04:08:02)


#2 2019-01-12 04:04:24

Registered: 2019-01-11
Posts: 2

Re: [SOLVED]"exit_boot() failed! efi_main() failed!" after switching cable

After trying quite a few ideas, the solution turned out to be fairly simple.

I unplugged all my non-essential USB devices (i.e. keyboard and mouse). I typically have several devices plugged in at any given time, including a USB sound card, Steam Controller, an old racing wheel, and a webcam. Removing them and the live USB allowed me to boot normally into KDE. From there, I ran

sudo pacman -Syu

to ensure everything was up to date and rebooted. Plugging my USB devices back in doesn't seem to have affected the boot process at all-- it works just as expected.
I suspect the error I experienced is the result of USB devices interfering with the startup process in some way.


Board footer

Powered by FluxBB