You are not logged in.

#1 2006-07-16 03:34:02

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Auto-mounting not working.

Basically when I connect my psp/any usb device, it does not auto connect. Instead, iI have to mount it manually. I have gnome-volume-manager installed and at startup but it doesn't seem to be working. Any ideas ?

I tried running it in terminal and I get this:

(gnome-volume-manager:7546): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

(gnome-volume-manager:7546): Gdk-WARNING **: locale not supported by C library

Offline

#2 2006-07-16 05:09:55

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: Auto-mounting not working.

MasterChief1234 wrote:

Basically when I connect my psp/any usb device, it does not auto connect. Instead, iI have to mount it manually. I have gnome-volume-manager installed and at startup but it doesn't seem to be working. Any ideas ?

I tried running it in terminal and I get this:

(gnome-volume-manager:7546): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

(gnome-volume-manager:7546): Gdk-WARNING **: locale not supported by C library

Did you recently upgrade kernel? Because the new kernel breaks HAL, we'll have to wait for a fix, or downgrade the kernel.

Offline

#3 2006-07-16 14:36:13

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Re: Auto-mounting not working.

Ok, that explains it. I can wait for a fix then. Thank you.

Offline

#4 2006-07-16 16:10:35

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: Auto-mounting not working.

Newer kernel just released...try upgrading.


/path/to/Truth

Offline

#5 2006-08-04 17:57:58

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Re: Auto-mounting not working.

Automounting is still not working...I am using the 2.6.17.7-2 standard arch kernel but it still doesn't work. As a result I can't figure out how to correctly mount my cds and dvds.

Offline

#6 2006-08-04 18:03:30

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,756

Re: Auto-mounting not working.

Are you a member of required groups ?

Fstab correctly set up

dbus hal in rc.conf

psp automount ???? emmm not sure on that one


Mr Green

Offline

#7 2006-08-04 18:18:13

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Re: Auto-mounting not working.

Here's my fstab:

#
# /etc/fstab: static file system information
#
# <file>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

/dev/cdrom             /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd               /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/fd0               /mnt/fl   vfat      user,noauto             0      0

/dev/hda3 / ext3 defaults 0 1
/dev/hda1 /boot ext2 defaults 0 1
/dev/hda2 swap swap defaults 0 0
/dev/hda3 / ext3 defaults 0 1
/dev/hda1 /boot ext2 defaults 0 1
/dev/hda2 swap swap defaults 0 0
/var/lib/pacman.db /var/lib/pacman ext2 loop,defaults 0 0
/var/lib/pacman.img /var/lib/pacman ext2 loop,defaults 0 0

and I just added dbus and hal to the Daemons section in my rc.conf.

Offline

#8 2006-08-04 18:44:19

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Auto-mounting not working.

and I just added dbus and hal to the Daemons section in my rc.conf.

you only need HAL to start, DBus is recommend by Hal.



(gnome-volume-manager:7546): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(gnome-volume-manager:7546): Gdk-WARNING **: locale not supported by C library

Which locale do you use in /etc/locale.gen?

When you not set the locale, then select one in /etc/locale.gen, and after this run "locale-gen" on console


Have you tried to turn it off and on again?

Offline

#9 2006-08-04 18:47:44

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Re: Auto-mounting not working.

I fixed the locale problem (by removing the comments from the locales I wanted to use and then running locale-gen), now I just need to make sure my fstab is setup correctly. Can anyone look at it ?

Offline

#10 2006-08-04 18:58:24

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Auto-mounting not working.

/dev/hda3 / ext3 defaults 0 1
/dev/hda1 /boot ext2 defaults 0 1
/dev/hda2 swap swap defaults 0 0
/dev/hda3 / ext3 defaults 0 1
/dev/hda1 /boot ext2 defaults 0 1
/dev/hda2 swap swap defaults 0 0
/var/lib/pacman.db /var/lib/pacman ext2 loop,defaults 0 0
/var/lib/pacman.img /var/lib/pacman ext2 loop,defaults 0 0

Why you have hda1 and hda2 2 times in fstab?

And swap have no mount point it must look like this

/dev/hda2 none sw 0 0

Have you tried to turn it off and on again?

Offline

#11 2006-08-04 19:09:45

MasterChief1234
Member
Registered: 2006-05-13
Posts: 49

Re: Auto-mounting not working.

Thanks automount now works and thanks for pointing that out in  fstab. I haven't looked at it for a while. I think pacman-drive might have added duplicate entries. I have one problem now, I can't play dvds. I get the message "Do  you have libdvdcss installed ?" I do but I can't play the dvds.

Offline

Board footer

Powered by FluxBB