You are not logged in.

#1 2019-01-11 10:35:24

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

[SOLVED]mount problem because of systemd-240 upgrade

After upgrading from systemd-239 to systemd 240, I can't mount any img or drive in any folder. using mount command.
It only says 'mount failed: Opeation not permitted.'
When I downgraded from systemd-240 to systemd-239, it solved.

Also when I upgrade to systemd-240 through 'pacman -Syyu' every time in last it shows

(7/9) Creating temporary files...
error: command failed to execute correctly

But during systemd-239 installion it doesn't happend.

Screenshots are here:

https://imgur.com/a/8NAmx1Y

Last edited by rizwanhasan (2019-01-12 07:17:47)

Offline

#2 2019-01-11 12:42:51

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 258
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

Change hooks in mkinitcpio.conf to use the systemd hooks and rebuild mkinitcpio


Registered Linux User #544546
   Time you enjoyed wasting was not wasted. --John Lennon.

Offline

#3 2019-01-11 15:24:00

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

how?

Offline

#4 2019-01-11 15:25:30

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,673

Re: [SOLVED]mount problem because of systemd-240 upgrade

Offline

#5 2019-01-11 16:04:11

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

This is my /etc/mkinitcpio.conf

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=()

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

#COMPRESSION="gzip"
COMPRESSION="cat"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

Last edited by rizwanhasan (2019-01-11 16:29:28)

Offline

#6 2019-01-11 16:05:03

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,673

Re: [SOLVED]mount problem because of systemd-240 upgrade

Please edit your post and use [ code ] tags when posting output.

https://wiki.archlinux.org/index.php/Co … s_and_code
https://bbs.archlinux.org/help.php#bbcode

Offline

#7 2019-01-11 16:31:01

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

Edited my post. Now see, my problem is happening only when systemd-240

Offline

#8 2019-01-11 16:34:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,326

Re: [SOLVED]mount problem because of systemd-240 upgrade

Yes we know, it can be fixed even with systemd 240 if you let it handle udev events instead of our default implementation if you replace 'udev' with 'systemd' in your HOOKS line like so:

HOOKS=(base systemd autodetect modconf block filesystems keyboard fsck)

Offline

#9 2019-01-11 16:41:37

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

I tried yours now, no change still same problem. But when I removed autodetect from hook mount problem solved but systemd-240 installation problem is continueing

HOOKS=(base udev modconf block filesystems keyboard fsck)

Last edited by rizwanhasan (2019-01-11 17:37:05)

Offline

#10 2019-01-11 20:08:29

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 258
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

rizwanhasan wrote:

I tried yours now, no change still same problem. But when I removed autodetect from hook mount problem solved but systemd-240 installation problem is continuing

Did you rebuild your initramfs image after editing the HOOKS array ?

If not do as v1del suggests and change udev to systemd in the hooks array, save the /etc/mkinitcpio.conf file.

then

sudo mkinitcpio -p linux

Do same for any other kernels you may have installed IE: linux-ck, linux-zen.linux-lts  etc.

sudo systemctl reboot

Registered Linux User #544546
   Time you enjoyed wasting was not wasted. --John Lennon.

Offline

#11 2019-01-11 20:34:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,326

Re: [SOLVED]mount problem because of systemd-240 upgrade

Hmm on rereading, this reads like an issue already after boot, in which case that should be irrelevant. In this case it might indeed be better to stay on the older version for now, or update to the new version in testing.

Offline

#12 2019-01-11 20:54:00

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

I already did that as you told and also installed testing version of systemd, no change. But I removed autodetect from mkinitcpio.conf and now my mount proboem solved. Thanka for helping guyz.

Offline

#13 2019-01-11 23:29:00

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,673

Re: [SOLVED]mount problem because of systemd-240 upgrade

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Offline

#14 2019-01-12 17:08:32

rizwanhasan
Banned
From: Bangladesh
Registered: 2017-10-30
Posts: 14
Website

Re: [SOLVED]mount problem because of systemd-240 upgrade

Of course smile

Offline

Board footer

Powered by FluxBB