You are not logged in.

#1 2019-01-10 16:14:35

multipitch
Member
From: Dublin, Ireland
Registered: 2013-10-30
Posts: 6

[Solved]Can't boot after install on Hyper-V

I created a new VM in Hyper-V with the following settings:
- name: "arch-vm"
- Generation 2
- Secure boot disabled
- Checkpoints disabled
- 8192 MB RAM
- Dynamic memory disabled
- 4 Virtual Processors
- 60 GB vhdx  virtual hard drive
- archlinux-2019.01.01-x86_64.iso mounted as DVD
- "Default Switch" network adaptor

The installation process didn't throw up anything peculiar, but when I rebooted I got the following message:

Waiting 10 seconds for device /dev/disk/by-partuuid/7bfb61b6-ecbd-4514-82c2-e011b957c055 ...
ERROR: device 'PARTUUID=7bfb61b6-ecbd-4514-82c2-e011b957c055' not found. Skipping fsck.
:: mounting 'PARTUUID=7bfb61b6-ecbd-4514-82c2-e011b957c055' on real root
mount: /new_root: can't find PARTUUID=7bfb61b6-ecbd-4514-82c2-e011b957c055.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off

I tried running from the dvd again and running

# mkinitcpio -p linux

and tried reinstalling systemd and linux.
I tried using GRUB instead and it gave a similar error about not finding the drive.
The PARTUUID is definitely correct (inserted using echo, blkid), and I tried using /dev/sda2 instead, but this didn't work either.
The underlying hard drive is NVMe, so tried adding "nvme" to modules in /etc/mkinitcpio.conf, but this also made no difference.

Any suggestions?

Installation steps:

# loadkeys uk
# ls /sys/firmware/efi/efivars

this returned some files, cofirming EFI boot

# ping 8.8.8.8

this worked - network working OK

# timedatectl set-ntp true
# gdisk /dev/sda

created new GPT partition table

o, y

created 512M EFI partition and use rest of space for main partition

n, (enter), (enter), +512M, ef00
    n, (enter), (enter), (enter), (enter)

wrote changes

w, y

# mkfs.fat -F32 /dev/sda1
# mkfs.ext4 /dev/sda2
# mount /dev/sda2 /mnt
# mkdir /mnt/boot
# mount /dev/sda1 /mnt/boot
# pacstrap /mnt base
# genfstab -U /mnt >> /mnt/etc/fstab
# arch-chroot /mnt

now running in chroot...

# ln -sf /usr/share/zoneinfo/Europe/Dublin /etc/localtime
# hwclock --systohc
# vi /etc/locale.gen

copied the following lines to the top of the list and uncommented them
(everything else remains commented out)
    en_GB.UTF-8 UTF-8
    en_US.UTF-8 UTF-8

# echo LANG=en_GB.UTF-8 > /etc/locale.conf
# echo KEYMAP=uk > /etc/vconsole.conf
# echo arch-vm > /etc/hostname
# nano /etc/hosts

added the following:

127.0.0.1    localhost
::1             localhost
127.0.1.1    arch-vm.localdomain    arch-vm

# nano /etc/systemd/network/20-wired.network

added the following:

[Match]
Name=eth0

[Network]
DHCP=ipv4

# systemctl enable systemd-networkd.service
# systemctl enable systemd-resolved.service
# passwd
# bootctl install
# mkdir /etc/pacman.d/hooks/
# nano /etc/pacman.d/hooks/systemd-boot.hook

inserted the following:

[Trigger]
Type = Package
Operation = Upgrade
Target = systemd

[Action]
Description = Updating systemd-boot
When = PostTransaction
Exec = /usr/bin/bootctl update

# cp /boot/loader/loader.conf /boot/loader/loader.conf.bak
# nano /boot/loader/loader.conf

added the  following:

default arch
timeout 3
editor 0

# nano /boot/loader/entries/arch.conf

added the following (options added later):

title   Arch Linux
linux   /vmlinuz-linux
initrd  /initramfs-linux.img

add options, unmount and shut down:

# echo “options root=PARTUUID=$(blkid -s PARTUUID -o value /dev/sda2) rw” >> /boot/loader/entries/arch.conf
# exit
# umount /dev/sda1
# umount /dev/sda2
# shutdown now

Once shut down, the DVD iso is removed and the VM is restarted. Then the error shown above occurs.

Last edited by multipitch (2019-01-10 20:39:42)

Offline

#2 2019-01-10 17:23:44

teejer
Member
Registered: 2016-11-14
Posts: 9

Re: [Solved]Can't boot after install on Hyper-V

I'm having the same issue on my physical workstation using Systemd-240. It works with systemd-239. Can you try arch-chroot from a live usb and downgrade to 239?

Offline

#3 2019-01-10 18:39:37

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,337

Re: [Solved]Can't boot after install on Hyper-V

Online

#4 2019-01-10 20:37:59

multipitch
Member
From: Dublin, Ireland
Registered: 2013-10-30
Posts: 6

Re: [Solved]Can't boot after install on Hyper-V

Thanks to both of you.
I was driving myself mad thinking I'd screwed something up.
I can confirm that downgrading worked for me.

Offline

#5 2019-01-10 20:39:40

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,652
Website

Re: [Solved]Can't boot after install on Hyper-V

Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#6 2019-01-13 21:04:18

multipitch
Member
From: Dublin, Ireland
Registered: 2013-10-30
Posts: 6

Re: [Solved]Can't boot after install on Hyper-V

The bug is fixed in systemd 240.34-2; upgraded from v239 succesfully.

Offline

Board footer

Powered by FluxBB