You are not logged in.
I installed JupyterLab as follows:
sudo pacman -S jupyterlab
sudo jupyter nbextension enable --py --sys-prefix widgetsnbextension(https://wiki.archlinux.org/index.php/Jupyter)
For my first project I am doing some HTML parsing so I installed some modules via pip:
python3.7 -m pip install --user beautifulsoup4
python3.7 -m pip install --user lxml
python3.7 -m pip install --user html5libAnd wrote away in JupyterLab using BS4 and html5lib in Python 3 (which is the only version of Python detected by JupyterLab on the system despite Python 2 being present - whatever).
Then I wanted to try enable some extensions for JupyterLab as described in https://medium.com/@subpath/jupyter-lab … d97d529fc1
But I can't because when I do:
jupyter labextension install @jupyterlab/latexOR:
jupyter labextension install @mflevine/jupyterlab_htmlI get:
Errored, use --debug for full output:
ValueError: Please install nodejs 5+ and npm before continuing installation. nodejs may be installed using conda or directly from the nodejs website.So I thought "OK I'll install nodejs using pip" and I did:
python3.7 -m pip install --user nodejsBut this installed a waaaaay out of date version and it pulled in something to do with django. So I removed them:
python3.7 -m pip uninstall --user nodejs
python3.7 -m pip uninstall nodejs optional-djangoAnd instead decided to install npm via pacman which brings in nodejs as a dependency:
sudo pacman -S npmAnd retried enabling the extension:
jupyter labextension install @jupyterlab/latexWhich failed again with a different message:
/usr/bin/node: error while loading shared libraries: libicui18n.so.63: cannot open shared object file: No such file or directory
Errored, use --debug for full output:
ValueError: Please install nodejs >=6.11.5 before continuing. nodejs may be installed using conda or directly from the nodejs website.So I checked node:
node --helpBut this wouldn't execute because it couldn't find a shared object file:
node: error while loading shared libraries: libicui18n.so.63: cannot open shared object file: No such file or directoryI figured I could get it by installing lib32-icu package:
sudo pacman -S lib32-icu
sudo find / -name libicui18n.so.63Bingo. Present under `/usr/lib32`. So I ran:
export LD_LIBRARY_PATH=/usr/lib:/usr/lib32And then tried re-running:
jupyter labextension install @jupyterlab/latexWhich gave:
/usr/bin/node: error while loading shared libraries: libicui18n.so.63: wrong ELF class: ELFCLASS32
Errored, use --debug for full output:
ValueError: Please install nodejs >=6.11.5 before continuing. nodejs may be installed using conda or directly from the nodejs website.So I checked node again:
node --helpWhich now gave:
node: error while loading shared libraries: libicui18n.so.63: wrong ELF class: ELFCLASS32So my questions are:
1. how do I resolve the object issue described above?
2. when should I be using pacman and when to use pip? How does the whole conda thing change when to use pacman?
Last edited by miomio (2019-02-04 03:52:13)
Offline
/usr/lib/libicui18n.so.63 is in the core/icu package which should already be installed. You've subsequently installed the lib32-icu 32bit version which is more than likely the reason for your error message. You should install using pacman.
Do you get this...
pacman -Q icu
icu 63.1-2if not, perhaps check with...
pacman -Qkk icuand this...
pacman -Q nodejs
nodejs 11.9.0-1Offline
Yes - that was it. Needed the 64bit package.... duh! I did get another error after running node though, but I needed to update to OpenSSL 1.1.1 and update libnghttp2 from core.
Works now.
Offline
Why are you using update and single packages in the same sentence? You have been told this at least once already, but if your modus operandi is to pick and select single pieces to upgrade you are using the wrong distribution.
You must have your entire system up to date or you are introducing a load of issues similar to what you've seen here.
However if this issue is [SOLVED] please mark it as such by editing the topic title.
Offline