You are not logged in.

#1 2018-10-29 15:34:42

Registered: 2015-07-06
Posts: 4

ITE 8396 touchpad not working

hi everybody.
I got a new notebook Lenovo Ideapad 530S. The touchpad is not working or detected at all.
Notebook has a touchpad button, this button works - when pressed the touchpad enabled/disabled icon is displayed.
I believe the touchpad is ITE 8396 based on contents of /sys/bus/acpi/devices:

ACPI0003:00@  device:09@  device:18@  device:27@    LNXPWRBN:00@  PNP0A08:00@  PNP0C0A:00@
AMDI0010:00@  device:0a@  device:19@  device:28@    LNXSYBUS:00@  PNP0B00:00@  PNP0C0C:00@
AMDI0011:00@  device:0b@  device:1a@  device:29@    LNXSYBUS:01@  PNP0C01:00@  PNP0C0D:00@
AMDI0011:01@  device:0c@  device:1b@  FUJ7401:00@   LNXSYSTM:00@  PNP0C02:00@  PNP0C0F:00@
AMDI0030:00@  device:0d@  device:1c@  ITE8396:00@   LNXVIDEO:00@  PNP0C02:01@  PNP0C0F:01@
CIND0C60:00@  device:0e@  device:1d@  LNXCPU:00@    LNXVIDEO:01@  PNP0C02:02@  PNP0C0F:02@
device:00@    device:0f@  device:1e@  LNXCPU:01@    LNXVIDEO:02@  PNP0C02:03@  PNP0C0F:03@
device:01@    device:10@  device:1f@  LNXCPU:02@    MSFT0001:00@  PNP0C02:04@  PNP0C0F:04@
device:02@    device:11@  device:20@  LNXCPU:03@    MSFT0002:00@  PNP0C02:05@  PNP0C0F:05@
device:03@    device:12@  device:21@  LNXCPU:04@    MSFT0101:00@  PNP0C02:06@  PNP0C0F:06@
device:04@    device:13@  device:22@  LNXCPU:05@    PNP0000:00@   PNP0C02:07@  PNP0C0F:07@
device:05@    device:14@  device:23@  LNXCPU:06@    PNP0100:00@   PNP0C02:08@  PNP0C14:00@
device:06@    device:15@  device:24@  LNXCPU:07@    PNP0103:00@   PNP0C02:09@  VPC2004:00@
device:07@    device:16@  device:25@  LNXPOWER:00@  PNP0200:00@   PNP0C04:00@
device:08@    device:17@  device:26@  LNXPOWER:01@  PNP0800:00@   PNP0C09:00@

Here is the output of dmesg:
and libinput list-devices:

I have tried various tricks:

Add i8042 flags to kernel command line:

i8042.nopnp i8042.noloop i8042.reset=1 i8042.nomux

I have tried several combination with only difference making i8042.nopnp, that removed a warning from dmesg output.

Add acpi_osi flags to kernel command line:

acpi_osi=! acpi_osi='Windows 2012'
acpi_osi=! acpi_osi='Linux'

Setting CONFIG_PINCTRL_AMD=y in kernel configuration (was 'm').

Adding "ITE8396" in device ids in elantech_i2c_core.c.

There are no options about the input devices in BIOS sttings.
I have tried to spam the notebook button while the notebook was starting.

All i have tried has the same result - touchpad is not even listed in libinput.
Thank you very much for you help!


#2 2019-02-07 23:10:02

Registered: 2013-12-21
Posts: 27

Re: ITE 8396 touchpad not working

Same issue here, also Lenovo Ideapad 530S.


#3 2019-02-08 22:19:24

Registered: 2013-12-21
Posts: 27

Re: ITE 8396 touchpad not working

I've opened a bug on the bugzilla:


Board footer

Powered by FluxBB