You are not logged in.

#1 2019-02-08 16:31:37

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

[Solved] Wifi TP-Link TL-WN823N doesn't work

Hi, I'm trying to use my Wlan adapter: TL-WN823N with no luck.
I've tried both in my laptop and in my PC.

1) The adapter seems to be detected:
$lsusb

4 Bus 001 Device 005: ID 2357:0109 TP-Link TL WN823N RTL8192EU

2) The driver seems to be loaded:
$dmesg | grep usbcore

 22 [    0.274361] usbcore: registered new interface driver usbfs
 23 [    0.274361] usbcore: registered new interface driver hub
 24 [    0.274361] usbcore: registered new device driver usb
 25 [    0.396046] usbcore: registered new interface driver usbserial_generic
 26 [    1.554273] usbcore: registered new interface driver usbhid
 27 [    5.879897] usbcore: registered new interface driver snd-usb-audio
 28 [    5.881150] usbcore: registered new interface driver uvcvideo
 29 [    6.790052] usbcore: registered new interface driver rtl8xxxu
 30 [    6.790052] usbcore: registered new interface driver rtl8xxxu

3)After $ip link:

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
      link/ether 1c:1b:0d:52:dd:e8 brd ff:ff:ff:ff:ff:ff
 3: wlp0s20f0u8: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
      link/ether 8e:9c:94:c6:3e:0d brd ff:ff:ff:ff:ff:ff

4)Check kernel messages for the firmware:
$dmesg | grep firmware

[    0.196610] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    3.864926] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    5.814188] usb 1-8: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin

5)Check any messages for the rtl8xxxu
$checkdmesg | grep rtl8xxxu

[    5.814188] usb 1-8: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[    6.790052] usbcore: registered new interface driver rtl8xxxu
[    6.792422] rtl8xxxu 1-8:1.0 wlp0s20f0u8: renamed from wlan0

6)When I try$wifi-menu
The networks are recognized
I chose mine, enter password
And I get:
"CONNECTING FAILED"

I've followed the following post, with the same results:
https://michaelheap.com/tp-link-tl-wn82 … rch-linux/

I've both tried in a clean installation of Arch and in my laptop where I've not installed yet, and can't do it because I don't have a inner card (either for ethernet or wifi)

Thanks!!!

Last edited by manux-chacarita (2019-02-09 11:16:40)

Offline

#2 2019-02-08 17:35:26

seth
Member
Registered: 2012-09-03
Posts: 11,651

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

The behavior is recorded for the chip.
Please do not follow random blog posts, see https://aur.archlinux.org/packages/8192eu-dkms/ and post updated outputs (because after installing 8192eu, rtl8xxxu should no longer show up)

Offline

#3 2019-02-08 21:22:09

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

Thanks for your response.
As you suggested, I've installed 8192eu and this are the outputs,
Please let me know if I'm missing any logs

$ dmesg | grep usbcore

 
[    0.275793] usbcore: registered new interface driver usbfs
[    0.275793] usbcore: registered new interface driver hub
[    0.275793] usbcore: registered new device driver usb
[    0.395704] usbcore: registered new interface driver usbserial_generic
[    1.493812] usbcore: registered new interface driver usbhid
[    5.211821] usbcore: registered new interface driver snd-usb-audio
[    5.213099] usbcore: registered new interface driver uvcvideo
[    6.118633] usbcore: registered new interface driver rtl8xxxu
[    6.133636] usbcore: registered new interface driver rtl8192eu

$ dmesg | grep 8192eu

[    4.800259] usb 1-8: rtl8192eu_parse_efuse: dumping efuse (0x200 bytes):
[    4.800304] usb 1-8: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[    5.779866] 8192eu: loading out-of-tree module taints kernel.
[    5.780135] 8192eu: module verification failed: signature and/or required key missing - tainting kernel
[    5.789584] RTL871X: rtl8192eu v4.4.1_17696.20160509_BTCOEX20160412-0042
[    5.789585] RTL871X: rtl8192eu BT-Coex version = BTCOEX20160412-0042
[    5.789608] usbcore: registered new interface driver rtl8192eu

dmesg | grep xxxu

[    4.800304] usb 1-8:i rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[    5.773741] usbcore: registered new interface driver rtl8xxxu
[    5.792051] rtl8xxxu 1-8:1.0 wlp0s20f0u8: renamed from wlan0

Offline

#4 2019-02-08 21:29:50

seth
Member
Registered: 2012-09-03
Posts: 11,651

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

What happens if you blacklist rtl8xxxu?
https://wiki.archlinux.org/index.php/Ke … acklisting

(To be sure: it still doesn't work, does it?)

Offline

#5 2019-02-08 22:18:25

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

Hi, thank you very much Seth!
It was dead, but after blacklisting the old driver, it started working.

One more thing:
wifi-menu is still not working, I can use it through Network Manager inside my Window Manager.
Any ideas?

(Should I close this post and open a new one with the last question?)

Thanks again!

Offline

#6 2019-02-08 22:23:18

seth
Member
Registered: 2012-09-03
Posts: 11,651

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

From your initial post, something (probably networkmanager?) is bringing the interface up and wifi-menu will refuse to operate it.
Pick and use only one network managing service (in case of wifi-menu it's netctl) per interface.

Offline

#7 2019-02-09 10:33:18

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

Thanks again, yes, I could connect directly after booting through the network manager cli.
Now that I have the solution for the desk pc (ethernet helped me downloading the drivers) I would like to use the same drivers in a new fresh installation on a laptop with no ethernet or wifi card, just USB and the same wlan adapter. Should I remaster the arch iso with the 8192eu drivers before installation?

Offline

#8 2019-02-09 10:45:13

seth
Member
Registered: 2012-09-03
Posts: 11,651

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

You'll have to get the kernel module onto that system - whether you remaster an iso or just usb-walk it over doesn't matter.
Notice that the dkms package will attempt to build the module, what's likely not going to work (I've no idea, but don't think there's a compiler in the iso) - so you have to bring a precompiled module !!!for the kernel version in the iso!!!

If you're facing more issues, you'd better open a new thread on topic.

Offline

#9 2019-02-09 10:45:24

progandy
Member
Registered: 2012-05-17
Posts: 3,404

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

You can remaster it or you could build the module with the same kernel version as the ISO, put the built package on a USB drive and install it on the booted iso.

Edit: As seth said, a dkms won't work of course. Then you'd have to copy and install dkms with all its dependencies as well.

Edit: You could use the dkms package and let it build the module after installing it on the host with the correct kernel version, and then copy it manually to the position in /usr/lib/modules. Then "rmmod" the original module and then load the new one.

Last edited by progandy (2019-02-09 10:53:57)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#10 2019-02-09 10:51:29

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

Thank you guys, as you suggested I will try out and if I have any issues in the process I'll open a new thread.

Offline

#11 2019-02-09 16:17:47

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,621

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

Is tethering a phone by USB an option?  They show up as a wired Ethernet.  Just plug it it, turn on tethering, and run dhcpcd as root.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#12 2019-02-10 21:33:02

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

ewaller wrote:

Is tethering a phone by USB an option?

Hi Ewaller! It's a great option that I haven't thought about before.
I've tried it in my pc with arch installed and it worked perfectly.
When I try in the laptop with the arch ISO:

1) # dhcpcd

dlopen: /usr/lib/dhcpcd/dev/udev.so: cannot read file data: Input/output error
script_runreason: /usr/lib/dhcpcd/dhcpcd-run-hooks: Input/output error
script_runreason: /usr/lib/dhcpcd/dhcpcd-run-hooks: Input/output error
DUID 00:04:5c:46:06:fa:19:2f:45:3a:b2:99:7b:08:8c:63:bb:9b
enp0s20u1: IAID 49:a7:a1:c6
enp0s20u1: soliciting an IPv6 router
enp0s20u1: rebinding lease of 192.168.42.139
enp0s20u1: leased 192.168.42.139 for 3600 seconds
enp0s20u1: adding route to 192.168.42.0/24
enp0s20u1: adding default route via 192.168.42.129
script_runreason: /usr/lib/dhcpcd/dhcpcd-run-hooks: Input/output error
forked to background, child pid 847

2) If I run again dhcpcd:

sending commands to master dhcpcd process

3) ping 8.8.8.8 works fine, same thing with for example archlinux.org ip

4) But when I ping archlinux.org:

ping: archlinux.org: Temporary failure in name resolution

(If I am going out of the thread let me know and I'll do a new post about this issue probably in newbies section)
Thanks!

Last edited by manux-chacarita (2019-02-10 22:22:25)

Offline

#13 2019-02-11 21:23:05

manux-chacarita
Member
Registered: 2019-02-08
Posts: 8

Re: [Solved] Wifi TP-Link TL-WN823N doesn't work

I was missing to add a name server in the /etc/resolv.conf :
For example:

 nameserver 8.8.8.8 

After this I could ping any url.
Thanks again guys!

Offline

Board footer

Powered by FluxBB