You are not logged in.

#1 2019-02-21 15:45:33

StarDino
Member
Registered: 2019-02-21
Posts: 15

[SOLVED] KDE 75Hz screen flicker

Steps to reproduce:

1) Use KDE (Might not work on other DE's)
2) Change refresh-rate from system settings>displays to 75Hz (if you have a monitor that supports it)
3) Obtain screen flickering, I could only fix this by changing it to 50Hz, it won't get fixed when changing to 60Hz (But it still won't flicker if I change from 50 to 60, just if I change to 75 and then from 75 to anything besides 50).

I use DP instead of HDMI, but I don't think that's the problem (It's not, I tried HDMI too).

I don't know how new this problem is, but I just noticed it today.

I have no idea if this is the right place to post this, but I am a newbie.

Last edited by StarDino (2019-02-23 19:28:06)

Offline

#2 2019-02-21 18:52:33

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,155

Re: [SOLVED] KDE 75Hz screen flicker

Which graphics driver are you using? Is Composting enabled?

Offline

#3 2019-02-22 10:55:16

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

I have an AMD RX 550 so I use the AMDGPU driver.

Compositing was enabled. I used the settings Smooth for scale method and OpenGL 2.0 for the rendering backend, I tried switching both the scale method around and the rendering backend (to OpenGL 3.1 and XRender) but it seemed to make no difference.

Edit:

I tried triggering it again, seems removing the ~/.local/share/kscreen folder fixes things on reboot.

This time I made a backup of the file within the folder (since there's just one) to compare one that doesn't have the bug and one that does, I only found 1 difference:

"refresh": 74.97250366210938 (in the one that has the bug)
"refresh": 60 (in the one that doesn't have the bug)

I think this might be caused because I have a FreeSync monitor, so when I switch resolutions it changes the refresh-rate too.

Last edited by StarDino (2019-02-22 11:24:42)

Offline

#4 2019-02-22 11:51:35

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,155

Re: [SOLVED] KDE 75Hz screen flicker

the problem stopped after I made a new user account and switched to it

Yes it does look like problem with your own user settings for your X environment. Do you have an xorg configuration? Perhaps you can create one to dictate the refresh rate. Another alternative is an xrandr startup script to run the correct refresh rate. Or if you use SDDM  you can also use the files in /usr/share/sddm/scripts to set up your refresh rate or other X environment at login.

You can manually run xrandr and try the different refresh rates available for your monitor to see which ones trigger the flickering.

Offline

#5 2019-02-22 11:54:55

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

I tried to change Refresh rate to 74.97 Hz in settings and same problem appears, changing it to 50.00 Hz after that fixes it, but neither 60.00 Hz or 59.94 Hz fix it (although I can switch to them without problems after I used 50.00 Hz once, just not 74.97 Hz)

Here's what my monitor's Hz are for the different settings I don't know if it will be of any importance but I should mention (I have an AOC G2590VXQ monitor 75 Hz)

60.00 Hz in Display settings = 68 H.Frequency in the monitor settings
50.00 Hz in Display settings = 56 H.Frequency in the monitor settings
59.94 Hz in Display settings = 68 H.Frequency in the monitor settings
74.97 Hz in Display settings = 84 H.Frequency in the monitor settings
V.Frequency is always : FreeSync

Last edited by StarDino (2019-02-22 11:55:47)

Offline

#6 2019-02-22 12:03:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,698

Re: [SOLVED] KDE 75Hz screen flicker

There seems to be somewhat of a lack of synchronisation between the kscreen setting and KWin's rendering. It will default to 60Hz and afaik by itself not move above that point, check ~/.config/kwinrc under the [Compositing] tab and check which refresh rate is set in both of these cases,, and whether manually adjusting it to the new 74FPS fixes the flicker

MaxFPS=74
RefreshRate=74

You might also want to post

qdbus org.kde.KWin /KWin supportInformation

from a non-flickering and a flickering run to determine what is the cause here.

Last edited by V1del (2019-02-22 12:07:30)

Offline

#7 2019-02-22 12:06:57

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

Under compositing in kwinrc I just have:

[Compositing]
AnimationSpeed=2
Backend=OpenGL
Enabled=true
GLCore=true
GLPreferBufferSwap=a
GLTextureFilter=1
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=true
XRenderSmoothScale=false

That's it.

And adding RefreshRate there manually appears to not do anything.

Edit:

I used the qdbus org.kde.KWin /KWin supportInformation command like V1del recommended and compared them when it flickers and when it doesn't.

The information files in both situations are identical. (I used > to save the information in both situations, then used meld to compare)

Last edited by StarDino (2019-02-22 12:39:27)

Offline

#8 2019-02-22 12:51:28

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

Output of

xrandr --props

?
You can suspend the compositor altogether (SHIFT+Alt+F12 to toggle) to see whether it's related at all.

Offline

#9 2019-02-22 13:03:30

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

Shift+Alt+F12 didn't do anything to prevent or trigger the problem.

I tried xrandr --props and used the method from before to compare the one where it flickers and where it doesn't and found only 1 difference (I only changed the refresh rate to 74.97 in kscreen, 'kcmshell5 kcm_kscreen'):

Flicker:
1920x1080     60.00 +  74.97*   50.00    59.94

Non-Flicker:
1920x1080     60.00*+  74.97    50.00    59.94

That's the only difference between the 2.

I can post the whole thing if you want, is there a specific way to post logs here?

Edit:

I just realized that the star * moves to whatever refresh you change to, so that's normal, silly me.

Also I tried switching from DP to HDMI and that made no difference, so I switched back to DP.

Last edited by StarDino (2019-02-22 13:53:41)

Offline

#10 2019-02-22 13:56:50

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

The whole thing, either in code tags or eg. pipe it to "curl -F c=@- https://ptpb.pw"
But because I'm stupid, please post "xrandr -q --verbose" instead.

Also, to what resolution do you attempt to change when this happens?

Offline

#11 2019-02-22 14:25:45

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

I used 'xrandr -q --verbose' like you asked:

No flicker
Flicker

I changed resolution to 1024x768, I don't need to change resolution but if I do it changes refresh rate to the highest one available. (75.03 Hz for 1024x768 is highest for me, so when I change resolution to it refresh changes to that and triggers the bug)

From there I can change resolutions all I want it won't fix it, only way is to change refresh-rate to 50.00 Hz, any other and it won't get fixed (afterwards I can change it to 60, or any other besides ones that start with 7, like 74.97 or it'll start again)

Last edited by StarDino (2019-02-22 14:37:03)

Offline

#12 2019-02-22 15:21:44

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

1920x1080@75 would exceed older HDMI standards/cables.
Since your switching around DP and HDMI: is there any kind of adapter involved?

You can btw. select the refresh rate, eg. try to

xrandr --output DisplayPort-0 --mode 1024x768 --rate 60.02
xrandr --output DisplayPort-0 --auto
xrandr --output DisplayPort-0 --mode 1024x768
xrandr --output DisplayPort-0 --mode 1920x1080 --rate 60
xrandr --output DisplayPort-0 --mode 1024x768
xrandr --output DisplayPort-0 --auto

(Do you so far use some GUI to change the resolutions?)

Offline

#13 2019-02-22 15:42:21

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

No adapter, the monitor supports DP, HDMI and D-Sub.

I use KDE's KScreen, it has GUI. (shortcut is 'kcmshell5 kcm_kscreen')

It installed when I installed the plasma group so I use it.

I tried 'xrandr --output DisplayPort-0 --mode 1920x1080 --rate 74' refresh did change to that, the bug was still triggered.

Last edited by StarDino (2019-02-22 15:44:31)

Offline

#14 2019-02-22 15:51:36

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

Yeah, the idea was to *not* explicitly cause that particular mode ;-)

Offline

#15 2019-02-22 16:04:42

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

xrandr --output DisplayPort-0 --mode 1920x1080 --rate 60

is as far as I can go.

xrandr --output DisplayPort-0 --mode 1920x1080 --rate 68

triggers it.

xrandr --output DisplayPort-0 --mode 1920x1080 --rate 54

fixes it, 55 doesn't but I can change to it.

(I can't change to 56,57,58,59.61.62.63,64,65,66,67, monitor doesn't react)

Last edited by StarDino (2019-02-22 16:13:49)

Offline

#16 2019-02-22 16:29:07

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

If you pass random refershrates, it will just pick the closest match.
What I meant by that command list was to see whether going to some specific XGA rate (but avoiding the high rate on FullHD) would cause it and whether the high FullHD rate is auto-chosen or something the kscreen GUI selects.

Offline

#17 2019-02-22 16:48:00

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

1920x1080 is as high as it can go, the rate of 60 is chosen by default, but the monitor itself is supposed to support 75.

kscreen just gives the options for: 60, 59.94, 50, 74.97 at 1080p.

Using the command to change refresh to 68 triggers it (or choosing 74.97 in kscreen).

'xrandr -q --verbose' shows it being switched to:
1920x1080 (0x59) 174.500MHz +HSync -VSync *current

Since this is a problem that's related to the 75 Hz (74.97) refresh-rate, and not resolutions themselves should I change the subject of this topic?

Last edited by StarDino (2019-02-22 17:58:05)

Offline

#18 2019-02-22 23:05:25

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,155

Re: [SOLVED] KDE 75Hz screen flicker

Do you absolutely need the 75Hz refresh rate?

Offline

#19 2019-02-23 10:33:08

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

d_fajardo wrote:

Do you absolutely need the 75Hz refresh rate?

I don't absolutely need the 75Hz refresh rate, same way I don't absolutely need KDE, archlinux, or possibly a computer, but I got and use them because I want to.

Thing is I bought this monitor because it could go to 75Hz and it had FreeSync, and I find it glitches on 75Hz so I'd really want to get it to work somehow.

Offline

#20 2019-02-23 15:16:06

seth
Member
Registered: 2012-09-03
Posts: 20,411

Re: [SOLVED] KDE 75Hz screen flicker

If I understand comment #11 and the update correctly, this also happens for XGA@75Hz (ie. no need to "boost" the pixelclock at FullHD)?
I suspect the issue is rather w/ amdgpu than something in the userspace (or even the ddx driver)

=> Please post a complete dmesg (covering the issue) and to be sure also your xorg log.

Also try the behavior w/
amdgpu.dc=0 amdgpu.audio=0 amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0

This deactivates the (new) display core driver, audio and various powermanagent - in case this "fixes" it, try to isolate the relevant parameter.
https://wiki.archlinux.org/index.php/Ke … le_options

Also please elaborate on the nature of the flicker (or try to catch it on video, if you can)

Offline

#21 2019-02-23 19:26:32

StarDino
Member
Registered: 2019-02-21
Posts: 15

Re: [SOLVED] KDE 75Hz screen flicker

Well, it seems setting

low or high in /sys/class/drm/card0/device/power_dpm_force_performance_level

fixes it, I should've tried the arch's AMDGPU wiki page (although the wiki only mentions frequencies of 120+Hz, not mentioning 75Hz, which is also affected).
Thanks for the replies guys.

Last edited by StarDino (2019-02-23 19:31:55)

Offline

Board footer

Powered by FluxBB