You are not logged in.

#201 2018-12-04 22:41:40

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 279

Re: mesa-git - latest videodrivers & issues

Lone_Wolf wrote:

lmsensors was updated today and apparently had a soname bump.
If you're using my aur *-mesa-git packages  , try rebuilding them.

Incase you're using Lord Heavy's mesa-git repo, you'll have to wait until he rebuilds the packages (or you could try contacting him directly) .

Packages are already rebuilt with new lm_sensors support

Offline

#202 2018-12-05 12:32:25

kaymio
Member
Registered: 2017-01-07
Posts: 26

Re: mesa-git - latest videodrivers & issues

Since a few weeks I'm using Lord Heavys repo, to be able to play Dying Light on Arch, finally! Thank you!

As of November 30th, the repo broke my DE (Cinnamon). SDDM worked, although the user icon was missing. After login cinnamon is stuck in a restart loop. Downgrading mesa-git, llvm-libs-svn and llvm-svn fixed the problem.

Affected versions on my side are

mesa-git-105999.89b4798c06-1 mesa-git-106052.95d62baac5-1

llvm-libs-svn-347971-1 llvm-libs-svn-348278-1

llvm-svn-347971-1-x86_64 llvm-svn-348278-1

cinnamon-session[2916]: WARNING: t+30,89171s: Application 'cinnamon.desktop' failed to register before timeout
cinnamon-session[2916]: CRITICAL: t+30,89191s: We failed, but the fail whale is dead. Sorry....
dbus-daemon[623]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-daemon.service' requested by ':1.101' (uid=1000 pid=3071 comm="/usr/lib/cinnamon-settings-daemon/csd-background ")
/cinnamon-killer-daemon[4359]: Bound Cinnamon restart to <Control><Alt>Escape.

Last edited by kaymio (2018-12-05 12:49:46)

Offline

#203 2018-12-05 12:56:01

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 279

Re: mesa-git - latest videodrivers & issues

kaymio wrote:

Since a few weeks I'm using Lord Heavys repo, to be able to play Dying Light on Arch, finally! Thank you!

As of November 30th, the repo broke my DE (Cinnamon). SDDM worked, although the user icon was missing. After login cinnamon is stuck in a restart loop. Downgrading mesa-git, llvm-libs-svn and llvm-svn fixed the problem.

Affected versions on my side are

mesa-git-105999.89b4798c06-1 mesa-git-106052.95d62baac5-1

llvm-libs-svn-347971-1 llvm-libs-svn-348278-1

llvm-svn-347971-1-x86_64 llvm-svn-348278-1

cinnamon-session[2916]: WARNING: t+30,89171s: Application 'cinnamon.desktop' failed to register before timeout
cinnamon-session[2916]: CRITICAL: t+30,89191s: We failed, but the fail whale is dead. Sorry....
dbus-daemon[623]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-daemon.service' requested by ':1.101' (uid=1000 pid=3071 comm="/usr/lib/cinnamon-settings-daemon/csd-background ")
/cinnamon-killer-daemon[4359]: Bound Cinnamon restart to <Control><Alt>Escape.

You should file a bug upstream at https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa

Offline

#204 2018-12-05 13:40:14

kaymio
Member
Registered: 2017-01-07
Posts: 26

Re: mesa-git - latest videodrivers & issues

Offline

#205 2018-12-14 15:03:29

Laucien
Member
Registered: 2018-09-16
Posts: 5

Re: mesa-git - latest videodrivers & issues

Hello!. Last night I was facing some issues updating my Arch install and took to Reddit to ask for some help -> https://www.reddit.com/r/archlinux/comm … trying_to/

Someone there mentioned that the package I was having issue with -> libdrm-git-6478.ba45adb2-1-x86_64.pkg.tar.xz <- is listed as 0 bites here https://pkgbuild.com/~lcarlier/mesa-git/x86_64/ and that I should say something.

Offline

#206 2018-12-16 08:24:50

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Laucien wrote:

Hello!. Last night I was facing some issues updating my Arch install and took to Reddit to ask for some help -> https://www.reddit.com/r/archlinux/comm … trying_to/

Someone there mentioned that the package I was having issue with -> libdrm-git-6478.ba45adb2-1-x86_64.pkg.tar.xz <- is listed as 0 bites here https://pkgbuild.com/~lcarlier/mesa-git/x86_64/ and that I should say something.

I had to ignore libdrm-git as well. The package is not ok anymore and needs a rebuild.

Offline

#207 2019-03-02 17:31:14

sandy8925
Member
Registered: 2013-06-25
Posts: 22

Re: mesa-git - latest videodrivers & issues

Hello, I'm trying to build mesa-git for development, debugging etc. of Mesa. Is it possible to load the built mesa-git libraries on demand, for example using an environment variable? (I think LD_PRELOAD is the one I need to use but I'm not sure).

Also, in order to build mesa-git, I'll need llvm-svn installed, but I don't want to install it - I want to continue running the stable versions of LLVM and Mesa for normal desktop use, and only load the mesa-git and llvm-svn libraries for applications that I'm testing.

Would I be able to achieve what I want by building llvm-svn in a chroot, and then compiling mesa-git inside that chroot? What if I want to use the compiled mesa libs outside the chroot?

Offline

#208 2019-03-08 12:32:05

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

sandy8925 wrote:

Hello, I'm trying to build mesa-git for development, debugging etc. of Mesa. Is it possible to load the built mesa-git libraries on demand, for example using an environment variable? (I think LD_PRELOAD is the one I need to use but I'm not sure).

No idea, those that want to compare mesa / mesa-git usually setup dedicated environments or switch between them through the package manager (often using a custom script).


At runtime mesa-git (and mesa) don't need a full llvm install, the necessary parts are in llvm-libs / llvm-libs-svn .
(keep in mind aur llvm-libs-svn conflicts with llvm-libs , lordheavy llvm-libs-svn doesn't. see first post of this thread for an overview)


For both implemetations of mesa-git the procedure is similar :

build and install llvm-svn
build mesa-git

If you use the same chroot for both builds that will work fine.
In case you want to use extra-x86_64-build you'll need an additonal step as that removes the chroot after building.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#209 2019-03-09 08:22:23

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Steam doesn't work anymore with mesa-git, it will crash during startup. I had to go back to stable Mesa for now.

$ steam
/home/rainer/.local/share/Steam/steam.sh: Zeile 106: VERSION_ID ist nicht gesetzt.
/home/rainer/.local/share/Steam/steam.sh: Zeile 106: VERSION_ID ist nicht gesetzt.
Running Steam on arch  64-bit
/home/rainer/.local/share/Steam/steam.sh: Zeile 106: VERSION_ID ist nicht gesetzt.
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
[0309/082320.073160:INFO:crash_reporting.cc(242)] Crash reporting enabled for process: browser
[0309/082320.098305:WARNING:crash_reporting.cc(281)] Failed to set crash key: UserID with value: 0
[0309/082320.098369:WARNING:crash_reporting.cc(281)] Failed to set crash key: BuildID with value: 1552112861
[0309/082320.098375:WARNING:crash_reporting.cc(281)] Failed to set crash key: SteamUniverse with value: Public
[0309/082320.098381:WARNING:crash_reporting.cc(281)] Failed to set crash key: Vendor with value: Valve
[0309/082320.106413:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
CApplicationManagerPopulateThread took 27 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
Installing breakpad exception handler for appid(steam)/version(1552114696)
/home/rainer/.local/share/Steam/steam.sh: Zeile 889:  4440 Speicherzugriffsfehler  (Speicherabzug geschrieben) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"

Last edited by raneon (2019-03-10 10:05:20)

Offline

#210 2019-03-09 12:51:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

Did you try with steam-native, raneon ?

Also please use [ code ] tags for such posts, see https://bbs.archlinux.org/help.php#bbcode


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#211 2019-03-10 10:06:09

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Yes, I tried with steam-native too, same issue. Even after resetting Steam.

Update: I did another test and it works now again.

Last edited by raneon (2019-03-10 10:14:54)

Offline

#212 2019-03-10 15:22:16

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Is it possible to use the Vulkan Overlay (hud) already with mesa-git (radv in my case)? I tried it with "VK_INSTANCE_LAYERS=VK_LAYER_MESA_overlay VK_LAYER_MESA_OVERLAY_STATS=submit,draw,pipeline-graphics VK_LAYER_MESA_OVERLAY_POSITION=top-right /path/to/my_vulkan_app" but it didn't work for me.

Offline

#213 2019-03-11 11:04:33

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

from https://gitlab.freedesktop.org/mesa/mes … yer/README

VK_INSTANCE_LAYERS=VK_LAYER_MESA_overlay VK_LAYER_MESA_OVERLAY_CONFIG=help /path/to/my_vulkan_app

What is the output of that ?

Last edited by Lone_Wolf (2019-03-11 11:05:28)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#214 2019-03-11 19:23:21

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Well there is no additional output. But either I do it completely wrong or it is just not supported yet.

$ VK_INSTANCE_LAYERS=VK_LAYER_MESA_overlay VK_LAYER_MESA_OVERLAY_CONFIG=help /usr/bin/vkquake 
Command line: /usr/bin/vkquake
Found SDL version 2.0.9
Detected 16 CPUs.
Quake 1.09 (c) id Software
GLQuake 1.00 (c) id Software
FitzQuake 0.85 (c) John Fitzgibbons
FitzQuake SDL port (c) SleepwalkR, Baker
QuakeSpasm 0.93.0 (c) Ozkan Sezer, Eric Wasylishen & others
vkQuake 1.00.0 (c) Axel Gneiting & others
Host_Init
Playing registered version.
Console initialized.
UDP Initialized
Server using protocol 666 (FitzQuake)
Exe: 15:49:32 Oct  1 2018
256.0 megabyte heap

Vulkan Initialization
Vendor: AMD
Device: AMD RADV unknown (LLVM 9.0.0)
Using VK_KHR_DEDICATED_ALLOCATION
Using A2B10G10R10 color buffer format
Using D32 depth buffer format
Creating command buffers
Initializing staging
Creating descriptor set layouts
Initializing dynamic vertex buffers
Initializing dynamic index buffers
Initializing dynamic uniform buffers
Initializing dynamic uniform buffers
Initializing samplers
Creating pipeline layouts
Using IMMEDIATE present mode
fpCreateSwapchainKHR
Creating color buffer
AA disabled
Creating depth buffer
Creating render passes
Creating frame buffers
Creating pipelines
detected controller: PS3 Controller

Sound Initialization
SDL audio spec  : 44100 Hz, 512 samples, 2 channels
SDL audio driver: pulseaudio - Vega 20 HDMI Audio [Radeon VII] Digital Stereo (HDMI 2), 32768 bytes buffer
Audio: 16 bit, stereo, 44100 Hz
CDAudio disabled at compile time

========= Quake Initialized =========

execing quake.rc
execing default.cfg
execing config.cfg
couldn't exec autoexec.cfg
3 demo(s) in loop
Shutting down SDL sound 

Offline

#215 2019-03-12 12:01:10

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

It should be supported, but I can't find info whether all vulkan apps support it.

If it works it should show an onscreen overlay like in the screenshots in these  phoronix articles[1] .
Maybe someone recognizes the application(s) those screenshots come from ?



https://www.phoronix.com/scan.php?page= … lay-Merged
https://www.phoronix.com/scan.php?page= … y-Dump-FPS


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#216 2019-03-13 18:38:15

raneon
Member
Registered: 2013-11-02
Posts: 40

Re: mesa-git - latest videodrivers & issues

Thanks, I did see the screenshots as well. I tried retroarch and Witcher 3, but had no luck. I still assume I must do something wrong or missed an important step.

Offline

#217 2019-03-27 16:31:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

raneon,

it seems vulkan overlay needs to be enabled at buildtime.
I just enabled it in my aur mesa-git (thanks to Haxk20) , try again with that version.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#218 2019-06-17 19:51:26

CopiousCoffee
Member
From: United Kingdom
Registered: 2016-08-02
Posts: 18

Re: mesa-git - latest videodrivers & issues

Does anyone here own XCOM: Enemy Unknown? The launcher works, just crashes after selecting the game. I ran Steam from a terminal window and this seem to be the culprit: "shadercachemanager/shadercacheimplmesa.cpp (203) : Assertion Failed: Unknown version 0 for Mesa cache entry!". LLVM is 9.0.0 and Mesa is 19.2.0.

I'm guessing this is an upstream issue, wondering if anyone else is getting the same issue? Interestingly, XCOM 2 works fine.

Offline

#219 2019-06-17 20:16:35

gee
Member
Registered: 2006-11-29
Posts: 281

Re: mesa-git - latest videodrivers & issues

I just tried the game and it worked fine.

Offline

#220 2019-06-17 20:17:22

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 279

Re: mesa-git - latest videodrivers & issues

CopiousCoffee wrote:

Does anyone here own XCOM: Enemy Unknown? The launcher works, just crashes after selecting the game. I ran Steam from a terminal window and this seem to be the culprit: "shadercachemanager/shadercacheimplmesa.cpp (203) : Assertion Failed: Unknown version 0 for Mesa cache entry!". LLVM is 9.0.0 and Mesa is 19.2.0.

I'm guessing this is an upstream issue, wondering if anyone else is getting the same issue? Interestingly, XCOM 2 works fine.

It works fine here with a vega64 card. What's your card ?

Offline

#221 2019-06-17 20:18:33

CopiousCoffee
Member
From: United Kingdom
Registered: 2016-08-02
Posts: 18

Re: mesa-git - latest videodrivers & issues

lordheavy wrote:
CopiousCoffee wrote:

Does anyone here own XCOM: Enemy Unknown? The launcher works, just crashes after selecting the game. I ran Steam from a terminal window and this seem to be the culprit: "shadercachemanager/shadercacheimplmesa.cpp (203) : Assertion Failed: Unknown version 0 for Mesa cache entry!". LLVM is 9.0.0 and Mesa is 19.2.0.

I'm guessing this is an upstream issue, wondering if anyone else is getting the same issue? Interestingly, XCOM 2 works fine.

It works fine here with a vega64 card. What's your card ?

Vega56, so must be my system then hmm

Offline

#222 2019-06-18 07:14:58

CopiousCoffee
Member
From: United Kingdom
Registered: 2016-08-02
Posts: 18

Re: mesa-git - latest videodrivers & issues

I've run apitrace on it. Still no idea what it's doing. Checked the files, reinstalled, rebuilt llvm and mesa packages. Nothing. It's borked.

https://dpaste.de/Gsuf/raw

lib32-llvm-libs-minimal-git 9.0.0_r319137.83c7b61052b-1
lib32-llvm-minimal-git 9.0.0_r319137.83c7b61052b-1
lib32-mesa-git 19.2.0_devel.111824.1d75f525891-1
llvm-libs-minimal-git 9.0.0_r319137.83c7b61052b-1
llvm-minimal-git 9.0.0_r319137.83c7b61052b-1
mesa-git 19.2.0_devel.111824.1d75f525891-1

Offline

#223 2019-06-18 11:04:33

gee
Member
Registered: 2006-11-29
Posts: 281

Re: mesa-git - latest videodrivers & issues

Oh I'm not using llvm-minimal but the one from LH's repository, and I assume he is too smile
Maybe that's where the difference is.

I do not use Steam Shaders Cache though, that's another possibility.
You may want to clear it and/or your own.

Last edited by gee (2019-06-18 11:05:43)

Offline

#224 2019-06-18 17:26:17

CopiousCoffee
Member
From: United Kingdom
Registered: 2016-08-02
Posts: 18

Re: mesa-git - latest videodrivers & issues

Ah, I was under the impression that pre-built versions of llvm-svn/git were dead after kerberizer's repo went dark. Didn't even know LH provided llvm-git.

Disabling the shader cache was one of the first things I tried unfortunately, https://i.imgur.com/tF0xEP9.png. I've even cleared the Mesa shader cache. Doesn't like it.

So weird that only XCOM: Enemy Unknown is affected. Everything else runs fine and I have over 300 games. The launcher is fine, but when I click on play the launcher closes and the splash screen goes all flickery.

Offline

#225 2019-06-18 22:30:18

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,045

Re: mesa-git - latest videodrivers & issues

apitrace: warning: unknown function "glCreateDebugObjectMESA"
apitrace: warning: unknown function "glClearDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogLengthMESA"
apitrace: warning: unknown function "glProgramCallbackMESA"
apitrace: warning: unknown function "glGetProgramRegisterfvMESA"
apitrace: warning: unknown function "glEGLImageTargetTexture2DOES"
apitrace: warning: unknown function "glEGLImageTargetRenderbufferStorageOES"
apitrace: warning: unknown function "glCreateDebugObjectMESA"
apitrace: warning: unknown function "glClearDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogLengthMESA"
apitrace: warning: unknown function "glProgramCallbackMESA"
apitrace: warning: unknown function "glGetProgramRegisterfvMESA"
apitrace: warning: unknown function "glEGLImageTargetTexture2DOES"
apitrace: warning: unknown function "glEGLImageTargetRenderbufferStorageOES"
apitrace: warning: unknown function "glCreateDebugObjectMESA"
apitrace: warning: unknown function "glClearDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogLengthMESA"
apitrace: warning: unknown function "glProgramCallbackMESA"
apitrace: warning: unknown function "glGetProgramRegisterfvMESA"
apitrace: warning: unknown function "glEGLImageTargetTexture2DOES"
apitrace: warning: unknown function "glEGLImageTargetRenderbufferStorageOES"
apitrace: warning: unknown function "glCreateDebugObjectMESA"
apitrace: warning: unknown function "glClearDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogMESA"
apitrace: warning: unknown function "glGetDebugLogLengthMESA"
apitrace: warning: unknown function "glProgramCallbackMESA"
apitrace: warning: unknown function "glGetProgramRegisterfvMESA"
apitrace: warning: unknown function "glEGLImageTargetTexture2DOES"
apitrace: warning: unknown function "glEGLImageTargetRenderbufferStorageOES"

Those unknown functions all look like they come from mesa. The apitrace also mentions sdl2 many times.


Check https://wiki.archlinux.org/index.php/St … oting#XCOM
Especially the 2nd issue looks like it may be relevant.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB