You are not logged in.

#1 2019-03-13 17:07:20

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,700
Website

Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

Upon updating chromium 72.0.3626.121-1 -> 73.0.3683.75-1, I am seeing really choppy scrolling via the wheel mouse.  Downgrading back to 72.0.3626.121 restores the smooth scrolling effect I am used to seeing.

Video: GeForce GT 1030 using the nvidia driver version 390.116
DE: xfce4
Xorg log

I didn't see thing via googling specific to this version.  Thoughts are appreciated.

Last edited by graysky (2019-03-15 07:49:40)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2019-03-13 20:46:20

seth
Member
Registered: 2012-09-03
Posts: 10,978

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

Compare "about:gpu" of both versions.

Online

#3 2019-03-13 22:22:53

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,700
Website

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

Didn't see much...
old
new
online diff

EDIT:  Viz Service Display Compositor?

Last edited by graysky (2019-03-13 22:26:57)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#4 2019-03-13 22:31:09

seth
Member
Registered: 2012-09-03
Posts: 10,978

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

chrome://flags/#enable-viz-display-compositor

Online

#5 2019-03-13 22:35:35

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,700
Website

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

seth wrote:

chrome://flags/#enable-viz-display-compositor

Nice!  I disabled it on the new version but still experience the visual artifacts when scrolling.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#6 2019-03-14 08:05:55

seth
Member
Registered: 2012-09-03
Posts: 10,978

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

"via the wheel mouse"
For clarification: this also affects scrolling w/ the scrollbar?

Online

#7 2019-03-14 17:21:03

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,700
Website

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

No, the scroll bar is unaffected as is PgUp and PgDn.  Only the wheel on the mouse.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#8 2019-03-14 20:38:08

seth
Member
Registered: 2012-09-03
Posts: 10,978

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

https://bugzilla.redhat.com/show_bug.cgi?id=1226465 ?

export GDK_CORE_DEVICE_EVENTS=1

Is chrome://flags/#smooth-scrolling enabled or disabled? Does it make a difference?

Online

#9 2019-03-14 20:55:05

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,700
Website

Re: Choppy scrolling with wheel mouse on chromium-73.0.3683.75-1 [SOLVED]

It's set to "default" but if I set it to "disabled" on the latest version of chromium, most if not all of the visual artifacts are gone.  Nice find, thank you.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB