You are not logged in.

#1 2019-03-17 11:56:23

ynuwyytqaw
Member
Registered: 2019-03-17
Posts: 2

[SOLVED] Gnome Shell 3.32 fails to start session due to world clock

After the upgrade to Gnome 3.32, the Gnome Shell session fails to start for both Wayland and X.org. Here is part of the journal:

Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: glamor: No eglstream capable devices found
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: > Warning:          Unsupported high keycode 372 for name <I372> ignored
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: >                   X11 cannot support keycodes above 255.
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: >                   This warning only shows for the first high keycode.
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: > Internal error:   Could not resolve keysym XF86MonBrightnessCycle
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: Errors from xkbcomp are not fatal to the X server
Mar 17 12:27:52 at-spi-bus-launcher[1214]: dbus-daemon[1220]: Activating service name='org.a11y.atspi.Registry' requested by ':1.15' (uid=1000 pid=1938 comm="/usr/bin/gnome-shell ")
Mar 17 12:27:52 at-spi-bus-launcher[1214]: dbus-daemon[1220]: Successfully activated service 'org.a11y.atspi.Registry'
Mar 17 12:27:52 at-spi-bus-launcher[1214]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: Window manager warning: Overwriting existing binding of keysym ff09 with keysym ff09 (keycode 17).
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: Window manager warning: Overwriting existing binding of keysym ff54 with keysym ff54 (keycode 74).
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: Window manager warning: Overwriting existing binding of keysym ff09 with keysym ff09 (keycode 17).
Mar 17 12:27:52 org.gnome.Shell.desktop[1938]: Window manager warning: Overwriting existing binding of keysym ffc7 with keysym ffc7 (keycode 4c).
Mar 17 12:27:53 gnome-shell[1938]: g_callable_info_get_n_args: assertion 'info != NULL' failed
Mar 17 12:27:53 org.gnome.Shell.desktop[1938]: current session already has an ibus-daemon.
Mar 17 12:27:53 gnome-shell[1938]: JS ERROR: TypeError: b.location.get_timezone(...) is null
                                   _clocksChanged/<@resource:///org/gnome/shell/ui/dateMenu.js:127:20
                                   _clocksChanged@resource:///org/gnome/shell/ui/dateMenu.js:125:9
                                   _connectHandler@resource:///org/gnome/shell/misc/util.js:472:9
                                   watchSetting@resource:///org/gnome/shell/misc/util.js:463:9
                                   WorldClocksSection@resource:///org/gnome/shell/ui/dateMenu.js:102:9
                                   _init@resource:///org/gnome/shell/ui/dateMenu.js:530:28
                                   _ensureIndicator@resource:///org/gnome/shell/ui/panel.js:1115:25
                                   _updateBox@resource:///org/gnome/shell/ui/panel.js:1126:29
                                   _updatePanel@resource:///org/gnome/shell/ui/panel.js:1071:9
                                   _init@resource:///org/gnome/shell/ui/panel.js:872:9
                                   _initializeUI@resource:///org/gnome/shell/ui/main.js:175:13
                                   start@resource:///org/gnome/shell/ui/main.js:124:5
                                   @<main>:1:31
Mar 17 12:27:53 gnome-shell[1938]: Execution of main.js threw exception: Script <main> threw an exception
Mar 17 12:27:53 gnome-shell[1938]: Attempting to call back into JSAPI during the sweeping phase of GC. This is most likely caused by not destroying a Clutter actor or Gtk+ widget with ::destroy signals connected,>
Mar 17 12:27:53 org.gnome.Shell.desktop[1938]: == Stack trace for context 0x561ffc0ae300 ==
Mar 17 12:27:53 gnome-shell[1938]: The offending signal was destroy on Gjs_DateMenuButton 0x561ffd4d69a0.
Mar 17 12:27:53 org.gnome.Shell.desktop[1938]: (EE) failed to read Wayland events: Connection reset by peer
Mar 17 12:27:53 gnome-session[1906]: gnome-session-binary[1906]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 17 12:27:53 gnome-session-binary[1906]: Unrecoverable failure in required component org.gnome.Shell.desktop
Mar 17 12:27:53 gnome-session-binary[1906]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 17 12:27:53 at-spi-bus-launcher[1214]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Mar 17 12:27:53 at-spi-bus-launcher[1214]:       after 21 requests (21 known processed) with 0 events remaining.
Mar 17 12:27:53 gdm-password][1890]: pam_unix(gdm-password:session): session closed for user ********
Mar 17 12:27:53 systemd-logind[609]: Failed to restore VT, ignoring: Input/output error
Mar 17 12:27:53 audit[1890]: USER_LOGOUT pid=1890 uid=0 auid=1000 ses=8 msg='uid=1000 exe="/usr/lib/gdm-session-worker" hostname=? addr=? terminal=? res=success'

Last edited by ynuwyytqaw (2019-03-18 08:29:13)

Offline

#2 2019-03-17 15:41:09

alex.shpilkin
Member
Registered: 2018-02-12
Posts: 3

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

Same exception here—and the xkbcomp errors too, surprisingly, since my input setup is rather atypical (three layout plus Japanese via IBus).

Offline

#3 2019-03-17 20:41:18

luca.wehrstedt
Member
Registered: 2018-02-19
Posts: 7

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

I'm hitting the same issue. Did you figure out what's the problem? Did you solve it?

Offline

#4 2019-03-17 20:43:16

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,156
Website

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#5 2019-03-17 21:36:03

luca.wehrstedt
Member
Registered: 2018-02-19
Posts: 7

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

I don't think extensions have anything to do here. The only ones I had were the ones provided by the gnome-shell-extensions package, which got updated to 3.32 as well. Anyways, I removed that package and this problem persisted.

I finally managed to fix it, by realizing that the stack trace of the exception in the logs mentions the "world clock". So I removed all the additional timezones I had registered in the Clocks app (i.e., the ones you access by clicking on the time in the top menu and then in the list of locations beneath the calendar). Once I removed all of them, this issue disappeared.

Offline

#6 2019-03-17 23:41:53

loqs
Member
Registered: 2014-03-06
Posts: 9,247

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

Offline

#7 2019-03-18 08:14:44

ynuwyytqaw
Member
Registered: 2019-03-17
Posts: 2

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

Hello luca.wehrstedt and loqs, Thank you! That did the trick.

To summarise, I ran this command to solve it:

dbus-launch gsettings reset org.gnome.clocks world-clocks

Offline

#8 2019-03-18 16:28:23

iodine
Member
Registered: 2011-09-20
Posts: 16

Re: [SOLVED] Gnome Shell 3.32 fails to start session due to world clock

I tried the above commands, re-installing GNOME etc. nothing worked, until I did

mv ~/.config/dconf/user ~/.config/dconf/user.bak

following this discussion -- https://bbs.archlinux.org/viewtopic.php?id=230145

Please keep in mind that this will reset all your gnome applications settings -- https://wiki.archlinux.org/index.php/GN … figuration

However, at least now I have a usable desktop.

Offline

Board footer

Powered by FluxBB