You are not logged in.

#3451 2019-03-10 16:42:56

sp4ke
Member
Registered: 2016-05-14
Posts: 6

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hi all,

I am having random freezes in linux-ck-haswell in 4.20 and the latest 5 release. I originally thought it was related to my overclocking but it happens even under stock clock. When I launch a cpu stress test it lasts around ~5 min before the freeze happens. Nothing shows on "dmesg -w" nor journalctl.

Also running with stock kernel runs perfectly.

I have to go back to 4.16.10 which has been the only stable ck-haswell for me since months sad.

Any one experiencing random freezes ?
Any way I can see what is the source of the freezes ?

Hardware: 5960x / Asus x99/a-3.1

My kernel params:

 intel_iommu=on scsi_moduse_blk_mq=1 vga=824 nohz_full=4-7,12-15 rcu_nocbs=4-7,12-15 audit=1

EDIT: I will compile back a few versions below to see if I have the same problem and report back.
EDIT2: I had to fallback to 4.16.10-1-ck-haswell all latest ck build from 4.17 and up random total system freezes for me

Last edited by sp4ke (2019-03-18 13:21:10)

Offline

#3452 2019-04-11 07:32:28

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 732

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hello, I'm trying to compile the CK kernel for the first time in order to include a patch for my machine. Everything went well but the produced package is named linux-ck, while I have linux-ck-skylake from the repo installed. I'd like to install the new built package as linux-ck-skylake, to avoid having another kernel installed and to just replace the old one, but I don't know how to do this without recompiling. I tried to change pkgbase to linux-ck-skylake and to repackage but I get this error:

$ makepkg -R
==> Making package: linux-ck-skylake 5.0.5-1 (gio 11 apr 2019 09:20:59 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package_linux-ck-skylake()...
/home/mori/build/linux-ck-skylake/PKGBUILD: line 334: version: No such file or directory
/home/mori/build/linux-ck-skylake/PKGBUILD: line 336: cd: linux-5.0.5: No such file or directory
==> ERROR: A failure occurred in package_linux-ck-skylake().
    Aborting...

Can anybody help me with this? Thanks.

Edit: I solved it, I simply forgot to rename the build directory.

Last edited by snack (2019-04-12 07:54:28)

Offline

Board footer

Powered by FluxBB