You are not logged in.

#1 2008-08-30 13:16:55

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

[Solved] SynCE, sync-engine not found

Today i've found out that there is a tool for Linux that lets me sync with my windows mobile PDA device. I installed synce-kde from Arch community repo but when i start it with 'synce-kpm' there is an error "Sync-engine is NOT running". I couldn't find sync-engine anywhere in repos/AUR and on SynCE webpage it is said that i should start sync-engine with following commands:

If you haven't do so already, please make sure that the sync-engine is running. You can do this by opening up a terminal and start it with:

$ sync-engine

Ubuntu Hardy users should instead execute

$ synce-sync-engine

That gives me nothing else than 'command not found' error. I would appreciate any help in this matter.

Last edited by hash (2008-08-31 19:07:52)

Offline

#2 2008-08-31 17:57:35

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 430

Re: [Solved] SynCE, sync-engine not found

You need to install synce-engine manually as this isn't in the repositories.  I did a full install of synce from source, and built all the necessary packages myself without using anything from the repositories.  My pkgbuild for synce-engine is below.  You can probably change the version information manually to allow for the packages you have installed yourself. iirc librapi and libsynce are prefixed with synce- in the main repositories.

# Contributor Simon Chambers (mail@simonchambers.org)
# Quick build of libsynce-0.11 as not online to get package from repo
pkgname=sync-engine
pkgver=0.12
pkgrel=1
provides=
depends=("libsynce>=0.12" "librapi2>=0.12")
makedepends=('pkgconfig')
arch=('i686')
pkgdesc=("libsynce - A component part of the synce repository")
packager=("Simon Chambers")
source=(http://downloads.sourceforge.net/synce/$pkgname-$pkgver.tar.gz)
url=("http://www.synce.org/")
license=("GPL")

build() {
    cd $startdir/src/$pkgname-$pkgver
    python setup.py build
    sudo python setup.py install
    sudo synce-install-plugins.py
    mkdir -p ~/.synce
    cp -i config/config.xml ~/.synce
    cd ..
}

Offline

#3 2008-08-31 18:00:17

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

SiC wrote:

You need to install synce-engine manually as this isn't in the repositories.  I did a full install of synce from source, and built all the necessary packages myself without using anything from the repositories.  My pkgbuild for synce-engine is below.  You can probably change the version information manually to allow for the packages you have installed yourself. iirc librapi and libsynce are prefixed with synce- in the main repositories.

# Contributor Simon Chambers (mail@simonchambers.org)
# Quick build of libsynce-0.11 as not online to get package from repo
pkgname=sync-engine
pkgver=0.12
pkgrel=1
provides=
depends=("libsynce>=0.12" "librapi2>=0.12")
makedepends=('pkgconfig')
arch=('i686')
pkgdesc=("libsynce - A component part of the synce repository")
packager=("Simon Chambers")
source=(http://downloads.sourceforge.net/synce/$pkgname-$pkgver.tar.gz)
url=("http://www.synce.org/")
license=("GPL")

build() {
    cd $startdir/src/$pkgname-$pkgver
    python setup.py build
    sudo python setup.py install
    sudo synce-install-plugins.py
    mkdir -p ~/.synce
    cp -i config/config.xml ~/.synce
    cd ..
}

Really thanks! smile Gonna try this for sure!

BTW Is there a reason for sync-engine not being in repos? Without this package all of the SynCE apps are useless, so whats the point of keeping them in repos?

EDIT:
IMHO the build function in your PKGBUILD is wrong, because it will install those files and create an empty package (because of using sudo). As a matter of fact i won't be able to ever 'uninstall' those files - only manually selecting each on of them.

I don't know well PKGBUILDs but i would change the build function to sth like this:

build() {
  cd ${startdir}/src/${pkgname}-${pkgver}
  python setup.py build
  python setup.py install --root=$startdir/pkg
  python synce-install-plugins.py
  mkdir -p ~/.synce
  cp -i config/config.xml ~/.synce
  cd ..
}

Last edited by hash (2008-08-31 19:06:27)

Offline

#4 2008-08-31 18:41:46

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 430

Re: [Solved] SynCE, sync-engine not found

I think I just opted to get it working, and have it listed as installed by pacman, I wasn't too bothered whether or not I could uninstall it, so you are right, that pkgbuild isn't the best.  As for why it's not in the repos, I don't know, that was something I was quite curious about too.

Offline

#5 2008-08-31 19:07:38

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

SiC wrote:

I think I just opted to get it working, and have it listed as installed by pacman, I wasn't too bothered whether or not I could uninstall it, so you are right, that pkgbuild isn't the best.  As for why it's not in the repos, I don't know, that was something I was quite curious about too.

But with your help I managed to install sync-engine wink Now it all works! Thanks for help smile

EDIT: Actually to make sync-engine compile there is needed one more library that is not in the repos - librtfcomp. I'll improve PKGBUILDs and will upload both(sync-engine and librtfcomp) to AUR. At least anyone else won't have the same problem tongue

Last edited by hash (2008-08-31 19:19:53)

Offline

#6 2008-08-31 19:23:35

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 430

Re: [Solved] SynCE, sync-engine not found

Cool, glad you got it working, I just hacked it together till I got it to work, I've got a whole bunch of pkgbuilds cos I built everything straight from source....  Really should have uploaded the pkgbuilds to aur... I'll have to owe you a pint.pdf.

Offline

#7 2008-08-31 19:54:14

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

OK. I've uploaded the PKGBUILDs to AUR:

http://aur.archlinux.org/packages.php?ID=19495
http://aur.archlinux.org/packages.php?ID=19496

Maybe someone will enjoy them tongue

Offline

#8 2008-09-02 14:04:00

FenDanT
Member
From: Chamoson- Wallis - Switzerland
Registered: 2007-11-13
Posts: 54

Re: [Solved] SynCE, sync-engine not found

Hey all tongue

Trying to sync my Htc Cruise for such a long time...

Is there a tutorial somewhere or something to help me installing all what is needed to sync ?

Not sure of what is excatly needed for doing it... Softwares, etc...

Quiet difficult to find some infos under Archlinux...

Any help will be appreciated  cool

Offline

#9 2008-09-02 14:10:08

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

Well, I managed to install synce-kde - required the sync-engine (link to PKGBUILD above). Now when i start synce-kpm i get "ActiveSync is running" and it looks like it detects my Mio P560 but still can't sync with it. When i plug in my PDA nothing happens, when i plug it out there is a message "Device disconnected".

Any tutorial would be great tongue

Offline

#10 2008-09-02 14:15:21

FenDanT
Member
From: Chamoson- Wallis - Switzerland
Registered: 2007-11-13
Posts: 54

Re: [Solved] SynCE, sync-engine not found

Hey lol

I have installed that

[jacques@chalet ~]$ yaourt synce
1 community/obby 0.4.4-1       
     A library which provides synced document buffers
2 community/orange 0.3.2-1 [installé]               
     a helper tool for synce                         
3 community/synce-dccm 0.9.1-1                       
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device                                   
4 community/synce-kde 0.12-2 [installé]
     provide a means of communication with a Windows CE device - KDE tools and
     integration
5 community/synce-libmimedir 0.4-1 [installé]
     provide a means of communication with a Windows CE device - library that
     parses MIME Directory Profile.
6 community/synce-librapi 0.12-1 [installé]
     provide a means of communication with a Windows CE device - libraries and
     tools for making remote calls to pocket pc
7 community/synce-libsynce 0.12-1 [installé]
     provide a means of communication with a Windows CE device - libraries
8 community/synce-mcfs 0.1.1-4
     Midnight Commander VFS for SynCE
9 community/synce-odccm 0.12-1
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device
10 community/synce-rra 0.12-1 [installé]
     provide a means of communication with a Windows CE device - rra libraries
     for synce
11 community/synce-serial 0.11-1
     provide a means of communication with a Windows CE device - helper scripts
     for setting up a serial connection
12 community/synce-vdccm 0.10.1-1
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device
13 community/syncekonnector 0.3.2-2
     SynCE KDE integration
14 aur/libopensync-plugin-synce 0.22-1
    SynCE plugin for OpenSync
15 aur/librtfcomp 1.1-1 [installé]
    SynCE librtfcomp library
16 aur/sync-engine 0.12-1 [installé]
    SynCE sync-engine

But ...

[jacques@chalet ~]$ synce-kpm       
Running dataserver                 
Traceback (most recent call last): 
  File "/usr/bin/synce-kpm", line 26, in <module>
    synceKPM.main.main()                         
  File "/usr/lib/python2.5/site-packages/synceKPM/main.py", line 74, in main
    import synceKPM.main_gui                                               
  File "/usr/lib/python2.5/site-packages/synceKPM/main_gui.py", line 6, in <module>                                                                             
    from synceKPM.gui.mainwindow import *                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/gui/mainwindow.py", line 27, in <module>                                                                     
    from pkg_resources import resource_filename                                 
ImportError: No module named pkg_resources                                     
^CTraceback (most recent call last):                                           
  File "/usr/bin/synce-kpm", line 26, in <module>                               
    synceKPM.main.main()                                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/main.py", line 72, in main   
    synceKPM.main_dataserver.main(False)                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/main_dataserver.py", line 55, in main                                                                         
    dataServerEventLoop.run()                                                   
KeyboardInterrupt

May be that lot of things are missing ?

roll

Offline

#11 2008-09-02 14:23:02

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

I've only installed synce-kde + sync-engine (and of course all the dependencies that were installed automatically) and synce-kpm seems to be running without any errors.

That's what i get when i run synce-kpm:

Running dataserver
running the GUI Part
Initializing DataServer
odccm is NOT running!!
Finished with init
pacman -Q | grep sync

sync-engine 0.12-1
synce-kde 0.12-2
synce-libmimedir 0.4-1
synce-librapi 0.12-1
synce-libsynce 0.12-1
synce-rra 0.12-1
synce-serial 0.11-1

Offline

#12 2008-09-02 14:39:17

FenDanT
Member
From: Chamoson- Wallis - Switzerland
Registered: 2007-11-13
Posts: 54

Re: [Solved] SynCE, sync-engine not found

Hey tongue

That's what i have

[jacques@chalet ~]$ pacman -Q | grep sync
sync-engine 0.12-1
synce-dccm 0.9.1-1
synce-kde 0.12-2
synce-libmimedir 0.4-1
synce-librapi 0.12-1
synce-libsynce 0.12-1
synce-rra 0.12-1
synce-serial 0.11-1
syncekonnector 0.3.2-2
[jacques@chalet ~]$

But always the same error as above sad

Offline

#13 2008-10-02 01:28:47

archlinuxsagi
Member
Registered: 2008-09-12
Posts: 259

Re: [Solved] SynCE, sync-engine not found

You will need to install setup-tools


FenDanT wrote:

Hey lol

I have installed that

[jacques@chalet ~]$ yaourt synce
1 community/obby 0.4.4-1       
     A library which provides synced document buffers
2 community/orange 0.3.2-1 [installé]               
     a helper tool for synce                         
3 community/synce-dccm 0.9.1-1                       
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device                                   
4 community/synce-kde 0.12-2 [installé]
     provide a means of communication with a Windows CE device - KDE tools and
     integration
5 community/synce-libmimedir 0.4-1 [installé]
     provide a means of communication with a Windows CE device - library that
     parses MIME Directory Profile.
6 community/synce-librapi 0.12-1 [installé]
     provide a means of communication with a Windows CE device - libraries and
     tools for making remote calls to pocket pc
7 community/synce-libsynce 0.12-1 [installé]
     provide a means of communication with a Windows CE device - libraries
8 community/synce-mcfs 0.1.1-4
     Midnight Commander VFS for SynCE
9 community/synce-odccm 0.12-1
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device
10 community/synce-rra 0.12-1 [installé]
     provide a means of communication with a Windows CE device - rra libraries
     for synce
11 community/synce-serial 0.11-1
     provide a means of communication with a Windows CE device - helper scripts
     for setting up a serial connection
12 community/synce-vdccm 0.10.1-1
     provide a means of communication with a Windows CE device - daemon to
     communicate with a handheld device
13 community/syncekonnector 0.3.2-2
     SynCE KDE integration
14 aur/libopensync-plugin-synce 0.22-1
    SynCE plugin for OpenSync
15 aur/librtfcomp 1.1-1 [installé]
    SynCE librtfcomp library
16 aur/sync-engine 0.12-1 [installé]
    SynCE sync-engine

But ...

[jacques@chalet ~]$ synce-kpm       
Running dataserver                 
Traceback (most recent call last): 
  File "/usr/bin/synce-kpm", line 26, in <module>
    synceKPM.main.main()                         
  File "/usr/lib/python2.5/site-packages/synceKPM/main.py", line 74, in main
    import synceKPM.main_gui                                               
  File "/usr/lib/python2.5/site-packages/synceKPM/main_gui.py", line 6, in <module>                                                                             
    from synceKPM.gui.mainwindow import *                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/gui/mainwindow.py", line 27, in <module>                                                                     
    from pkg_resources import resource_filename                                 
ImportError: No module named pkg_resources                                     
^CTraceback (most recent call last):                                           
  File "/usr/bin/synce-kpm", line 26, in <module>                               
    synceKPM.main.main()                                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/main.py", line 72, in main   
    synceKPM.main_dataserver.main(False)                                       
  File "/usr/lib/python2.5/site-packages/synceKPM/main_dataserver.py", line 55, in main                                                                         
    dataServerEventLoop.run()                                                   
KeyboardInterrupt

May be that lot of things are missing ?

roll

Offline

#14 2008-10-02 01:47:34

archlinuxsagi
Member
Registered: 2008-09-12
Posts: 259

Re: [Solved] SynCE, sync-engine not found

hash wrote:

Well, I managed to install synce-kde - required the sync-engine (link to PKGBUILD above). Now when i start synce-kpm i get "ActiveSync is running" and it looks like it detects my Mio P560 but still can't sync with it. When i plug in my PDA nothing happens, when i plug it out there is a message "Device disconnected".

Any tutorial would be great tongue

Odccm needs to be running and your pocket pc device needs to be using rndis or advance networking.
If everything is ok. You should be see the list of software install in "Software Manager" tab in
synce-kpm.

Opensync is required for syncing.
But i have yet play around enough to do the syncing.

Archlinux developers has stated that opensync latest tools are not stable enough and hence in aur.

http://bbs.archlinux.org/viewtopic.php?id=45683

Offline

#15 2008-10-02 13:12:13

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

Thanks for mentioning the missing dependency (setuptools). I'll add it to PKGBUILD soon.

Later i'll also try to sync my PDA again tongue

Last edited by hash (2008-10-02 13:22:59)

Offline

#16 2008-10-02 13:32:05

archlinuxsagi
Member
Registered: 2008-09-12
Posts: 259

Re: [Solved] SynCE, sync-engine not found

hash wrote:

Thanks for mentioning the missing dependency (setup-tools). I'll add it to PKGBUILD soon.

Later i'll also try to sync my PDA again tongue

Setup-tools should be a dependency of synce-kpm not sync-engine.
I have already e-mail the packager of synce-kpm and file a bug report but
no reply so far.

Please note the important thing is that odccm(synce-odccm) needs to be installed and run
before running synce-kpm.

Usb-dns-lite package isn not required if you have kernel2.6.26.

Mmm. I guess we should start an archlinux wiki on synce. I have search there is none currently.

Last edited by archlinuxsagi (2008-10-02 14:16:16)

Offline

#17 2008-10-02 13:34:37

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

archlinuxsagi wrote:

Setup-tools should be a dependency of synce-kpm not sync-engine.
I have already e-mail the packager of synce-kpm and file a bug report but
no reply so far.

Please note the important thing is that odccm(synce-odccm) needs to be installed and run
before running synce-kpm.

I don't know whether usb-dns-lite package is a requirement as i am currently in not my testing partition.

Mmm. I guess we should start an archlinux wiki on synce. I have search there is none currently.

Well, actually i can't build sync-engine without setuptools, so i guess setuptools are dependency also for sync-engine.

Offline

#18 2008-10-02 14:24:17

archlinuxsagi
Member
Registered: 2008-09-12
Posts: 259

Re: [Solved] SynCE, sync-engine not found

hash wrote:

Well, actually i can't build sync-engine without setuptools, so i guess setuptools are dependency also for sync-engine.

OK. Noted. I guess previous i install setuptools first than synce

Offline

#19 2008-10-02 14:33:13

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

archlinuxsagi wrote:
hash wrote:

Well, actually i can't build sync-engine without setuptools, so i guess setuptools are dependency also for sync-engine.

OK. Noted. I guess previous i install setuptools first than synce

Well, same was for me - that's why i missed this dependency.

Offline

#20 2009-03-27 14:46:07

Kabbone
Member
Registered: 2009-02-06
Posts: 28

Re: [Solved] SynCE, sync-engine not found

I got a problem compiling the librtfcomp package from the AUR

I don't really know what I should do know. Perhaps anyone can help me.

==> Making package: librtfcomp 1.1-3 x86_64 (Fr 27. Mär 15:46:15 CET 2009)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
  -> Found librtfcomp-1.1.tar.gz in build dir
==> Validating source files with md5sums...
    librtfcomp-1.1.tar.gz ... Passed
==> Extracting Sources...
  -> bsdtar -x -f librtfcomp-1.1.tar.gz
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
PKGBUILD: ./configure: /bin/sh: bad interpreter: Permission denied
make: *** No targets specified and no makefile found.  Stop.
==> ERROR: Build Failed.
    Aborting...

Offline

#21 2009-03-27 17:55:33

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

I'm not sure whats causing this error. You could try as a workaround following thing:

Edit the following line in librtfcomp PKGBUILD:

./configure --prefix=/usr

and change it to

sh ./configure --prefix=/usr

Also you might want to check this:
http://helmi-blebe.blogspot.com/2006/11 … ssion.html

Offline

#22 2009-03-27 19:09:14

Kabbone
Member
Registered: 2009-02-06
Posts: 28

Re: [Solved] SynCE, sync-engine not found

Thanks, now I got it big_smile

Your link has solved my problem. The exec option of my home partition was missing in the fstab

Offline

#23 2019-04-15 07:22:38

susskind
Member
Registered: 2015-12-17
Posts: 17

Re: [Solved] SynCE, sync-engine not found

hash wrote:

OK. I've uploaded the PKGBUILDs to AUR:

http://aur.archlinux.org/packages.php?ID=19495
http://aur.archlinux.org/packages.php?ID=19496

Maybe someone will enjoy them tongue

Would it be possible that you reupload this please? It would be very useful I think to have that on AUR

Offline

#24 2019-04-15 11:39:24

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 111

Re: [Solved] SynCE, sync-engine not found

You can take a look here: https://wiki.archlinux.org/index.php/SynCE there are links to up to date aur packages and setup tips.

Offline

#25 2019-04-15 19:42:31

susskind
Member
Registered: 2015-12-17
Posts: 17

Re: [Solved] SynCE, sync-engine not found

Thanks! That's impressive I've got a so fast reply from you 10 years later!

hash wrote:

You can take a look here: https://wiki.archlinux.org/index.php/SynCE there are links to up to date aur packages and setup tips.

I've come from there in fact. The 'synce-sync-engine' on AUR is broken so I was hoping your version were working better.
As noted in the comment section on https://aur.archlinux.org/packages/synce-sync-engine/, I've got this error when launching 'sync-engine':

$ sync-engine
Traceback (most recent call last):
  File "/usr/bin/sync-engine", line 45, in <module>
    import SyncEngine.config as Config
  File "/usr/lib/python2.7/site-packages/SyncEngine/config.py", line 32, in <module>
    from formatapi import SupportedFormats,DefaultFormat
  File "/usr/lib/python2.7/site-packages/SyncEngine/formatapi.py", line 21, in <module>
    import formats
  File "/usr/lib/python2.7/site-packages/SyncEngine/formats/__init__.py", line 21, in <module>
    import parser
  File "/usr/lib/python2.7/site-packages/SyncEngine/formats/parser.py", line 25, in <module>
    import conversions
  File "/usr/lib/python2.7/site-packages/SyncEngine/formats/conversions.py", line 29, in <module>
    import pyrtfcomp
ImportError: No module named pyrtfcomp

Last edited by susskind (2019-04-15 19:43:13)

Offline

Board footer

Powered by FluxBB