You are not logged in.

#1 2019-05-04 23:11:05

dviktor
Member
From: Moscow
Registered: 2015-10-18
Posts: 153

[SOLVED] qt4 package doesn't build properly for some users

Some days ago qt4 was moved from official repository to the AUR (https://aur.archlinux.org/packages/qt4/). However, for some users very strange bug with building exists:

./wtf/TypeTraits.h:186:69: error: ‘std::tr1’ has not been declared
template<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { };
^~~
./wtf/TypeTraits.h:186:74: error: expected ‘{’ before ‘has_trivial_constructor’
template<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { };
^~~~~~~~~~~~~~~~~~~~~~~
./wtf/TypeTraits.h:187:68: error: ‘std::tr1’ has not been declared
template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { };
^~~
./wtf/TypeTraits.h:187:73: error: expected ‘{’ before ‘has_trivial_destructor’
template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { };
^~~~~~~~~~~~~~~~~~~~~~

yarr/YarrInterpreter.cpp: In member function ‘bool JSC::Yarr::Interpreter::backtrackParenthesesOnceEnd(JSC::Yarr::ByteTerm&, JSC::Yarr::Interpreter::DisjunctionContext)’: yarr/YarrInterpreter.cpp:707:13: warning: this statement may fall through [-Wimplicit-fallthrough=] if (backTrack->begin == notFound) { ^~ yarr/YarrInterpreter.cpp:711:9: note: here case QuantifierNonGreedy: ^~~~
make[2]: [Makefile.WebKit:1062: .obj/release-static/YarrInterpreter.o]
Error 1 make[2]: Leaving directory '/home/mickeyrat/builds/qt4/src/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source/JavaScriptCore'
make[1]: [Makefile.WebKit:43: sub-JavaScriptCore-JavaScriptCore-pro-make_default-ordered]
Error 2 make[1]: Leaving directory '/home/mickeyrat/builds/qt4/src/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source'
make: ** [Makefile:747: sub-webkit-make_default-ordered]
Error 2 ==> ERROR: A failure occurred in build(). Aborting...

Seems like this bug is well known for long a long time (one two) and is related to the c++11 standard. As suggested using gnu++98 standard should solve problem. However PKGBUILD for qt4 already have gnu++98 modifications but some users still can't build package properly.

EDIT: seems like building in clean chroot solves the problem. Closed

Last edited by dviktor (2019-05-05 09:19:10)

Offline

#2 2019-05-05 15:30:32

semeion
Member
From: Brazil
Registered: 2008-10-20
Posts: 62

Re: [SOLVED] qt4 package doesn't build properly for some users

Yes, i get same error trying to compile from AUR.

Offline

#3 2019-05-05 15:33:26

dviktor
Member
From: Moscow
Registered: 2015-10-18
Posts: 153

Re: [SOLVED] qt4 package doesn't build properly for some users

Try to build inside clean chroot. Seems it solves the problem

Offline

#4 2019-05-06 05:57:42

waitnsea
Member
From: France
Registered: 2013-02-10
Posts: 37

Re: [SOLVED] qt4 package doesn't build properly for some users

dviktor wrote:

Try to build inside clean chroot. Seems it solves the problem

Hello,
Would you kindly detail ?

Offline

#5 2019-05-06 07:27:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,311

Re: [SOLVED] qt4 package doesn't build properly for some users

Online

#6 2019-05-06 07:51:29

waitnsea
Member
From: France
Registered: 2013-02-10
Posts: 37

Re: [SOLVED] qt4 package doesn't build properly for some users

Thank you V1del - done for me too and I learned  something more

Last edited by waitnsea (2019-05-06 07:51:57)

Offline

Board footer

Powered by FluxBB