You are not logged in.

#1 2006-08-11 16:13:46

From: London
Registered: 2005-09-13
Posts: 123

Sound card changes sometimes upon reboot


Odd problem here.  I have an onboard AC97 card which is disabled in BIOS and a soundblaster card which I use for sound instead of the AC97.  For some reason recently the AC97 card is sometimes used instead of the soundblaster.  I've check my BIOS and this is definatly disabled so I'm at a loss as to why this should happen.

It has been working fine with this set up for over a year and nothing has been changed.  Any pointers would be great.



#2 2006-08-11 16:58:02

Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879

Re: Sound card changes sometimes upon reboot

This is a udev issue.  Newer changes in udev cause device loading to work asyncronously.  Thus, there is no guarentee that one card is loaded before the other.

Personally, when it comes to sound cards, I doubt you need both, so it may be best simply to blacklist the module for the one you do not want.  If you want them both, you can use the wiki trick for network cards, to rename your sound devices and force a certain ordering.  See here: … to-Loading


#3 2006-08-11 17:29:08

Registered: 2006-01-23
Posts: 510

Re: Sound card changes sometimes upon reboot

just load the module for your soundblaster card by adding it at the beginning of the MODULES array in your rc.conf.
this also works for my network card which i use instead of my onboard. smile


Board footer

Powered by FluxBB