You are not logged in.

#1 2019-02-11 16:54:59

egorcod
Member
Registered: 2019-02-11
Posts: 7

Fn+f7 keyboard shortcut

After updating Arch Linux, the fn+f7 keyboard shortcut, which previously switched the screen backlight, does not work. Can I somehow get it back?

Offline

#2 2019-02-12 11:43:24

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 413

Re: Fn+f7 keyboard shortcut

Try installing to linux-lts

Andrew

Offline

#3 2019-02-12 11:58:26

Skunky
Member
Registered: 2018-01-25
Posts: 97

Re: Fn+f7 keyboard shortcut

Which desktop environment you are using?

Offline

#4 2019-02-12 13:32:18

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,676
Website

Re: Fn+f7 keyboard shortcut

Is the key binding not triggering, or is the command itself not working?  What command is that key triggering?  Can you run it manually?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2019-02-12 14:12:33

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

fdservices wrote:

Try installing to linux-lts

Andrew

It not helped.

Offline

#6 2019-02-12 14:13:05

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

Skunky wrote:

Which desktop environment you are using?

Xmonad

Offline

#7 2019-02-12 14:15:30

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

Trilby wrote:

Is the key binding not triggering, or is the command itself not working?  What command is that key triggering?  Can you run it manually?

I think, command is not triggering, because I can create this keybinding in Xmonad. Initially, I don't set any keybinding, and this was working.

Offline

#8 2019-02-12 15:56:16

Skunky
Member
Registered: 2018-01-25
Posts: 97

Re: Fn+f7 keyboard shortcut

What xbindkeys say if you try using Fn+f7?

Last edited by Skunky (2019-02-12 15:56:37)

Offline

#9 2019-02-12 17:05:11

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

Skunky wrote:

What xbindkeys say if you try using Fn+f7?

"Say"? It's "a program that allows to bind commands to certain keys or key combinations on the keyboard."

Offline

#10 2019-02-12 17:53:18

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,676
Website

Re: Fn+f7 keyboard shortcut

I just realized we may all be on the wrong track.  There was no X11 level keybinding, this was a firmware action that has stopped working.  You could add a key binding to Xmonad to run an xbacklight command (or to write directly to the relevant /sys/class/ file) and that would remedy the symptoms quite easily, but if you want to get to the bottom of the change in the default firmware handling of this we need to look in a different direction:

What is the hardware?  When did this key stop working?  Was there a kernel update that changed it?  If so, does downgrading to the previous kernel make it work again?

For future reference, when you are responding to several posts at once, please consolidate your replies into a single post (rather than making many sequential posts).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#11 2019-02-12 18:13:22

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

Trilby wrote:

I just realized we may all be on the wrong track.  There was no X11 level keybinding, this was a firmware action that has stopped working.  You could add a key binding to Xmonad to run an xbacklight command (or to write directly to the relevant /sys/class/ file) and that would remedy the symptoms quite easily

I already did it.

Trilby wrote:

What is the hardware?

Asus X540SA

Trilby wrote:

When did this key stop working?

2019-02-08, seemingly

Trilby wrote:

Was there a kernel update that changed it?

Yes. https://www.archlinux.org/packages/?sor … =&flagged=

Trilby wrote:

If so, does downgrading to the previous kernel make it work again?

I installed LTS, and it not works (it worked previously)

Offline

#12 2019-02-12 18:17:32

Skunky
Member
Registered: 2018-01-25
Posts: 97

Re: Fn+f7 keyboard shortcut

egorcod wrote:
Skunky wrote:

What xbindkeys say if you try using Fn+f7?

"Say"? It's "a program that allows to bind commands to certain keys or key combinations on the keyboard."

You can do

 xbindkeys -k 

and check if the keyboard shortcut is working correctly.
For example Fn+F7 on my laptop equals to

XF86ScreenSaver

Last edited by Skunky (2019-02-13 01:55:00)

Offline

#13 2019-02-12 19:08:02

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,676
Website

Re: Fn+f7 keyboard shortcut

Using an lts kernel is not an ideal test.  Can you get a kernel from your cache and/or the arch archive from before that date and test if using the older kernel is sufficient to restore the behavior?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#14 2019-02-13 13:51:29

egorcod
Member
Registered: 2019-02-11
Posts: 7

Re: Fn+f7 keyboard shortcut

Trilby wrote:

Using an lts kernel is not an ideal test.  Can you get a kernel from your cache and/or the arch archive from before that date and test if using the older kernel is sufficient to restore the behavior?

Switching to 4.19.8 linux and linux-headers fixes this problem. But I don't think it's a good solution

Offline

#15 2019-02-13 14:04:02

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,676
Website

Re: Fn+f7 keyboard shortcut

Nope, it's not a solution, but it's an excellent diagnostic as it confirms that it was a kernel change that affected how the firmware controls are handled.  In otherwords, there's no reason to look into WM settings or xbindkeys information.

I can't dig into it now, but the next step would be to follow up on what changed between the two kernel versions.  With luck the addition of the proper command line parameter to the kernel could get everything back in order.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#16 2019-05-12 23:00:24

Herbalist
Member
Registered: 2014-01-12
Posts: 31

Re: Fn+f7 keyboard shortcut

I was having the same issue, adding 'acpi_backlight=vendor' as a kernel parameter fixed the issue, as suggested by Trilby

Offline

Board footer

Powered by FluxBB