You are not logged in.

#1 2019-05-19 22:05:04

Cinbu
Member
Registered: 2016-12-27
Posts: 29

Laptop can't find bluetooth keyboard

Hi,
I got a new bluetooth keyboard, and while it can be found by my smartphone, and through Windows in my dual boot setup, I can't discover it using bluetoothctl.
I also tried it with graphical bluetooth manager, with a similar result. The bluetooth discovery works otherwise, since bluetoothctl can find my smart phone for example.

I don't have much experience in that area, and the Arch wiki didn't help me further much. Can someone here see a possible problem?

Offline

#2 2019-05-19 23:06:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,557

Re: Laptop can't find bluetooth keyboard

You need to provide a lot more information.

What is your Bluetooth hardware?
Does Bluetooth work at all on your system?  Does it work with other devices?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-05-20 19:14:25

Cinbu
Member
Registered: 2016-12-27
Posts: 29

Re: Laptop can't find bluetooth keyboard

Bluetooth works from both sides. I tried it with my phone. I can connect my laptop with my phone and I can connect the phone with the keyboard.
Yet the laptop can't find the keyboard when scanning. I also checked it with Windows, from where I can connect the laptop with the keyboard.
So I guess it is a software issue.

I tried to figure out what bluetooth hardware I have, but couldn't find it out using lshw or lspci. Maybe I have missed it due to the cryptic name.

When I use dmesg I get this, so it seems bluetooth is working in general:

$dmesg | grep -i bluetooth
[    3.974533] Bluetooth: Core ver 2.22
 [    3.974550] Bluetooth: HCI device and connection manager initialized
 [    3.974553] Bluetooth: HCI socket layer initialized
 [    3.974555] Bluetooth: L2CAP socket layer initialized
 [    3.974558] Bluetooth: SCO socket layer initialized
 [16999.805599] audit: type=1130 audit(1558297307.859:113): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=?  res=success'
 [16999.812324] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
 [16999.812325] Bluetooth: BNEP filters: protocol multicast
 [16999.812328] Bluetooth: BNEP socket layer initialized
 [16999.853859] Bluetooth: RFCOMM TTY layer initialized
 [16999.853865] Bluetooth: RFCOMM socket layer initialized
 [16999.853870] Bluetooth: RFCOMM ver 1.11}}

Offline

#4 2019-05-22 16:15:55

quan2m
Member
Registered: 2012-01-27
Posts: 7

Re: Laptop can't find bluetooth keyboard

Something whacky is going on with post 5.1+ kernels and bluetooth keyboards. I just downgraded for the first time in at 7yrs to fix the bluetooth keyboard problem. 5.0.13 seems to be last kernel that behaves in a sane fashion.

The downgrade tool works very well. Thus far everything seems to be working fine with downgrading just linux and linux-headers

https://wiki.archlinux.org/index.php/do … g_packages

Offline

Board footer

Powered by FluxBB