You are not logged in.

#1 2017-04-04 15:53:23

wenbushi
Member
Registered: 2016-11-10
Posts: 6

[Solved] MT7601U USB Wireless Adapter doesn't work

I installed Arch Linux for my PC a few days ago. The mt7601u usb wireless adapter worked fine during the installation, though with
harmless error  TSSI upper saturation. When the installation was completed(the PC
was forced to shutdown once because of my mistake),  the mt7601u can no longer work either in livecd or newly installed system.

The default mode for mt7601u is not wireless adapter:

lsusb
Bus 001 Device 017: ID 148f:2878 Ralink Technology, Corp.
ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 40:8d:5c:f7:95:f3 brd ff:ff:ff:ff:ff:ff
dmesg
[    6.781661] usb 1-9: device descriptor read/64, error -110
[   22.354966] usb 1-9: device descriptor read/64, error -110
[   22.574846] usb 1-9: new high-speed USB device number 5 using xhci_hcd
[   27.901660] usb 1-9: device descriptor read/64, error -110
[   43.474987] usb 1-9: device descriptor read/64, error -110
[   43.694866] usb 1-9: new high-speed USB device number 6 using xhci_hcd
[   48.908324] usb 1-9: device descriptor read/8, error -110
[   54.241655] usb 1-9: device descriptor read/8, error -110
[   54.461449] usb 1-9: new high-speed USB device number 7 using xhci_hcd
[   59.574988] usb 1-9: device descriptor read/8, error -110
[   64.908321] usb 1-9: device descriptor read/8, error -110
[   65.014753] usb usb1-port9: unable to enumerate USB device

After switching mode:

sudo usb_modeswitch -KW -v 148f -p 2878
lsusb
Bus 001 Device 009: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
lsmod| grep mt7601u
mt7601u                94208  0
mac80211              692224  1 mt7601u
cfg80211              524288  2 mac80211,mt7601u
usbcore               208896  6 usbhid,usb_storage,mt7601u,xhci_pci,uas,xhci_hcd

There is still no wireless interface:

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 40:8d:5c:f7:95:f3 brd ff:ff:ff:ff:ff:ff
dmesg
[  252.213586] usb 1-10: new high-speed USB device number 8 using xhci_hcd
[  252.344913] usb-storage 1-10:1.0: USB Mass Storage device detected
[  252.903169] usb 1-10: USB disconnect, device number 8
[  253.320254] usb 1-10: new high-speed USB device number 9 using xhci_hcd
[  253.657247] usb 1-10: reset high-speed USB device number 9 using xhci_hcd
[  253.790455] mt7601u 1-10:1.0: ASIC revision: 76010001 MAC revision: 76010500
[  253.792933] mt7601u 1-10:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
[  254.106917] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  257.346944] mt7601u 1-10:1.0: Vendor request req:07 off:09a8 failed:-110
[  257.653614] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  257.973636] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  258.293633] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  258.613615] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  258.933580] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  259.253659] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  259.573631] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  259.893642] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  260.213635] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  260.533642] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  260.546916] mt7601u 1-10:1.0: Vendor request req:02 off:09a8 failed:-110
[  263.746938] mt7601u 1-10:1.0: Vendor request req:07 off:0734 failed:-110
[  264.053582] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  264.373645] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  264.693677] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  265.013484] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  265.333624] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  265.653642] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  265.973632] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  266.293636] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  266.613491] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  266.933626] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  266.946893] mt7601u 1-10:1.0: Vendor request req:42 off:0230 failed:-110
[  270.146941] mt7601u 1-10:1.0: Vendor request req:07 off:0080 failed:-110
[  270.453588] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  270.773590] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  271.093431] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  271.413453] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  271.733676] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  272.053618] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  272.373632] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  272.693666] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  273.013603] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  273.333578] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  273.346885] mt7601u 1-10:1.0: Vendor request req:02 off:0080 failed:-110
[  273.653630] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  273.973632] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  274.293628] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  274.613457] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  274.933550] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  275.253633] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  275.573684] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  275.893444] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  276.216923] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  276.533587] xhci_hcd 0000:00:14.0: WARN: unexpected TRB Type 4
[  276.546913] mt7601u 1-10:1.0: Vendor request req:02 off:0080 failed:-110
[  276.546972] mt7601u: probe of 1-10:1.0 failed with error -110
[  276.547024] usbcore: registered new interface driver mt7601u

Can anyone help me to figure it out or offer some suggestions? Thank you very much.

Last edited by wenbushi (2019-05-28 08:11:25)

Offline

#2 2019-05-28 08:10:11

wenbushi
Member
Registered: 2016-11-10
Posts: 6

Re: [Solved] MT7601U USB Wireless Adapter doesn't work

It turns out to be a driver problem. I've found a solution to rebuild the driver at https://bugs.launchpad.net/ubuntu/+sour … ug/1716301.

Full steps:

1. Download the driver codes from kernel.org.
2. Rebuild the driver with mcu.patch provided by comment #53

cd drivers/net/wireless/mediatek/mt7601u
patch -p0 < mcu.patch
make -C /lib/modules/$(uname -r)/build/ M=$(pwd) modules

3. Insert the device to load dependent modules.
4. Remove the device along with the original driver:

sudo rmmod mt7601u

5. Reload the new driver:

sudo insmod ./mt7601u.ko vnd_reset=0

6. Insert the device.

Now the device works well.

Last edited by wenbushi (2019-05-28 08:15:16)

Offline

Board footer

Powered by FluxBB