You are not logged in.

#1 2019-04-19 07:32:12

steoguitar
Member
Registered: 2015-04-23
Posts: 46

Headphone and pc speaker volume are inverted

Hi, when i turn on the pc, volume is always muted.
So I have to open alsa mixer and then I have to increase HEADPHONES volume even if no headphone are plugged in.
If I plug in some headphones or external speaker there is no problems because pc speaker volume is not muted.
So the headphone channel and pc speaker are inverted.

how can i fix?
if there is no fix, is there a way to automatically unmute headphone volume at boot?

Last edited by steoguitar (2019-04-19 10:02:28)

Offline

#2 2019-05-19 07:07:42

cowile
Member
Registered: 2019-05-01
Posts: 15

Re: Headphone and pc speaker volume are inverted

First guess: Run alsamixer. See if a category called "Auto-Mute Mode" is enabled. If it is, use the arrow keys to navigate to it and press down arrow to disable. Your sound should no longer be muted at boot.

If that doesn't work, I need more information. Post the output of the following command:

amixer

The Linux motto is "Laugh in the face of danger." Oops, wrong one. "Do it yourself." Yes, that's it. -- Linus Torvalds

Offline

#3 2019-05-29 16:08:54

steoguitar
Member
Registered: 2015-04-23
Posts: 46

Re: Headphone and pc speaker volume are inverted

Hi, here is my amixer output

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 61870 [94%] [on]
  Front Right: Playback 61870 [94%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 44647 [68%] [on]
  Front Right: Capture 44647 [68%] [on]

Offline

#4 2019-05-29 17:55:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,805

Re: Headphone and pc speaker volume are inverted

That's the virtual pulseaudio mixer, quite useless for debugging most of these hardware related issues, use

amixer -c0 #Or whatever the correct card index is, check aplay -l

Offline

#5 2019-06-01 07:21:31

steoguitar
Member
Registered: 2015-04-23
Posts: 46

Re: Headphone and pc speaker volume are inverted

I used that command. Previously I set Headphone volume up to listen some music so here is the output:

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 110 [87%] [-12.75dB] [on]
  Front Right: Playback 110 [87%] [-12.75dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 3
  Mono: Playback 1 [33%] [-12.00dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 62 [52%] [1.00dB]
  Front Right: Capture 62 [52%] [1.00dB]
Simple mixer control 'Internal Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 [67%] [20.00dB]
  Front Right: 2 [67%] [20.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

I don't know how to unmute at boot headphone volume. Even if the best solution should be to let the system recognize correctly the channel (why speaker and headphone are inverted?)

Offline

#6 2019-06-01 07:28:37

Ropid
Member
Registered: 2015-03-09
Posts: 608

Re: Headphone and pc speaker volume are inverted

Your hardware has that "Auto Mute Mode" thing that was mentioned. Select that setting in alsamixer and change it to "Disabled".

When you start alsamixer, you probably first see just a volume control and nothing else. At that point, press the F6 key to switch devices to your motherboard's hardware and then you will find that "Auto Mute Mode" setting.

Offline

#7 2019-06-01 07:47:23

steoguitar
Member
Registered: 2015-04-23
Posts: 46

Re: Headphone and pc speaker volume are inverted

Ropid wrote:

Your hardware has that "Auto Mute Mode" thing that was mentioned. Select that setting in alsamixer and change it to "Disabled".

When you start alsamixer, you probably first see just a volume control and nothing else. At that point, press the F6 key to switch devices to your motherboard's hardware and then you will find that "Auto Mute Mode" setting.

Yes, I have always to select sound card by tapping F6. I already set unmute to disabled but at boot Headphone volume is muted.
Senzanome.png

Offline

Board footer

Powered by FluxBB