You are not logged in.

#1 2019-06-12 07:06:12

localhorst
Member
Registered: 2019-06-12
Posts: 4

[DE] IWLWIFI verbraucht sehr viel Strom

Hallo, ich habe vor ca. 3 Monaten Arch Linux auf meinen HP Laptop installiert. Anfangs alles gut doch nun schaute ich in Powertop und sah, dass iwlwifi sehr viel Strom benötigt:

Ausgabe von Powertop

5.09 W      3,7 pkts/s                Device         Network interface: wlo1 (iwlwifi)

Die Restlaufzeit beträgt nun auch "nur" noch 6 Stunden, vorher waren es 16 Stunden. Ich habe versucht linux, linux-headers, systemd und linux-firmware per downgrade zurückzuinstallieren, doch das brachte keinen Erfolg.

Das gleiche Problem (ath5k) habe ich auf meinem ASUS Laptop, dort gibt powertop mittlerweile 20 Watt an für die WLAN-Karte. Wenn ich beim ASUS per modprobe -r ath5k beende und neu lade klappt es danach etwas besser mit so 5 Watt Verbrauch, was aber auch nicht gerade gut ist finde ich.

Weiß zufällig jemand jemand einen Tipp?

Danke, Gruß Tommy

Offline

#2 2019-06-12 10:25:26

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,992
Website

Re: [DE] IWLWIFI verbraucht sehr viel Strom


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#3 2019-06-12 15:55:20

localhorst
Member
Registered: 2019-06-12
Posts: 4

Re: [DE] IWLWIFI verbraucht sehr viel Strom

Hallo und danke für die Antwort, leider hat das nichts gebracht. Powertop gibt nun für noch mehr Geräte hohe Leistungen aus:

Gesch. Leistung              Auslastung       Ereignisse/s    Kategorie       Beschreibung
  8.66 W      0,0 pkts/s                Device         Netzwerkschnittstelle: enp2s0 (r8169)
  6.34 W     61,0%                      Device         Display backlight
  4.44 W    100,0%                      Device         USB-Gerät: 2.4G Keyboard Mouse (MOSART Semi.)
  4.16 W      5,2 pkts/s                Device         Netzwerkschnittstelle: wlp3s0 (ath9k)
  2.19 W    100,0%                      Device         Funk-Gerät:btusb

Es gibt sogar die LAN-Karte aus obwohl diese nichtmal angeschlossen ist. Entweder spinnt Powertop oder irgendwas läuft hier falsch bei meinem Arch.

Ich werde wohl mal neu installieren und dann mal schauen. sad

Last edited by localhorst (2019-06-12 15:56:30)

Offline

#4 2019-06-12 16:36:26

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 513
Website

Re: [DE] IWLWIFI verbraucht sehr viel Strom

localhorst wrote:

Ich werde wohl mal neu installieren und dann mal schauen. sad

Das wäre nun wirklich unsinnig.
Versuch doch erst Mal den LTS Kernel.

Last edited by schard (2019-06-12 16:36:43)

Offline

#5 2019-06-13 03:12:23

localhorst
Member
Registered: 2019-06-12
Posts: 4

Re: [DE] IWLWIFI verbraucht sehr viel Strom

Ich habe bei beiden Laptops den LTS Kernel installiert, kein Erfolg iwlwifi liegt immernoch bei 5 - 8 Watt schwankend.

Offline

#6 2019-06-13 11:52:14

localhorst
Member
Registered: 2019-06-12
Posts: 4

Re: [DE] IWLWIFI verbraucht sehr viel Strom

Ich glaube den Schuldigen gefunden zu haben. Das Modul r8169 hat irgendwie quer geschossen, ständig war ein Verbrauch von 8 Watt oder mehr angezeigt worden, auch wenn gar kein Netzwerkkabel angeschlossen war. Habe nun r8169 auf die Blacklist gesetzt und siehe da es kehrt wieder etwas mehr Ruhe ein. 12 Stunden Akkulaufleistung, das ist zwar nicht das was ich anfangs hatte aber einigermaßen akzeptabel erstmal. Nur weiß ich wirklich nicht wieso iwlwifi ständig bei 8 Watt hängt obwohl wlo1 nur 1.3 mW anzeigt. Was steckt denn noch in dem iwlwifi mit drin?

Offline

Board footer

Powered by FluxBB