You are not logged in.

#1 2019-06-16 02:49:20

Maerman
Member
Registered: 2019-05-25
Posts: 7

[Solved]KDE Plasma full notifications applet not working

So since the recent update to KDE Plasma 5.16, my full notifications applet displays only the following error message:

Error loading QML file: file:///home/[my_username]/.local/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/main.qml:29:1: module "org.kde.plasma.private.notifications" version 1.0 is not installed

I tried installing full notifications as a separate widget, but that didn't work. I also tried reinstalling plasma-desktop and all its dependencies, but it didn't work.

I also searched the repos and the AUR for that missing module in the error message, but I didn't get any hits that jumped out at me as being necessary.

I probably just need to install some package, but I can't figure out which one it is.

Any help would be greatly appreciated; thanks in advance.

Last edited by Maerman (2019-06-17 03:43:20)

Offline

#2 2019-06-16 06:58:13

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,624

Re: [Solved]KDE Plasma full notifications applet not working

That QML module no longer exists, so the "full notifications applet" (whatever that is) will need to be ported

Offline

#3 2019-06-16 07:54:20

Maerman
Member
Registered: 2019-05-25
Posts: 7

Re: [Solved]KDE Plasma full notifications applet not working

arojas wrote:

That QML module no longer exists, so the "full notifications applet" (whatever that is) will need to be ported

I don't know how to do this; could you point me in the right direction?

Offline

#4 2019-06-16 09:00:48

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,624

Re: [Solved]KDE Plasma full notifications applet not working

Report this to the author of "full notifications applet" (since you installed it, I assume you know where it comes from)

Offline

#5 2019-06-16 10:55:30

Maerman
Member
Registered: 2019-05-25
Posts: 7

Re: [Solved]KDE Plasma full notifications applet not working

arojas wrote:

Report this to the author of "full notifications applet" (since you installed it, I assume you know where it comes from)

See, that's the thing. I did not install it; it came as the default notification applet with the system tray in Plasma 5.16 (before that it was just called "notifications"). I did not change anything from the default settings, and I did not uninstall anything. Also, the fact that I cannot find anybody else on the internet reporting the same issue indicates to me that I must have done something wrong, rather than this being an issue that stems from the developers.

Offline

#6 2019-06-16 11:08:19

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,624

Re: [Solved]KDE Plasma full notifications applet not working

Maerman wrote:

Error loading QML file: file:///home/[my_username]/.local/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/main.qml:29:1: module "org.kde.plasma.private.notifications" version 1.0 is not installed

It is in your home dir so yes, you installed it, intentionally or not. Plasma 5.16 (or anything else from the Arch repos for that matter) is never going to install anything in your home.

Offline

#7 2019-06-17 03:44:58

Maerman
Member
Registered: 2019-05-25
Posts: 7

Re: [Solved]KDE Plasma full notifications applet not working

It just solved itself. I have no idea what just happened, but my notifications are displaying as they should once more. I marked the post as solved; I just wish I knew what happened. Thanks, anyway.

Offline

#8 2019-06-19 09:20:43

wa1demar
Member
Registered: 2013-07-09
Posts: 6

Re: [Solved]KDE Plasma full notifications applet not working

Not working for me yet((

Offline

#9 2019-06-22 16:38:34

hurradiegams
Member
From: Salzburg
Registered: 2013-10-22
Posts: 2

Re: [Solved]KDE Plasma full notifications applet not working

wa1demar wrote:

Not working for me yet((

What worked for me:
I've deleted the folder ~/.local/share/plasma/plasmoids/org.kde.plasma.notifications/
After a reboot eg. relogin everything works as expected.

Offline

#10 2019-06-25 08:39:39

wa1demar
Member
Registered: 2013-07-09
Posts: 6

Re: [Solved]KDE Plasma full notifications applet not working

hurradiegams wrote:

What worked for me:
I've deleted the folder ~/.local/share/plasma/plasmoids/org.kde.plasma.notifications/
After a reboot eg. relogin everything works as expected.

Yippee!! Thanks a lot!! That's helped

Offline

Board footer

Powered by FluxBB