You are not logged in.

#1 2019-06-17 19:41:19

Registered: 2018-05-07
Posts: 5

Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

I'm trying to install arch from a live usb key on a dell optiplex, and during the boot sequence the screen becomes scrambled ( right after "Triggering uevents...".  Before that (including during the boot selection menu) everything looks fine (as you can see at the top of the screen on the image).  Afterwards, a few lines of pixels of different colors are printed and then it looks like each single line of text printed thereafter is wrapped many times around, one row of pixels at a time, which makes me suspect that there's some mismatch between the resolution the card is putting out and what the display things is happening.  Every new TTY I open with Ctrl-Alt-3 looks like this.  The system is still responsive and when I go to reboot, I see the green "OK" (just smeared over many lines).

I have a 4k dell display plugged via displayport into an NVIDIA RTX5000 card.  There's some kind of intel graphics on the motherboard but it only connects via VGA and I don't have a VGA compatible display handy (or a converter) so I'm hoping someone here has a suggestion for what's going on and whether it's fixable.

moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by 2ManyDogs (2019-06-17 22:40:32)


#2 2019-06-17 20:29:34

From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,588

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

No solution to the problem, but a suggestion on how to investigate further......   
I suggest you ssh into the box.  I don't recall if it is enabled by default on the install media, but sshd will allow you to connect.  You may have to start it by hand by typing blind.  If you connect it to a router, wired Ethernet will connect automatically and obtain a dynamic address.   You will need to figure out the address of the box by probing or looking at the router logs.

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
How to Ask Questions the Smart Way


#3 2019-06-17 21:45:19

Registered: 2012-05-17
Posts: 4,041

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

"Triggering uevents", maybe this results in loading the nouveau graphics driver or changing the graphics mode and that may cause problems with that card. You can try to disable modesetting during the installation process and then use the proprietary nvidia driver later (reenable modesetting) … odesetting

Last edited by progandy (2019-06-17 21:47:43)

| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |


#4 2019-06-26 09:47:07

Registered: 2019-06-26
Posts: 1

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

You are not the only one with this issue, im having this as well on a 2080ti, and im not sure why, for me atleast it happens after uevnts has been triggered … eight=1400


#5 2019-07-28 08:04:13

Registered: 2019-07-28
Posts: 1

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

hi, i have the same problem.
in my case it startet as i updatet my cpu from amd 1800x to amd 3800x.
i also have an rtx 2080, but before the cpu upgrade the iso bootet just fine,
and i also tryed to boot a custom arch-iso with the nvidia(430) driver, wih the same results.

just for info my system specs:

mainboard: asus prime 570-p (newest bios)
cpu: amd 3800x
ram: 32GB
grafik: geforce rtx 2080


after consolting the wiki a bit more, i got it work with the "nomodeset" parameter roll .

Last edited by dikiy4eburator (2019-07-28 08:37:52)


#6 2019-08-22 11:05:38

From: Oxford, United Kingdom
Registered: 2019-06-11
Posts: 2

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

Hi everyone,
the same problem on Alienware Area 51m, i9 9000, RTX2080, 64GB RAM, 2x512GB Sanmsung 970Pro no RAID, Panel 144MHz G-Sinc.
I hope that ill be first wth Arch on this machine and I will create full report in Arch WiKi about this beast with Arch Linux which I running very successfully and more faster in gaming with proprietary nvidia drivers then Window10 on Dell G3 17inch, i5 3.2Ghz, GTX1050Ti, 32GB RAM, 1x512GB Samsung 970Pro with exception fingerprint reader on power buton not working.
However intalation stoped with the same result scrabled screen teh same as like AllofPolo pic.
If? dikiy4eburator find out solution how to install Arch on machine with RTX2080 why is not here full dicription about solution?
More then one decade I was user Ubuntu and and now freshly in Arch, install ubuntu on Alienware Area 51m no problem, but all graphic tests mainly Unigine are about 15-25% worse then with Windows 10 Pro, my oppinion big problem with drivers even Ubuntu clainm that is it last update proprietary driver from nVidia.
Maybe the same result will be if Ill be finaly successful with installation Arch and do some graphic test mainly for gaming and suport DLSS in linuch with proprietary drivers
If I will be successful with instalation Arch definitely Ill let know here with details how to do and reach maximal potencial performance with RTX2080 in Arch.


#7 2019-08-22 11:16:09

Forum Moderator
Registered: 2012-10-16
Posts: 11,856

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

As mentioned in the last post, boot into the system with nomodeset, install Arch and the proprietary drivers and go from there.

Also please put some effort into future posts to make them more legible, there are quite a few typos and grammar errors that look like the result of hasty typing rather than a language barrier, it makes the post quite jarring to read. If it is indeed a language barrier, you might want to post your question in the Other Languages subforum.


#8 2019-08-22 12:09:57

From: Oxford, United Kingdom
Registered: 2019-06-11
Posts: 2

Re: Live USB TTY scrambled (nvidia RTX5000 connected to 4k display)

Hi V1del,

you are right English is not my mother tongue and I write my first post without help traslator and hasty ttyping, I see that for communication here I realy need improve it.
Of course i will post here some effort about run Arch on Alienware Area 51m.
Thanks for tip about boot with nomodeset, I tray it but, I hope that with proprietary drivers from Arch repository results of tests will be minimal the same as like in Win10.


Board footer

Powered by FluxBB