You are not logged in.

#1 2019-07-09 18:46:47

Snostorm
Member
Registered: 2009-04-12
Posts: 17

[Solved] Issues building freecad and freecad-git

In short  It seems to be a user environment issue.


Please can I get some help I was compiling the freecad package 0.18.* , but after my last system update I was not able to get it to recompile I have switched freecad-git, but am having the similar/same issue, looking at cmake error logs point to pthread.so issue but I have seem to have that lib, but maybe ld is not detecting it correctly, it also oddly complains about opencascade while compiling, but nothing in the cmake error file about that just on screen during compile, everything but freecad is from community unless I missed one double checked opencascade, pyside2 and shiboken2 as these have all caused update issues previously but the community build seemed to work the last time I had to recompile.


cmake error log https://pastebin.com/jmsYTvD4

Cmake log https://pastebin.com/TBZQbckc

Terminal compile time https://pastebin.com/3P4FvM42

Last edited by Snostorm (2019-07-10 23:40:25)

Offline

#2 2019-07-09 19:53:38

Snostorm
Member
Registered: 2009-04-12
Posts: 17

Re: [Solved] Issues building freecad and freecad-git

Okay, had a little more time tonight, It seems to be cmake is not finding open cascade I tried adding -DOCC_INCLUDE_DIR=/usr/include/opencascade  but it did not seem to help.  If I manualy hack the cMake file FindOpenCasCade.cmake  in the git clone and force OCC_INCLUDE_DIR=/usr/include/opencascade  the configure completes.  How do I do this correctly for the pkgbuild and instal

Offline

#3 2019-07-09 20:44:51

loqs
Member
Registered: 2014-03-06
Posts: 8,475

Re: [Solved] Issues building freecad and freecad-git

Could you please post the full output from building with makepkg instead of yaourt.
I built freecad-git 1:0.19pre.r856.g45367edb6 successfully in a clean chroot (without 'python-pivy' but with 'coin' added as a dependency,  I will add 'python-pivy' back for a later rebuild test)
Edit:
rebuilt successfully with python-pivy although pivy appeared not to be used.

Last edited by loqs (2019-07-09 23:57:34)

Offline

#4 2019-07-10 19:42:13

Snostorm
Member
Registered: 2009-04-12
Posts: 17

Re: [Solved] Issues building freecad and freecad-git

I went and uninstalled my broken freecad
pacman -Rncs feecad

then tried to reinstall , it located that med was also built from AUR

I rebuilt that  then reinstalled dependencies with pacman

Here is a fresh git clone and makepkg
I am getting the same issues.
https://gitlab.com/snippets/1873950

Offline

#5 2019-07-10 20:23:58

loqs
Member
Registered: 2014-03-06
Posts: 8,475

Re: [Solved] Issues building freecad and freecad-git

Ensure devtools is installed on the system then the following worked for me

git clone https://aur.archlinux.org/med.git
cd med
extra-x86_64-build
cd ..
git clone https://aur.archlinux.org/coin.git
cd coin
extra-x86_64-build
cd ..
git clone https://aur.archlinux.org/freecad-git.git
cd freecad-git #edit PKGBUILD replace python-pivy with coin in depends
extra-x86_64-build -- -I ../med/med-4.0.0-3-x86_64.pkg.tar.xz -I ../coin/coin-4.0.0a+11927+me74da184f75b-1-x86_64.pkg.tar.xz

Offline

#6 2019-07-10 23:33:14

Snostorm
Member
Registered: 2009-04-12
Posts: 17

Re: [Solved] Issues building freecad and freecad-git

So devtools is new to me , I have not done much package maintenance/development.   While it seems to have worked, I would still like to figure out why the std makepkg  is not working so I dont have to do that every time. I captured a debug of cmake in the src dir  to look at   https://gitlab.com/snippets/1873950  attached here in comment.  I understand helpers are not supported but using makepkg should still work I should not need devtools to install from AUR correct?  and thank you for the help.

Offline

#7 2019-07-10 23:57:08

loqs
Member
Registered: 2014-03-06
Posts: 8,475

Re: [Solved] Issues building freecad and freecad-git

CMake Error at cMake/FindOpenCasCade.cmake:95 (file):
  file STRINGS file "//include/opencascade/Standard_Version.hxx" cannot be
  read.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


CMake Error at cMake/FindOpenCasCade.cmake:98 (string):
  string sub-command REGEX, mode MATCH needs at least 5 arguments total to
  command.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


CMake Error at cMake/FindOpenCasCade.cmake:99 (file):
  file STRINGS file "//include/opencascade/Standard_Version.hxx" cannot be
  read.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


CMake Error at cMake/FindOpenCasCade.cmake:102 (string):
  string sub-command REGEX, mode MATCH needs at least 5 arguments total to
  command.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


CMake Error at cMake/FindOpenCasCade.cmake:103 (file):
  file STRINGS file "//include/opencascade/Standard_Version.hxx" cannot be
  read.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


CMake Error at cMake/FindOpenCasCade.cmake:106 (string):
  string sub-command REGEX, mode MATCH needs at least 5 arguments total to
  command.
Call Stack (most recent call first):
  CMakeLists.txt:693 (find_package)


-- Found OCC: //include/opencascade (found version "..") 
-- -- Found OCE/OpenCASCADE version: ..
-- -- OCE/OpenCASCADE include directory: //include/opencascade
-- -- OCE/OpenCASCADE shared libraries directory: //lib

compared with

-- Found OCC: /usr/include/opencascade (found version "7.3.0") 
-- -- Found OCE/OpenCASCADE version: 7.3.0
-- -- OCE/OpenCASCADE include directory: /usr/include/opencascade
-- -- OCE/OpenCASCADE shared libraries directory: /usr/lib

Is /usr/include/opencascade/Standard_Version.hxx present on the system?

Last edited by loqs (2019-07-10 23:58:04)

Offline

#8 2019-07-11 18:10:41

Snostorm
Member
Registered: 2009-04-12
Posts: 17

Re: [Solved] Issues building freecad and freecad-git

Yes , if I

~ $  ls /usr/include/opencascade/Standard_Version.hxx

/usr/include/opencascade/Standard_Version.hxx


I used another user to attempt the makepkg  and it seemed to work , I did not bother letting go all the way , but it passed the configuration.

My system is pretty old, I have been rolling since ~2010 so I may have some cruft that I missed over the years when updating. 

Looking for any cmake environment stuff that may be in my home dir now.

thanks for the continued help.

Looking at the verbose cmake log

line 5047 it seemed to find Open cascade at first , then some how does not get prefix usr on 

line 4077: /lib64/cmake/opencascade/OpenCASCADEConfig.cmake(25):  get_filename_component(OpenCASCADE_INSTALL_PREFIX ${OpenCASCADE_INSTALL_PREFIX} PATH )

It may have to do with the intial set up by my user , but as a different user  $ yaourt -S freecad-git  , did build .  ,

okay after above as my new user  I did

cd tmp
git clone https://aur.archlinux.org/freecad-git.git
chmod -R go+rwX freecad-git/

then try makepkg as my user  it fails

moved that dir off repeated above  as good user
mv freecad-git/ broke-freecad-git/

makepkg worked, interupted with  ctrl ^C at compile
chmod -R go+rwX *

now as bad user  cd into proven good setup
cd /tmp/freecad-git/src/freecad-git

ran cmake statement from PKGBUILD with variable sub and it works

$  cmake . \
>         -DCMAKE_BUILD_TYPE=Release \
>         -DCMAKE_INSTALL_PREFIX="/usr/lib/freecad" \
>         -DCMAKE_INSTALL_DOCDIR="/usr/share/freecad/doc" \
>         -DCMAKE_INSTALL_DATADIR="/usr/share/freecad" \
>         -DFREECAD_USE_OCC_VARIANT="Official Version" \
>         -DBUILD_QT5=ON \
>         -DPYTHON_EXECUTABLE=/usr/bin/python3 \
>         -DOPENMPI_INCLUDE_DIRS=/usr/include \
>         -DSHIBOKEN_INCLUDE_DIR=/usr/include/shiboken2 \
>         -DSHIBOKEN_BINARY=/usr/bin/shiboken2 \
>         -DSHIBOKEN_LIBRARY="/usr/lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so" \
>         -DPYSIDE_INCLUDE_DIR=/usr/include/PySide2 \
>         -DPYSIDE_LIBRARY="/usr/lib/libpyside2.cpython-37m-x86_64-linux-gnu.so" \
>         -DPYSIDE_PYTHONPATH="/usr/lib/python3.7site-packages/PySide2" \
>         -DPYSIDE_TYPESYSTEMS=/usr/share/PySide2/typesystems

??????

Last edited by Snostorm (2019-07-11 20:13:53)

Offline

#9 2019-07-11 21:16:56

Snostorm
Member
Registered: 2009-04-12
Posts: 17

Re: [Solved] Issues building freecad and freecad-git

Solved for Real, and it is the most stupid thing, at some point I put in my ~/.bashrc  a PATH=/usr/bin/gnu:$PATH
the effect placed /bin at the start of my PATH , after removing all works as it should. 

Sorry for all the troubles caused by a part of history

Offline

Board footer

Powered by FluxBB