You are not logged in.

#1 2019-08-01 17:43:26

aminvakil
Member
From: Tehran
Registered: 2019-08-01
Posts: 1
Website

Acer Laptop doesn't respect boot priority

I have an Acer A515-51G-57FM laptop which has a western digital (1TB) hdd and a samsung m2 sata ssd (250GB) (BOTH MBR PARTITION TABLE)

Here is output of lsblk:

NAME                   MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                      8:0    0 931.5G  0 disk  
├─sda1                   8:1    0     1G  0 part  /media/amin/fedora/boot
├─sda2                   8:2    0 368.1G  0 part  /media/amin/drive_d
├─sda3                   8:3    0 368.1G  0 part  
├─sda4                   8:4    0     1K  0 part  
└─sda5                   8:5    0 194.3G  0 part  
  └─sda5_crypt         254:4    0 194.3G  0 crypt 
    ├─fedorahdd-root   254:5    0    30G  0 lvm   
    │ └─fedorahdd_root 254:9    0    30G  0 crypt /media/amin/fedora
    ├─fedorahdd-home   254:6    0 158.4G  0 lvm   
    │ └─fedorahdd_home 254:8    0 158.4G  0 crypt /media/amin/fedora/home
    └─fedorahdd-swap   254:7    0   5.9G  0 lvm   
sdb                      8:16   0 232.9G  0 disk  
├─sdb1                   8:17   0     1G  0 part  /boot
├─sdb2                   8:18   0 135.9G  0 part  
│ └─cryptlvm           254:0    0 135.9G  0 crypt 
│   ├─fedora-root      254:1    0    30G  0 lvm   /
│   ├─fedora-home      254:2    0   100G  0 lvm   /home
│   └─fedora-swap      254:3    0   5.9G  0 lvm   [SWAP]
├─sdb3                   8:19   0   549M  0 part  
└─sdb4                   8:20   0  95.5G  0 part

("fedora" logical volume is actually my Arch Linux logical volume, but as it was created before by Fedora I didn't change its name.

On my HDD I've installed a Fedora 30 if something goes wrong with my Arch Linux (unstable update, wrong configuration, etc.) I could still have a stable OS on my system to work on.

On my SSD there is Arch Linux and Windows.

Now here is the problem:

On my BIOS Setup I've set my ssd as boot order #1 and hdd as boot order #2, but it doesn't boot to Arch Linux automatically and I've got to Press F12 everytime in order to boot Arch up.

My BIOS is Legacy and I've executed

sudo grub-install --target=i386-pc /dev/sdb a million times

a million times, but bios doesn't boot ssd automatically as I've set in bios setup boot order.

Also my

/etc/mkinitcpio.conf

hooks is like this:

HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt sd-lvm2 filesystems fsck)

I've also tried setting compression to cat like this but it didn't change anything:
COMPRESSION="cat"

And

GRUB_CMDLINE_LINUX

in my

/etc/default/grub

goes like this:

GRUB_CMDLINE_LINUX_DEFAULT="rd.luks.name=xxx=cryptlvm root=/dev/fedora/root pci=nommconf nouveau.modeset=0 rd.driver.blacklist=nouveau ipv6.disable=1"

They were like this before, but I've changed udev to systemd in order to fix this issue and speed up the boot process:

HOOKS=(base udev autodetect keyboard keymap consolefont modconf block encrypt lvm2 filesystems fsck)
GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=UUID=xxx:cryptlvm root=/dev/fedora/root pci=nommconf nouveau.modeset=0 rd.driver.blacklist=nouveau ipv6.disable=1"

I don't know it's relevant or not my grub bootloader is password protected on change, I mean you can boot arch without typing password, but if you want to boot fedora from arch grub or windows from arch grub or change grub you've got to hold left shit and type password.

My BIOS is password protected too, and I want to disable F12 completely to prevent changing boot order and boot from usb, but I can't do this.

Last edited by aminvakil (2019-08-01 17:53:16)

Offline

Board footer

Powered by FluxBB