You are not logged in.

#1 2019-08-03 18:19:19

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Install spectrum3d

Hello,

I need help get the program spectrum3d running, please. This is the website for interest: http://spectrum3d.sourceforge.net/
Please be kind and do spell things out step by step for me if you're responding.

the problem I currently have comes after running #makepkg as a normal user

I get. ERROR: Cannot find the whirlpoolsum binary required for source file checksums operations

Im cant resolve this on my on, what shall I do next

Kind regards,

J

Offline

#2 2019-08-03 18:32:15

loqs
Member
Registered: 2014-03-06
Posts: 8,169

Re: Install spectrum3d

Remove the line

whirlpoolsums=('7da32c5fcc18a34d3fede8704339a1ca33ad40a541c3892fe0d14b7f08ae012f0b2c3dbed08067100700729fc53b7e927fea352c07ff2276f7b28c27d10f375b')

from the PKGBUILD.

Offline

#3 2019-08-03 18:33:18

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,920
Website

Re: Install spectrum3d

https://aur.archlinux.org/packages/spectrum3d

Mod note: moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2019-08-03 18:43:27

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

Thanks, a new problem now...

I get some missing dependencies..some I was able to install using pacman. these were glu and sdl.
it still says its missing gstreamer0.10

I ran pacman -s gstreamer which install something but it can't find specifically gstreamer0.10.

Thanks very much for your support!

Offline

#5 2019-08-03 18:52:40

loqs
Member
Registered: 2014-03-06
Posts: 8,169

Re: Install spectrum3d

If the PKGBUILD wanted gstreamer or something gstreamer provided makepkg -s would install gstreamer if it was not already.
https://aur.archlinux.org/packages/gstreamer0.10/

Offline

#6 2019-08-03 18:56:42

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,899
Website

Re: Install spectrum3d

loqs wrote:

If the PKGBUILD wanted ...

You are assuming the PKGBUILD is well written.  The comments on the AUR page would cast doubt on this.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2019-08-03 19:02:34

loqs
Member
Registered: 2014-03-06
Posts: 8,169

Re: Install spectrum3d

# Maintainer: Luke R. <g4jc@openmailbox.org> GPG: rsa4096/3EAE8697

pkgname=spectrum3d
pkgver=2.7.2
pkgrel=1
pkgdesc="An audio spectrum analyser in 3D for Linux"
url="http://spectrum3d.sourceforge.net/index.html"
license=('GPL3')
arch=('i686' 'x86_64')
depends=("gtk3" "gstreamer" "sdl" "alsa-lib" "glu" "jack")
optdepends=("gstreamer-bad-plugins" "gstreamer-ugly-plugins")
source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
sha512sums=('e2885888eb2c608e9095dac15d98ad7a2e5dd902763c59334f0ecf0e8d1ab7503f32a42e35507e69eddafcaa04eddd7339c92ead879323b73798b61742c511c6')

build() {
  cd $pkgname-$pkgver
  ./configure --prefix=/usr/
  make 
}

package() {
  cd $pkgname-$pkgver
  make DESTDIR="$pkgdir/" install
}

Edit:
jack is linked from the binary so can not be optional only a depend or not built with jack support

Last edited by loqs (2019-08-03 19:10:20)

Offline

#8 2019-08-03 19:14:07

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,899
Website

Re: Install spectrum3d

Oops, I missed that these errors were in the build process - gstreamer0.10 is already a dependency, and the above-mentioned error was from makepkg not the built binary.  Sorry for a bit of noise - Fauveboy, you need to install the aur package loqs linked to above to satisfy the gstreamer0.10 dependency.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#9 2019-08-03 20:25:02

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

sorry I dont see a loqs package linked above? I've run makepkg after git clone https://aur.archlinux.org/packages/gstr … 0/...thats seemed to have installed something ? smile

But I still have the same problem, makepkg remains unable to find gstreamer0.10 as a dependency despite installing it?

Offline

#10 2019-08-03 20:43:26

loqs
Member
Registered: 2014-03-06
Posts: 8,169

Re: Install spectrum3d

The link was in post #5.  What makepkg command did you run precisely for gstreamer0.10 ?
The PKGBUILD in post #7 replaces updated the package to 2.7.2 the gstreamer0.1 dependency with a dependency on gstreamer.

Offline

#11 2019-08-03 21:32:00

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

ah yes, sorry I used that link in post #5. I then ran makepkg -s, but as I mention the gstreamer0.10 isn't getting picked up :S

Offline

#12 2019-08-03 21:39:49

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,920
Website

Re: Install spectrum3d

Post the full makepkg output, as well as the output of

pacman -Qs gstreamer0.10

Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#13 2019-08-03 22:08:31

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

the output is for makepkg is:

==> Making packages: spectrum3d 2.5.0-2 (Sun Aug 2019 00:00:23 BST)
==> Checking runtime dependencies...
==> Missing dependencies:
   ->gstreamer0.10
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

there is no output for #pacman -Qs gstreamer0.10

theres an output for #pacman -Qs gstreamer:

local/gst-plugins-base-libs 1.16.0-3
GStreamer open-source multimedia framework base libraries
local/gstreamer 1.16.0-2
GStreamer open-source multimedia framework core library

Offline

#14 2019-08-03 22:15:14

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,920
Website

Re: Install spectrum3d

Then you haven't installed gstreamer0.10.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#15 2019-08-03 22:46:44

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

ah its all definitely installed now.

I get a new problem saying:

no protocol specified
unable to init server: Could not connect: connection refused

(spectrum3d:5330):GTK-warning**:00:40:28.397: cannot open display: :0

...has this something todo with using DWM ?

Offline

#16 2019-08-03 22:56:18

loqs
Member
Registered: 2014-03-06
Posts: 8,169

Re: Install spectrum3d

Was this in a terminal started from X or from a console?

Offline

#17 2019-08-03 23:42:54

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,899
Website

Re: Install spectrum3d

Please also always include the command used and complete output in [ code ] tags.  In this case, context makes it clear that you were running something - likely the primary binary - from the package; but earlier it wasn't clear whether paraphrased errors were from attempting to run the installed program, or from makepkg.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#18 2019-08-04 08:41:12

Fauveboy
Member
Registered: 2019-08-03
Posts: 7

Re: Install spectrum3d

okay, on the last outputs I only used the command. This was in a terminal? x11 is involved somehow? I thought console was just an alt name for terminal?

spectrum3d

Offline

#19 2019-08-04 13:17:54

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,899
Website

Re: Install spectrum3d

Fauveboy wrote:

I thought console was just an alt name for terminal?

Console generally refers to a tty not under a graphical session.  Terminal is more general and would include X11 terminal emulators.

But forget the terminology, the key point is that this is an X11 client program, it needs to be run from within an X11 session (or at least provided the DISPLAY environment variable of an active X display).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB