You are not logged in.

#1 2004-03-14 05:27:36

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Cannot boot into Arch any longer

I'm getting the following error now when attempting to boot into Arch 0.6 from a Mandrake 10  install using lilo:

INIT: Id "x" respawing too fast : disabled for 5 minutes

When I  recently linstalled the updated my kernel in Arch, I ran 'lilo -v' which caused the Arch lilo to be the default bootloader.  I upgraded my Mandrake install (which shares the same disk) and reconfigured *it's* lilo so that I could boot back into Windows and added an entry for Arch.  Since then, when I choose Arch from the lilo boot menu, I get the above error.

Below is my /etc/inittab file (which I've not recently changed and appears correct):

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)    Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

c1:2345:respawn:/sbin/agetty 38400 vc/1 linux
c2:2345:respawn:/sbin/agetty 38400 vc/2 linux
c3:2345:respawn:/sbin/agetty 38400 vc/3 linux
c4:2345:respawn:/sbin/agetty 38400 vc/4 linux
c5:2345:respawn:/sbin/agetty 38400 vc/5 linux
c6:2345:respawn:/sbin/agetty 38400 vc/6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

x:5:respawn:/opt/kde/bin/kdm -nodaemon

# End of file

I have an uncommented  'exec startkde' in my .xinitrc file.

This is my lilo.conf from Mandrake:

boot=/dev/hda
map=/boot/map
default="Arch0.6"
keytable=/boot/am_old.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/arch/boot/vmlinuz26
        label="Arch0.6"
        root=/dev/hda9
        read-only
image=/boot/vmlinuz-2.6.3-4mdk
        label="Mandrake263-4"
        root=/dev/hda5
        initrd=/boot/initrd-2.6.3-4mdk.img
        append="devfs=mount acpi=ht splash=silent"
        read-only
image=/boot/vmlinuz
        label="linux-nonfb"
        root=/dev/hda5
        initrd=/boot/initrd.img
        append="devfs=mount splash=silent acpi=ht"
        read-only
other=/dev/hda1
        label="windows"
        table=/dev/hda
other=/dev/fd0
        label="floppy"
        unsafe
image=/boot/vmlinuz
        label="failsafe"
        root=/dev/hda5
        initrd=/boot/initrd.img
        append="failsafe splash=silent acpi=ht devfs=nomount"
        read-only

When I edited, I removed the entry for the 2.4.25 Mandrake kernel and added Arch as the first entry and set it as the default.

I can provide other files or information as needed.

I appreciate the feedback.

Offline

#2 2004-03-14 07:25:25

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Cannot boot into Arch any longer

x:5:respawn:/opt/kde/bin/kdm -nodaemon

This is the line that's causing it.  It's probably not because of this line, but because kdm isn't starting properly (possibly erroring) and being re-run because of the respawn option.

Try booting into single user mode, changing the default run level to 3, and debugging it from there (figure out why kdm doesn't want to start right).


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#3 2004-03-14 23:05:28

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Re: Cannot boot into Arch any longer

This ended up being due to my not adding an entry for my nvidia card in rc.conf  :oops:  :oops:

Well, at least the mystery is solved.

Thanks

Offline

#4 2004-03-15 06:23:08

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: Cannot boot into Arch any longer

Lol. Shit happens. Welcome, dude!


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB