You are not logged in.

#1 2019-08-07 13:48:40

Ennis-Ham
Member
Registered: 2018-05-18
Posts: 4

Installation hangs on uevent

Hey I had recently gotten back from vacation and updated my system and it stopped booting past grub for whatever reason. I figured I should have been able to use an arch bootable to go in and manually fix it but I haven't been able to boot past grub on that either. I've rewrote the iso about 2 or three times now with the newest torrent, and every attempt has bricked on the udev/uevent call. Is there a specific parameter I need to use? The laptop I was trying to fix was a Lenovo Thinkpad X1 Yoga (1st gen).

Offline

#2 2019-08-07 14:03:13

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,035

Re: Installation hangs on uevent

General guess, though I'd expect it to hang later if that was the issue, does pressing buttons (doesn't matter which) eventually lead to a successful boot? If it does you are hit by the low entropy during early boot issue you might be able to try and add

random.trust_cpu=on

to your kernel parameters. If that doesn't help, another issue that's currently floating about on intel graphics is an issue with the panel refresh code, in which case

i915.enable_psr=0

should help. If even that doesn't work  try

loglevel=7

and/or

nomodeset

post potentially resulting errors.

Offline

#3 2019-08-07 14:23:24

Ennis-Ham
Member
Registered: 2018-05-18
Posts: 4

Re: Installation hangs on uevent

V1del wrote:

General guess, though I'd expect it to hang later if that was the issue, does pressing buttons (doesn't matter which) eventually lead to a successful boot? If it does you are hit by the low entropy during early boot issue you might be able to try and add

random.trust_cpu=on

to your kernel parameters. If that doesn't help, another issue that's currently floating about on intel graphics is an issue with the panel refresh code, in which case

i915.enable_psr=0

should help. If even that doesn't work  try

loglevel=7

and/or

nomodeset

post potentially resulting errors.

So the intel graphics fix solved my issue for the arch iso. How do make this parameter persistent? I tried looking into the grub.cfg but I've never edited grub configurations before and the amount of data in there is intimidating.

EDIT: Actually I got it now, thanks for the help
the line I had to edit was

	GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

	GRUB_CMDLINE_LINUX_DEFAULT="quiet splash random.trust_cpu=on i915.enable_psr=0"

in

/etc/default/grub

Last edited by Ennis-Ham (2019-08-07 15:06:45)

Offline

Board footer

Powered by FluxBB