You are not logged in.

#1 2019-08-08 22:12:58

orisha
Member
Registered: 2019-08-08
Posts: 3

GX61 Media Controller not being detected by Arch (kind of)

This is probably a lost battle, but I decided to give it a try.
So, following the Arch USB MIDI keyboards (https://wiki.archlinux.org/index.php/USB_MIDI_keyboards)

#aseqdump
Waiting for data at port 129:0. Press Ctrl+C to end.
Source  Event                  Ch  Data
#lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 007: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 002 Device 006: ID 0bda:579a Realtek Semiconductor Corp. 
Bus 002 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 002 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 002 Device 009: ID 2467:2034  
Bus 002 Device 008: ID 3938:1031  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The 2467:2034 line actually belongs to the midi keyboard, if I unplugged from the USB, it disappear.

#lsmod | grep usb
snd_usb_audio         274432  0
snd_usbmidi_lib        40960  1 snd_usb_audio
snd_rawmidi            45056  2 snd_seq_midi,snd_usbmidi_lib
btusb                  57344  0
media                  61440  5 videodev,snd_usb_audio,videobuf2_v4l2,uvcvideo,videobuf2_common
btrtl                  20480  1 btusb
btbcm                  16384  1 btusb
btintel                28672  1 btusb
rtsx_usb_ms            24576  0
bluetooth             675840  41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
memstick               20480  1 rtsx_usb_ms
snd_hwdep              20480  2 snd_usb_audio,snd_hda_codec
snd_pcm               135168  6 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
snd                   110592  23 snd_hda_codec_generic,snd_seq,snd_hda_codec_conexant,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_timer,snd_pcm,snd_rawmidi
rtsx_usb_sdmmc         32768  0
mmc_core              184320  1 rtsx_usb_sdmmc
rtsx_usb               28672  2 rtsx_usb_sdmmc,rtsx_usb_ms
usbhid                 65536  0
hid                   143360  2 usbhid,hid_generic
#aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
aseqdump -p 0

Doesn't register any event when touching the keyboard keys



Besides that, I installed qsynth and run it using the alsa option, but it doesn't seems to detect the keyboard.

Any ideas?

Offline

#2 2019-08-09 10:28:12

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,135

Re: GX61 Media Controller not being detected by Arch (kind of)

This how-to assumes that you are using ALSA

The output of aconnect -i indicates alsa doesn't have control of the keyboard, you might be using something else for sound like pulseaudio.

post output of pacman -Qs pulse please.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-08-09 11:42:34

orisha
Member
Registered: 2019-08-08
Posts: 3

Re: GX61 Media Controller not being detected by Arch (kind of)

Hi Lone_Wolf, thanks for the reply. Here it is:

#pacman -Qs pulse
local/lib32-libpulse 12.2-1
    A featureful, general-purpose sound server (32-bit client libraries)
local/libao 1.2.2-2
    Cross-platform audio output library and plugins
local/libcanberra-pulse 0.30+2+gc0620e4-2
    PulseAudio plugin for libcanberra
local/libpulse 12.2-2
    A featureful, general-purpose sound server (client library)
local/pavucontrol 1:4.0-1
    PulseAudio Volume Control
local/pavucontrol-qt 0.14.1-1
    A Pulseaudio mixer in Qt (port of pavucontrol)
local/plasma-pa 5.16.4-1 (plasma)
    Plasma applet for audio volume management using PulseAudio
local/pulseaudio 12.2-2
    A featureful, general-purpose sound server
local/pulseaudio-alsa 2-4
    ALSA Configuration for PulseAudio
local/pulseaudio-bluetooth 12.2-2
    Bluetooth support for PulseAudio


I will add the errors I get using Qsynth when setting to different midi drivers:
alsaseq

14:09:50.952 Qsynth1: Stopping MIDI player...
14:09:50.953 Qsynth1: Waiting for MIDI player to terminate...
14:09:50.953 Qsynth1: Destroying MIDI player...
14:09:50.953 Qsynth1: Destroying MIDI router...
14:09:50.954 Qsynth1: Destroying audio driver...
14:09:50.956 Qsynth1: Unloading soundfont: "/usr/lib/lv2/FluidPipes.lv2/FluidPlug.sf2" (SFID=5)...
14:09:50.956 Qsynth1: Unloading soundfont: "/usr/lib/lv2/FluidOrgans.lv2/FluidPlug.sf2" (SFID=3)...
14:09:50.957 Qsynth1: Unloading soundfont: "/usr/lib/lv2/AirFont320.lv2/FluidPlug.sf2" (SFID=1)...
14:09:50.959 Qsynth1: Destroying synthesizer engine...
14:09:50.966 Qsynth1: Synthesizer engine terminated.
14:09:51.529 Qsynth1: Creating synthesizer engine...
14:09:51.532 Qsynth1: Loading soundfont: "/usr/lib/lv2/AirFont320.lv2/FluidPlug.sf2" (bank offset 0)...
14:09:51.584 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidPianos.lv2/FluidPlug.sf2" (bank offset 0)...
14:09:51.604 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidOrgans.lv2/FluidPlug.sf2" (bank offset 0)...
14:09:51.623 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidStrings.lv2/FluidPlug.sf2" (bank offset 0)...
14:09:51.656 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidPipes.lv2/FluidPlug.sf2" (bank offset 0)...
14:09:51.662 Qsynth1: Creating audio driver (alsa)...
14:09:51.667 Qsynth1: Creating MIDI router (alsa_seq)...
14:09:51.672 Qsynth1: Creating MIDI driver (alsa_seq)...
14:09:51.672 Qsynth1: Creating MIDI player...
14:09:51.672 Qsynth1: fluid_synth_set_reverb_on(1)
14:09:51.676 Qsynth1: fluid_synth_set_chorus_on(1)
14:09:51.677 Qsynth1: Synthesizer engine started.
14:09:51.678 Qsynth1: fluid_synth_set_gain(1)
14:09:51.678 Qsynth1: fluid_synth_set_reverb(0.2,0,1,0.9)
14:09:51.678 Qsynth1: fluid_synth_set_chorus(3,1,0.3,8,0)
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
fluidsynth: error: Unknown integer parameter 'synth.dump'
fluidsynth: warning: Requested 2 periods, got 3 instead
fluidsynth: warning: Failed to set thread to high priority
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Failed to set thread to high priority
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]

oss

[14:13:45.554 Qsynth1: Stopping MIDI player...
14:13:45.555 Qsynth1: Waiting for MIDI player to terminate...
14:13:45.555 Qsynth1: Destroying MIDI player...
14:13:45.555 Qsynth1: Destroying MIDI driver...
14:13:45.637 Qsynth1: Destroying MIDI router...
14:13:45.638 Qsynth1: Destroying audio driver...
14:13:45.640 Qsynth1: Unloading soundfont: "/usr/lib/lv2/FluidPipes.lv2/FluidPlug.sf2" (SFID=5)...
14:13:45.642 Qsynth1: Unloading soundfont: "/usr/lib/lv2/FluidOrgans.lv2/FluidPlug.sf2" (SFID=3)...
14:13:45.643 Qsynth1: Unloading soundfont: "/usr/lib/lv2/AirFont320.lv2/FluidPlug.sf2" (SFID=1)...
14:13:45.650 Qsynth1: Destroying synthesizer engine...
14:13:45.679 Qsynth1: Synthesizer engine terminated.
14:13:46.237 Qsynth1: Creating synthesizer engine...
14:13:46.238 Qsynth1: Loading soundfont: "/usr/lib/lv2/AirFont320.lv2/FluidPlug.sf2" (bank offset 0)...
14:13:46.277 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidPianos.lv2/FluidPlug.sf2" (bank offset 0)...
14:13:46.292 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidOrgans.lv2/FluidPlug.sf2" (bank offset 0)...
14:13:46.303 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidStrings.lv2/FluidPlug.sf2" (bank offset 0)...
14:13:46.320 Qsynth1: Loading soundfont: "/usr/lib/lv2/FluidPipes.lv2/FluidPlug.sf2" (bank offset 0)...
14:13:46.324 Qsynth1: Creating audio driver (alsa)...
14:13:46.328 Qsynth1: Creating MIDI router (oss)...
14:13:46.328 Qsynth1: Creating MIDI driver (oss)...
14:13:46.328 Qsynth1: Failed to create the MIDI driver (oss). No MIDI input will be available.
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
fluidsynth: error: Unknown integer parameter 'synth.dump'
fluidsynth: warning: Requested 2 periods, got 3 instead
/dev/midi: No such file or directory
fluidsynth: warning: Failed to set thread to high priority
14:13:48.532 Qsynth1: Creating MIDI player...
14:13:48.534 Qsynth1: fluid_synth_set_reverb_on(1)
14:13:48.534 Qsynth1: fluid_synth_set_chorus_on(1)
14:13:48.536 Qsynth1: Synthesizer engine started.
14:13:48.536 Qsynth1: fluid_synth_set_gain(1)
14:13:48.537 Qsynth1: fluid_synth_set_reverb(0.2,0,1,0.9)
14:13:48.537 Qsynth1: fluid_synth_set_chorus(3,1,0.3,8,0)
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]
fluidsynth: warning: Instrument not found on channel 9 [bank=128 prog=9], substituted [bank=128 prog=0]

Last edited by orisha (2019-08-09 12:14:36)

Offline

#4 2019-08-09 15:06:35

orisha
Member
Registered: 2019-08-08
Posts: 3

Re: GX61 Media Controller not being detected by Arch (kind of)

So an update, midi events are actually being captured, I was just being dump and not choosing the right channel.

# aseqdump -p 24
Waiting for data. Press Ctrl+C to end.
Source  Event                  Ch  Data
 24:0   Note on                 0, note 62, velocity 96
 24:0   Note on                 0, note 58, velocity 80
 24:0   Note on                 0, note 60, velocity 93
 24:0   Note off                0, note 58, velocity 0
 24:0   Note off                0, note 62, velocity 0
 24:0   Note off                0, note 60, velocity 0
 24:0   Note on                 0, note 60, velocity 40
 24:0   Note on                 0, note 59, velocity 43
 24:0   Note on                 0, note 57, velocity 42
 24:0   Note off                0, note 57, velocity 0
 24:0   Note off                0, note 60, velocity 0
 24:0   Note off                0, note 59, velocity 0
 24:0   Note on                 0, note 62, velocity 27
 24:0   Note off                0, note 62, velocity 0

However, they don't seem to be detected neither by zynaddsubfx nor by qsynth. Tried configured them with both Alsa and OSS




Some success!

I was able to configure Qsynth for it to finally work. I installed the alsa-oss package, choose oss as the midi device, and set /dev/midi2 as the midi device. With zynaddsubfx no luck, even selecting OSS too.

Last edited by orisha (2019-08-09 15:40:30)

Offline

Board footer

Powered by FluxBB