You are not logged in.

#1 2019-08-11 07:11:17

karnasw
Member
Registered: 2019-05-16
Posts: 12

Plymouth Nvidia 430.XX not working on boot (GTX 1070)

Hi, I have problem with plymouth on my PC. I configured plymouth without problem on old notebook with Radeon.

But on my PC with Nvidia GTX 1070 and 430.XX drivers splash screen doesn't appear on boot. It appears sometimes on shutdown when some process blocking it.
Kernel version 5.2.8, KDE 5.16.4, EFI boot, disabled sddm.service and enabled sddm-plymouth.service.

My settings:

grub (default) (grub-mkconfig -o /boot/grub/grub.cfg used)

# GRUB boot loader configuration

GRUB_DEFAULT=2
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0 nvidia-drm.modeset=1"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires to
# set 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

mkinitcpio.conf (mkinitcpio -p linux used)

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base udev plymouth autodetect modconf block filesystems keyboard fsck)

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

plymouthd.conf

# Distribution defaults. Changes to this file will get overwritten during
# upgrades.
[Daemon]
Theme=arch-breeze
ShowDelay=0
#DeviceTimeout=5

What am I doing wrong?

Last edited by karnasw (2019-08-11 07:15:16)

Offline

#2 2019-08-11 09:07:58

Piri
Member
Registered: 2018-06-02
Posts: 53

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)

https://bbs.archlinux.org/viewtopic.php … 7#p1830427

EDIT: Never mind me, you already set ShowDelay...

Last edited by Piri (2019-08-11 09:10:56)

Offline

#3 2019-08-11 11:55:53

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,030

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)

Prop nvidia does usually not support the standard high res EFI modes invoked by the UEFI. You can try setting it up like here: https://wiki.archlinux.org/index.php/GR … resolution

Offline

#4 2019-08-11 17:23:57

karnasw
Member
Registered: 2019-05-16
Posts: 12

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)

I set "GRUB_GFXMODE=1680x1050x32,1920x1080x32,auto" and "GRUB_GFXPAYLOAD_LINUX=keep".I ran "grub-mkconfig -o /boot/grub/grub.cfg" after. This didn't help.

Offline

#5 2019-08-11 19:29:54

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,789
Website

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)

V1del wrote:

Prop nvidia does usually not support the standard high res EFI modes invoked by the UEFI. You can try setting it up like here: https://wiki.archlinux.org/index.php/GR … resolution

I seem to recall this as well when I used nvidia hardware.  If you want higher resolutions, lose the nvidia smile


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#6 2019-08-11 20:27:04

dockland
Member
From: Sweden
Registered: 2015-06-06
Posts: 837

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)


I possess a device, in my pocket, that is capable of accessing the entirety of information known to man.
I use it to look at funny pictures of cats and to argue with strangers.

Offline

#7 2019-08-12 09:51:31

karnasw
Member
Registered: 2019-05-16
Posts: 12

Re: Plymouth Nvidia 430.XX not working on boot (GTX 1070)

Maybe that is the problem with kernel. I will wait.

Offline

Board footer

Powered by FluxBB