You are not logged in.

#1 2019-08-14 01:41:01

gamalan
Member
Registered: 2019-08-14
Posts: 2

Chromium ERR_SPDY_PROTOCOL_ERROR

I'm not where to post this, but because I use Archlinux and this problem only happen in my Archlinux, so I post it here.

I always got ERR_SPDY_PROTOCOL_ERROR for a certain website(personal blog) when accessing with specific detail. The website itself is using Wordpress, in a shared hosting provider. Here is the problem in detail:

- Happen only in my Archlinux installation, (I use a laptop with dual GPU, Intel+Nvidia, but Nvidia only run when using optirun, primusrun)
- Only happen in GUI Web Client such as Chromium, Firefox, Opera, etc
- Happen in normal or incognito mode
- I use dnscrypt-proxy for DNS resolver, with dnscrypt active/not the problem still persist
- The homepage [DOMAIN] is loaded normally, SSL certificate is valid
- Happen when accessing [DOMAIN]/wp-admin or [DOMAIN]/wp-login.php
- If I force login via cPanel, I can access [DOMAIN]/wp-admin normally
- If I access via mobile phone or other OS, I can access [DOMAIN]/wp-admin normally
- Doesn't happen when I browse using lynx
- Doesn't happen to others

What I have done:
- https://www.techsupportall.com/fix-err_ … rmanently/
- Removing the browser package and reinstall
- Reset browser configuration

What should I check? What did I miss?

Thank you for the help.

Offline

#2 2019-08-14 14:23:35

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,851

Re: Chromium ERR_SPDY_PROTOCOL_ERROR

My first hunch would have to do with whether this is an IPv4 vs IPv6 issue.
Does your system have a global IPv6 address?  If you, for example, ping archlinux.org, is the response from an IPv4 or an IPv6 address?
How about your other systems?

OTOH, I could be completely wrong.  In any event, welcome to the Arch Linux forums.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-08-15 11:02:09

gamalan
Member
Registered: 2019-08-14
Posts: 2

Re: Chromium ERR_SPDY_PROTOCOL_ERROR

As far as I can tell, my ISP hasn't fully implement IPv6 yet. When I ping, using Archlinux, or Windows, normally it would return IPv4 address. But, because it loaded properly when I use lynx in Arch, I don't think it's IPv4 or IPv6 issue.
I also try to see from the net event from the browser(chromium, firefox), but I don't know what I should be looking for.

Offline

Board footer

Powered by FluxBB