You are not logged in.

#1 2019-08-14 05:07:53

atomy
Member
Registered: 2019-08-14
Posts: 4

[SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

Since upgrading xfce4 to 4.14 some Themes in the Appearance-Settings have no effect, some themes seem to have stopped working at all, basically all xfce-* themes.

When Downgrading to the previous version it resumes working. This happens both on my laptop and my desktop-computer.

 $ ~> cat /var/log/pacman.log | grep 2019-08-12 | grep "upgraded xf"
[2019-08-12 07:14] [ALPM] upgraded xfconf (4.12.1-7 -> 4.14.1-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-appfinder (4.12.0-5 -> 4.14.0-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-panel (4.12.2-1 -> 4.14.0-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-clipman-plugin (1.4.3-1 -> 1.4.3-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-datetime-plugin (0.7.1-1 -> 0.8.0-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-genmon-plugin (4.0.1-1 -> 4.0.2-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-notes-plugin (1.8.1-3 -> 1.8.1-4)
[2019-08-12 07:15] [ALPM] upgraded xfce4-notifyd (0.4.4-1 -> 0.4.4-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-power-manager (1.6.4-1 -> 1.6.5-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-pulseaudio-plugin (0.4.1-1 -> 0.4.2-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-session (4.12.1-11 -> 4.14.0-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-settings (4.12.4-2 -> 4.14.0-1)
[2019-08-12 07:15] [ALPM] upgraded xfce4-terminal (0.8.8-1 -> 0.8.8-2)
[2019-08-12 07:15] [ALPM] upgraded xfce4-xkb-plugin (0.8.1-1 -> 0.8.1-2)
[2019-08-12 07:15] [ALPM] upgraded xfdesktop (4.13.6-1 -> 4.14.1-2)
[2019-08-12 07:15] [ALPM] upgraded xfwm4 (4.12.5-1 -> 4.14.0-1)
[2019-08-12 08:14] [ALPM] upgraded xfce4-panel (4.12.2-1 -> 4.14.0-1)

Any advice?

Last edited by atomy (2019-08-26 04:53:04)

Offline

#2 2019-08-14 06:01:16

kayam4n
Member
Registered: 2019-08-14
Posts: 3

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

Hello,

same problem here. Downgrading didn't help though. Removing ~/.config/gtk-2.0 gtk-3.0 xfce4 and xfce4-session didn't help neither.
Regards

Offline

#3 2019-08-14 11:04:27

toz
Member
Registered: 2011-10-28
Posts: 415

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

atomy wrote:

Since upgrading xfce4 to 4.14 some Themes in the Appearance-Settings have no effect, some themes seem to have stopped working at all, basically all xfce-* themes.

Those are GTK2 themes. Xfce has migrated to GTK3 and therefore those themes that don't have gtk-3.0 components defined will default to Adwaita (and look like they no longer work). So basically, you now need to use a theme that was built to support the version of GTK3 that you are running (Greybird, Arc, Adapta, etc).

You can remove them by uninstalling the gtk-xfce-engines package - which is no longer required by Xfce.

Offline

#4 2019-08-15 06:07:46

atomy
Member
Registered: 2019-08-14
Posts: 4

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

kayam4n wrote:

Downgrading didn't help though.

Those are the ones I downgraded using https://aur.archlinux.org/packages/downgrade/

[2019-08-14 06:50] [ALPM] downgraded libxfce4util (4.14.0-1 -> 4.13.5-1)
[2019-08-14 06:50] [ALPM] downgraded xfconf (4.14.1-1 -> 4.12.1-7)
[2019-08-14 06:51] [ALPM] downgraded libxfce4ui (4.14.1-2 -> 4.13.7-1)
[2019-08-14 06:51] [ALPM] downgraded xfce4-appfinder (4.14.0-1 -> 4.12.0-5)
[2019-08-14 06:51] [ALPM] downgraded xfce4-panel (4.14.0-1 -> 4.12.2-1)
[2019-08-14 06:52] [ALPM] downgraded xfce4-clipman-plugin (1.4.3-2 -> 1.4.3-1)
[2019-08-14 06:52] [ALPM] downgraded xfce4-datetime-plugin (0.8.0-1 -> 0.7.1-1)
[2019-08-14 06:52] [ALPM] downgraded xfce4-genmon-plugin (4.0.2-1 -> 4.0.1-1)
[2019-08-14 06:53] [ALPM] downgraded xfce4-notes-plugin (1.8.1-4 -> 1.8.1-3)
[2019-08-14 06:53] [ALPM] downgraded xfce4-notifyd (0.4.4-2 -> 0.4.4-1)
[2019-08-14 06:53] [ALPM] downgraded xfce4-power-manager (1.6.5-2 -> 1.6.4-1)
[2019-08-14 06:53] [ALPM] downgraded xfce4-pulseaudio-plugin (0.4.2-2 -> 0.4.1-1)
[2019-08-14 06:54] [ALPM] downgraded xfce4-session (4.14.0-2 -> 4.12.1-11)
[2019-08-14 06:54] [ALPM] downgraded xfce4-settings (4.14.0-1 -> 4.12.4-2)
[2019-08-14 06:54] [ALPM] downgraded xfce4-terminal (0.8.8-2 -> 0.8.8-1)
[2019-08-14 06:55] [ALPM] downgraded xfce4-xkb-plugin (0.8.1-2 -> 0.8.1-1)
[2019-08-14 06:55] [ALPM] downgraded xfdesktop (4.14.1-2 -> 4.13.6-1)
[2019-08-14 06:55] [ALPM] downgraded xfwm4 (4.14.0-1 -> 4.12.5-1)

Offline

#5 2019-08-15 06:47:25

atomy
Member
Registered: 2019-08-14
Posts: 4

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

toz wrote:

Those are GTK2 themes. Xfce has migrated to GTK3 and therefore those themes that don't have gtk-3.0 components defined will default to Adwaita (and look like they no longer work). So basically, you now need to use a theme that was built to support the version of GTK3 that you are running (Greybird, Arc, Adapta, etc).

You can remove them by uninstalling the gtk-xfce-engines package - which is no longer required by Xfce.

Thanks, this helped!

My Theme-list is pretty empty now and I am having a hard time to find one that I like, is there are list of themes are in the archlinux repo somewhere?

Offline

#6 2019-08-15 10:34:19

paneless
Member
Registered: 2013-02-21
Posts: 27

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

Take a look at xfce-look.org. Download the theme(s) you like and extract them to your ~/.themes folder - you will probably need to create this directory first.

Offline

#7 2019-08-19 06:25:09

kayam4n
Member
Registered: 2019-08-14
Posts: 3

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

atomy wrote:
toz wrote:

Those are GTK2 themes. Xfce has migrated to GTK3 and therefore those themes that don't have gtk-3.0 components defined will default to Adwaita (and look like they no longer work). So basically, you now need to use a theme that was built to support the version of GTK3 that you are running (Greybird, Arc, Adapta, etc).

You can remove them by uninstalling the gtk-xfce-engines package - which is no longer required by Xfce.

Thanks, this helped!

My Theme-list is pretty empty now and I am having a hard time to find one that I like, is there are list of themes are in the archlinux repo somewhere?

Solved this problem indeed. Thank you. Please mark the thread as solved.

Offline

#8 2019-08-19 15:58:34

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,763

Re: [SOLVED] xfce 4.14 - xfce-themes in xfce4-appearance-settings broken

Moderator:  Cleaned up the thread due to some minor miscommunication.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB