You are not logged in.

#1 2019-08-16 00:16:15

Registered: 2011-02-18
Posts: 36

[SOLVED] Can't install Arch; Ubuntu OK

I am unable to install Arch from a USB stick, but I can install Ubuntu.

I had been running Arch on my LG Gram 13" (13Z980-A.AAS6U1), but one day it stopped booting. The only sign of life I could get was the boot menu (what one gets with F10) which only displayed boot devices or BIOS setup, but never did anything. I was not able to get to usual BIOS settings menu (F2). So, I sent it off to LG for warranty, and when I got it back, both my SSD's had been reformatted and wiped clean and Windows 10 Home installed. Needless to say, I was <ahem> upset. OK, time to install Arch, as I had done when I had originally gotten my LG Gram laptop.

I've been an Arch user for several years now, and I've installed Arch on at least an ASUS laptop, an Intel NUC, and two different no-name Intel boxes, so I was expecting a pretty routine Arch re-installation.

I created a USB stick with Arch 2019.08 on it using Rufus on Windows 10, but it was not recognized by laptop. The physical USB stick is seen by the BIOS, and I can move it up in the boot order, but the LG Gram will not boot from it. I used Etcher on my Arch desktop to create another USB stick and still couldn't boot. I used 'dd' to create the Arch install medium. I even created an Arch CD. Same deal: the physical device is recognized by the BIOS, but is unable to boot from it. I deleted Windows and the Windows boot manager so I had no OS's on my laptop, and then tried again installing Arch from a USB stick. Nothing worked. As far as I can tell, neither the USB sticks nor the CD were ever accessed; booting always started up with whatever other OS was present.

Strangely, I was able to create and boot from a Ubuntu USB stick without any issues. (I'm writing this from Ubuntu.)

Here is the relevant output of 'blkid' and 'fdisk -l' for the two USB sticks:

/dev/sdb1: UUID="2019-04-16-19-19-59-00" LABEL="Ubuntu 19.04 amd64" TYPE="iso9660" PTUUID="46f8e7bf" PTTYPE="dos" PARTUUID="46f8e7bf-01"
/dev/sdb2: SEC_TYPE="msdos" UUID="039E-EF17" TYPE="vfat" PARTUUID="46f8e7bf-02"

/dev/sdc1: UUID="2019-08-01-14-29-48-00" LABEL="ARCH_201908" TYPE="iso9660" PTUUID="5ccc69bc" PTTYPE="dos" PARTUUID="5ccc69bc-01"
/dev/sdc2: SEC_TYPE="msdos" LABEL_FATBOOT="ARCHISO_EFI" LABEL="ARCHISO_EFI" UUID="7340-BC46" TYPE="vfat" PARTUUID="5ccc69bc-02"
Disk /dev/sdb: 28.9 GiB, 31009800192 bytes, 60566016 sectors
Disk model: Patriot Memory  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type:dos
Disk identifier: 0x46f8e7bf

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *          0 4095999 4096000    2G  0 Empty
/dev/sdb2       4066772 4074259    7488  3.7M ef EFI (FAT-12/16/32)

Disk /dev/sdc: 28.9 GiB, 31009800192 bytes, 60566016 sectors
Disk model: Patriot Memory  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dosroot@hilbert:~# fdisk -l /dev/sdcroot@hilbert:~# fdisk -l /dev/sdc
Disk identifier: 0x5ccc69bc

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1  *        0 1273855 1273856  622M  0 Empty
/dev/sdc2         164  131235  131072   64M ef EFI (FAT-12/16/32)

Both sticks were created using:

dd bs=4M if=*.iso of=/dev/sd? status=progress oflag=sync


ubuntu-19.04-desktop-amd64.iso     #
archlinux-2019.08.01-x86_64.iso    #


The output of 'efibootmgr -v' (lightly formatted) is:

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0019,0000,0014,0015,0016,0017,0018,001A,001B
Boot0000* ubuntu	HD(1,GPT,ff1f2ebb-e508-4bdd-a242-3eb6025229ec,0x800,0xf4240)/File(\EFI\ubuntu\shimx64.efi)
Boot0010  Setup		FvFile(4213591d-ceef-425f-915b-ae4559680f62)
Boot0011  HiddenMenuSetup
Boot0012  SecureSetup	FvFile(a8f1e579-0d86-4c93-ffff-ffff76875225)
Boot0013  Boot Menu	FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0014* USB CD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0015* ATA HDD2:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot0016* ATA HDD1: SAMSUNG MZNLN256HAJQ-00000
Boot0017* NVMe0:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a406)
Boot0018* NVMe1: INTEL SSDPEKNW010T8
Boot0019* USB HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot001A* USB FDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot001B* USB LAN:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,e854bca4cae7704ca322b00da0376322)

The BIOS setup on the LG Gram is very, very simple. I can set the time, turn on or off a few settings like legacy OS, UEFI, software guard extensions, legacy USB, and a few security-related settings like passwords and fTPM/TPM, and of course, boot order. From the default BIOS settings, I turned off TPM, and changed the boot order. I think those are the only changes I needed to boot/run Ubuntu.

I'm quite comfortable with Linux in general and Arch in particular. I've been using Linux for 20(?) years and Arch for the last several. Before that it was Gentoo and Red Hat. But this has me baffled and frustrated. Any ideas on how can I get Arch installed and running on my LG Gram laptop? Why can I boot and install  Ubuntu from a USB stick, but not Arch?

Thanks for any help.

inxi -F reports:

System:    Host: hilbert Kernel: 5.0.0-25-generic x86_64 bits: 64 Desktop: Gnome 3.32.0 
           Distro: Ubuntu 19.04 (Disco Dingo) 
Machine:   Type: Laptop System: LG product: 13Z980-A.AAS6U1 v: 0.1 serial: <root required> 
           Mobo: LG model: 13Z980 v: FAB1 serial: <root required> UEFI: Phoenix v: K2ZC0265 X64 date: 07/26/2018 
Battery:   ID-1: CMB0 charge: 51.6 Wh condition: 68.1/72.8 Wh (94%) 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 600 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600 5: 600 6: 600 7: 600 
           8: 600 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: i915 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.2 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.0.0-25-generic 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp3s0 state: up mac: 64:5d:86:50:44:c5 
Drives:    Local Storage: total: 1.16 TiB used: 7.78 GiB (0.7%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
           ID-2: /dev/sda vendor: Samsung model: MZNLN256HAJQ-00000 size: 238.47 GiB 
Partition: ID-1: / size: 218.92 GiB used: 7.77 GiB (3.5%) fs: btrfs dev: /dev/sda3 
           ID-2: /home size: 218.92 GiB used: 7.77 GiB (3.5%) fs: btrfs dev: /dev/sda3 
           ID-3: swap-1 size: 19.07 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 41.0 C mobo: 0.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 285 Uptime: 9h 43m Memory: 19.35 GiB used: 1.26 GiB (6.5%) Shell: bash inxi: 3.0.33 

Last edited by vgivanovic (2019-08-16 19:17:50)


#2 2019-08-16 00:46:01

Registered: 2014-03-06
Posts: 10,971

Re: [SOLVED] Can't install Arch; Ubuntu OK

You could use Install_from_existing_Linux.
Did you verify the signature of the arch iso?  Does the arch usb stick work as expected in another system?


#3 2019-08-16 19:13:08

Registered: 2011-02-18
Posts: 36

Re: [SOLVED] Can't install Arch; Ubuntu OK

SecureBoot was the problem. Once I turned it off, everything worked as expected.

Thanks for your suggestions! They eventually led to a solution.

FYI, I eventually used the Install_from_existing_Linux method you pointed me to. I knew about it, and I had actually built a system using the 'arch-bootstrap' script that's mentioned, but because of SecureBoot, it wouldn't boot either. So I thought it didn't work.

I did learn a couple of things in the process of getting Arch installed. They may seem obvious, but they weren't to me.

  • 'efibootmgr -c' creates a new boot entry in the BIOS boot, regardless of the the '--disk' flag. I was under the impression that 'efibootmgr' wrote a boot block on the disk specified by the '--device' flag. This led to many incorrect conclusions about what 'efibootmgr' was doing, and bafflement when the results didn't fit the model I had in my head.

  • The instructions given in arch-bootstrap refer to a directory called 'myarch'. This should be the root directory of the mounted drive you are installing to (with a corresponding, mounted '/boot'), not some random directory.

  • I bounced back and forth using 'chroot' between my running Ubuntu system and the Arch system I was installing, getting the packages right. In particular, I installed 'arch-install-scripts' and then copied the 'arch-chroot' script to my Ubuntu system and then used it instead of the usual 'chroot'. It takes care of all those pesky mounts that are required to get the Arch system to behave normally.

  • 'arch-bootstrap' is really very good. The part about 'myarch' did lead me astray, and running the script generated some errors which can be ignored, but other than those two minor issues, it worked perfectly.


#4 2019-08-16 19:15:23

Registered: 2011-02-18
Posts: 36

Re: [SOLVED] Can't install Arch; Ubuntu OK

Grrr. Can't see how to mark this topic [SOLVED] ...

Figured it out ...

Last edited by vgivanovic (2019-08-16 19:18:39)


#5 2019-08-16 19:20:36

Registered: 2012-05-26
Posts: 639

Re: [SOLVED] Can't install Arch; Ubuntu OK

You can edit the title of your first post to mark it as [SOLVED]


Board footer

Powered by FluxBB