You are not logged in.

#1 2019-08-18 18:00:48

Ekynox360
Member
Registered: 2019-08-18
Posts: 5

Display artifacts with Xfce

Hello, everyone.

I wonder if you are aware of this display problem (https://imgur.com/uAezKID)? As it stands, I can no longer use Arch with the GUI. This appeared recently after an update. Everything is up to date on my side.

Thank you

Offline

#2 2019-08-18 18:01:56

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,120
Website

Re: Display artifacts with Xfce

What was updated? What is your graphics stack? Please see How To Ask Questions The Smart Way



Moving to NC...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2019-08-18 18:37:59

Ekynox360
Member
Registered: 2019-08-18
Posts: 5

Re: Display artifacts with Xfce

I use:

- X.org X Server 1.20.5
- pixman 0.38.4
- lightdm 1.30.0
- xfce 4.14

Offline

#4 2019-08-18 18:52:47

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,120
Website

Re: Display artifacts with Xfce

Graphics stack means your video card(s) and drivers.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2019-08-18 19:23:41

toz
Member
Registered: 2011-10-28
Posts: 416

Re: Display artifacts with Xfce

Looks like a compositor issue. Try this to see if it helps.

Offline

#6 2019-08-18 19:25:40

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,940
Website

Re: Display artifacts with Xfce

See also https://bbs.archlinux.org/viewtopic.php … 1#p1859321

tl;dr: enable the TearFree option for your (DDX) video driver.

Offline

#7 2019-08-18 19:35:27

Ekynox360
Member
Registered: 2019-08-18
Posts: 5

Re: Display artifacts with Xfce

I have a Ryzen 3 2200G with xf86-video-amdgpu and mesa drivers. On the lightdm welcome page, I don't have these artifacts.

Offline

#8 2019-08-18 19:39:18

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Display artifacts with Xfce

Offline

#9 2019-08-18 22:10:10

toz
Member
Registered: 2011-10-28
Posts: 416

Re: Display artifacts with Xfce

Ekynox360 wrote:

I have a Ryzen 3 2200G with xf86-video-amdgpu and mesa drivers. On the lightdm welcome page, I don't have these artifacts.

Try testing with the compositor vblank mode set to xpresent:

xfwm4 --vblank=xpresent --replace

Offline

#10 2019-08-19 15:16:04

Ekynox360
Member
Registered: 2019-08-18
Posts: 5

Re: Display artifacts with Xfce

toz wrote:

Try testing with the compositor vblank mode set to xpresent:

xfwm4 --vblank=xpresent --replace

When I do this, I no longer have artifact but my windows no longer have a menu bar. Furthermore, an error occurs.

xfwm4-CRITICAL : Xfconf could not be initialized
xfwm4-WARNING: Missing data from default files

Offline

#11 2019-08-19 23:03:05

toz
Member
Registered: 2011-10-28
Posts: 416

Re: Display artifacts with Xfce

You have a bigger issue with your system. You need to figure out why xfconf is not initializing.

- Which display manager are you using and how are you starting X?
- Check your pacman log to make sure all packages updated properly.
- Look at your journal and ~/.xsession-errors.log file if one exists
- Is the xfconfd process running?

Offline

#12 2019-08-20 16:40:55

Ekynox360
Member
Registered: 2019-08-18
Posts: 5

Re: Display artifacts with Xfce

I reinstalled the whole system. It works now.

Last edited by Ekynox360 (2019-09-29 10:24:12)

Offline

Board footer

Powered by FluxBB