You are not logged in.

#1 2019-08-12 15:15:52

abutanaev
Member
From: Russia, Novosibirsk
Registered: 2011-03-29
Posts: 43

[Solved] xfce4 update badly broken

extra/mousepad                0.4.2-1    1 -> 2
extra/ristretto               0.10.0-1   1 -> 2
extra/xfce4-clipman-plugin    1.4.3-1    1 -> 2
extra/xfce4-notifyd           0.4.4-1    1 -> 2
extra/xfce4-terminal          0.8.8-1    1 -> 2
extra/xfce4-xkb-plugin        0.8.1-1    1 -> 2
extra/exo                     0.12.7-1   -> 0.12.8-1
extra/libinput                1.13.4-1   -> 1.14.0-1
extra/libxfce4ui              4.13.7-1   -> 4.14.1-2
extra/libxfce4util            4.13.5-1   -> 4.14.0-1
extra/thunar                  1.8.8-1    -> 1.8.9-2
extra/thunar-volman           0.9.4-1    -> 0.9.5-2
extra/tumbler                 0.2.6-1    -> 0.2.7-1
extra/vim-spell-ru            20180224-1 -> 20190731-1
extra/xfce4-appfinder         4.12.0-5   -> 4.14.0-1
extra/xfce4-datetime-plugin   0.7.1-1    -> 0.8.0-1
extra/xfce4-genmon-plugin     4.0.1-1    -> 4.0.2-1
extra/xfce4-panel             4.12.2-1   -> 4.14.0-1
extra/xfce4-power-manager     1.6.4-1    -> 1.6.5-2
extra/xfce4-pulseaudio-plugin 0.4.1-1    -> 0.4.2-2
extra/xfce4-session           4.12.1-11  -> 4.14.0-2
extra/xfce4-settings          4.12.4-2   -> 4.14.0-1
extra/xfconf                  4.12.1-7   -> 4.14.1-1
extra/xfdesktop               4.13.6-1   -> 4.14.1-2
extra/xfwm4                   4.12.5-1   -> 4.14.0-1

This caused artifacts on the screen (colored little squares), I had to revert the update to be able to work in X. I have Ryzen3 2200G integrated video with 128M memory allocated to video in BIOS

$ lspci |grep -i vga
09:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c8)
$ pacman -Qs xf86-video
local/xf86-video-amdgpu 19.0.1-1 (xorg-drivers)
    X.org amdgpu video driver
local/xf86-video-fbdev 0.5.0-1 (xorg-drivers)
    X.org framebuffer video driver

Last edited by abutanaev (2019-08-13 13:53:26)

Offline

#2 2019-08-12 20:42:44

davinci
Member
Registered: 2019-07-17
Posts: 8

Re: [Solved] xfce4 update badly broken

i can confirm. same cpu. amdgpu driver.
just upgraded xfce4 and it's simply not useable. lots of artifacts whenever stuff gets repainted on screen. even fonts. (even while typing this text)

how did you downgrade and what packages? trying linux-lts now, hope that helps.

edit:
with linux-lts, artifacts are gone for now. but opengl apps are slow and laggy, same just right after updating xfce4 packages.

Last edited by davinci (2019-08-12 20:52:24)

Offline

#3 2019-08-12 20:53:10

nethhb
Member
Registered: 2014-10-17
Posts: 2

Re: [Solved] xfce4 update badly broken

Same here. Lenovo T495, Ryzen 7 Pro 3700U CPU, amdgpu driver.
After the update today I only get a black screen after the login and can't do anything (even another TTY via Ctrl+Alt+F2 is not possible). I can only do a forced power off.

Updated packages:

libinput (1.13.4-1 -> 1.14.0-1)
xfconf (4.12.1-7 -> 4.14.1-1)
libxfce4ui (4.13.7-1 -> 4.14.1-2)
man-db (2.8.5-2 -> 2.8.6.1-1)
man-pages (5.01-1 -> 5.02-1)
mousepad (0.4.2-1 -> 0.4.2-2)
parole (1.0.2-1 -> 1.0.2-2)
python-lxml (4.4.0-1 -> 4.4.1-1)
thunar (1.8.8-1 -> 1.8.9-2)
thunar-volman (0.9.4-1 -> 0.9.5-2)
tumbler (0.2.6-1 -> 0.2.7-1)
xfce4-appfinder (4.12.0-5 -> 4.14.0-1)
xfce4-panel (4.12.2-1 -> 4.14.0-1)
xfce4-clipman-plugin (1.4.3-1 -> 1.4.3-2)
xfce4-genmon-plugin (4.0.1-1 -> 4.0.2-1)
xfce4-notes-plugin (1.8.1-3 -> 1.8.1-4)
xfce4-notifyd (0.4.4-1 -> 0.4.4-2)
xfce4-power-manager (1.6.4-1 -> 1.6.5-2)
xfce4-pulseaudio-plugin (0.4.2-1 -> 0.4.2-2)
xfce4-session (4.12.1-11 -> 4.14.0-2)
xfce4-settings (4.12.4-2 -> 4.14.0-1)
xfce4-terminal (0.8.8-1 -> 0.8.8-2)
xfce4-xkb-plugin (0.8.1-1 -> 0.8.1-2)
xfdesktop (4.14.0-1 -> 4.14.1-2)
xfwm4 (4.12.5-1 -> 4.14.0-1)
xorg-xrandr (1.5.0-2 -> 1.5.1-1)

Not the problem:
gst-plugins-bad (1.16.0-4 -> 1.16.0-5)
ristretto (0.10.0-1 -> 0.10.0-2)
xf86-video-intel (1:2.99.917+865+g60022507-1 -> 1:2.99.917+870+g6f4972d5-1)
vulkan-icd-loader (1.1.115-1 -> 1.1.117-1)

@davinci: downgrading packages: https://wiki.archlinux.org/index.php/Do … g_packages
I did it via Arch Linux Archive in pacman.conf. The state of 2019-08-11 does work.

Last edited by nethhb (2019-08-12 21:05:13)

Offline

#4 2019-08-12 21:01:55

toz
Member
Registered: 2011-10-28
Posts: 417

Re: [Solved] xfce4 update badly broken

Does it make a difference if you disable the compositor?

Offline

#5 2019-08-12 21:04:53

davinci
Member
Registered: 2019-07-17
Posts: 8

Re: [Solved] xfce4 update badly broken

toz wrote:

Does it make a difference if you disable the compositor?

How can i do that?

Offline

#6 2019-08-12 21:09:38

toz
Member
Registered: 2011-10-28
Posts: 417

Re: [Solved] xfce4 update badly broken

Settings Manager > Window Manager Tweaks > Compositor and uncheck "Enable display compositing".

Also try with compositor enabled and "Display fullscreen overlay windows directly" unchecked.

Offline

#7 2019-08-12 21:13:03

davinci
Member
Registered: 2019-07-17
Posts: 8

Re: [Solved] xfce4 update badly broken

nethhb wrote:

@davinci: downgrading packages: https://wiki.archlinux.org/index.php/Do … g_packages
I did it via Arch Linux Archive in pacman.conf. The state of 2019-08-11 does work.

Thanks, worked for me too.

@toz: will try

Offline

#8 2019-08-12 21:15:28

toz
Member
Registered: 2011-10-28
Posts: 417

Re: [Solved] xfce4 update badly broken

One other thing to try is to change the vblank mode. There are 3 options: glx (the default), off and xpresent. To do so, run the following commands to see if one works better than the other (with the compositor enabled):

xfwm4 --vblank=off --replace
xfwm4 --vblank=xpresent --replace
xfwm4 --vblank=glx --replace

Offline

#9 2019-08-12 21:17:08

davinci
Member
Registered: 2019-07-17
Posts: 8

Re: [Solved] xfce4 update badly broken

toz wrote:

Settings Manager > Window Manager Tweaks > Compositor and uncheck "Enable display compositing".

Also try with compositor enabled and "Display fullscreen overlay windows directly" unchecked.

Works fine without compositor.

edit:
But "Display fullscreen overlay windows directly" unchecked alone doesn't help.

xfwm4 --vblank=off --replace # works
xfwm4 --vblank=xpresent --replace # works
xfwm4 --vblank=glx --replace # doesn't work - artifacts

Last edited by davinci (2019-08-12 21:31:45)

Offline

#10 2019-08-12 22:24:34

toz
Member
Registered: 2011-10-28
Posts: 417

Re: [Solved] xfce4 update badly broken

davinci wrote:

xfwm4 --vblank=off --replace # works
xfwm4 --vblank=xpresent --replace # works

Cool. You can make it permanent with the following command:

xfconf-query -c xfwm4 -p /general/vblank_mode -s MODE

...where MODE is one of (in your case) "xpresent" or "off". Try both over the next little while to see which one generates the best performance.

Offline

#11 2019-08-13 13:52:50

abutanaev
Member
From: Russia, Novosibirsk
Registered: 2011-03-29
Posts: 43

Re: [Solved] xfce4 update badly broken

xfconf-query -c xfwm4 -p /general/vblank_mode -s xpresent

Works for me

Offline

#12 2019-08-13 16:02:59

nethhb
Member
Registered: 2014-10-17
Posts: 2

Re: [Solved] xfce4 update badly broken

@toz: Thank you for the tip about compositing. The combination of compositing=on and vblank=off worked for me too.

If somebody else finds this thread and is like me in the situation that he get only a black screen after the login: you can run the following command on the command line to turn off compositing:

xfconf-query -c xfwm4 -p /general/use_compositing -s false

Offline

#13 2019-08-13 17:59:26

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

nethhb wrote:

@toz: Thank you for the tip about compositing. The combination of compositing=on and vblank=off worked for me too.

If somebody else finds this thread and is like me in the situation that he get only a black screen after the login: you can run the following command on the command line to turn off compositing:

xfconf-query -c xfwm4 -p /general/use_compositing -s false

I've had xfdesktop on ignore since 4.12.4-2 because any version 4.13 messed up compositing badly - 4.13 was a developmental version from what I read. I thought yesterday when I seen everything had gone to 4.14 it would be OK to update.
I was wrong, I downgraded everything to 2019-08-11 like others did and that worked.

What about if you use Compiz instead of Xfwm4?

Do you think that changing window managers to Xfwm4 do the above, Compiz would then work too?

BRB, trying that...


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#14 2019-08-13 21:25:02

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

Nope that did not work for me.

xfconf-query -c xfwm4 -p /general/use_compositing -s false

This left me with about 2 or so inches at the bottom black. Like when compositing is off.

All of my conkys had a black background too. I downgraded back like it was (to 2019/08/11) but, my conkys still have a black background and no opacity.

I'm also confused - that command appears to turn compositing off but nethhb said "The combination of compositing=on and vblank=off worked for me too."


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#15 2019-08-13 21:36:21

Omar007
Member
Registered: 2015-04-09
Posts: 334

Re: [Solved] xfce4 update badly broken

That command does seem to turn compositing off so that statement combined with the command he posted seems a bit odd.
Based on what he said I'd have expected something along the lines of:

xfconf-query -c xfwm4 -p /general/use_compositing -s true    # Which would be the default if you didn't change it?
xfconf-query -c xfwm4 -p /general/vblank_mode -s off         # Where off = MODE as mentioned by toz

Offline

#16 2019-08-13 22:47:47

toz
Member
Registered: 2011-10-28
Posts: 417

Re: [Solved] xfce4 update badly broken

The first command is a CLI method of enabling/disabling compositing. If you don't have access to the GUI (if compositing is interfering), this is one way to disable it. Most people will want compositing enabled so it should eventually be set to true.

The second command is the CLI method to set the vblank mode. xfwm4 now supports 3 modes: "glx" (the default), "off" and "xpresent" (the preferred - but doesn't work for all systems - apparently nvidia doesn't support this). You can test each one individually to see which works best for your system and set it permanently using this command. If the vblank_mode xfconf property isn't set, it defaults to "glx". Note: you can also specify the vblank mode as a parameter to xfwm4 (--vblank=glx|off|xpresent), so its also possible to set the vblank mode by passing a parameter to the executable.

Offline

#17 2019-08-14 17:14:38

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

I'm still confused. I allowed the update to go through and have no wallpaper, just a black screen and no panels; I have (or should say had) a bottom panel too but, with the update neither.
Lucky I could get to Cairo Dock to get to terminal and applications. I set everything back to 2019-08-11 and it all works.

One thing is puzzling even without the update: I thought I could use the conkys I had on Fedora 30 with updated Arch. They have been using xfdesktop 4.13 since it came out and conky compositing and transparency requires changes to the conkyrc files.
So, I copied all my conky files from Fedora to Arch and they work but, not with the 4.14 version of the Xfce4 packages, the older ones 4.12.
The commented out lines worked before (override) and now the uncommented out lines work. That is what is puzzling me.

	-- Create 'own_window' type. Makes Conky behave like other panels.
	--own_window = true,
-------------------------------------------------------------
-- change this if you are not getting any conky display
-- options are: normal, desktop, dock, panel or override (default: normal)
-------------------------------------------------------------
	--own_window_type = 'override',
	-----own_window_type = 'desktop',
	-----own_window_hints = 'below,sticky,undecorated,skip_taskbar,skip_pager',
	-----own_window_transparent = true,
	-----own_window_class = 'Conky',
	-----own_window_argb_visual = true,
	-----own_window_argb_value = 165,
    own_window = true,
    own_window_type = 'normal',
    own_window_transparent = false,
    own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager',
    own_window_argb_visual = true,
    own_window_argb_value = 0,

aq6eH0am.jpg


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#18 2019-08-14 19:52:12

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

I did some research and the reason that Arch needed the changes in the conky files was because version 4.13 of xfdesktop had somehow gotten installed. Just like on Fedora 30.
So, the conky files worked perfectly after I downgraded xfdesktop back to 4.12.

I booted into openSUSE Tumbleweed (rolling) and found that they also use xfdesktop 4.12.

A little more research and just these files want to go to 4.14 and cause this disastrous compositing issue so I put them on ignore in /etc/pacman.conf.

warning: xfce4-appfinder: ignoring package upgrade (4.12.0-5 => 4.14.0-1)
warning: xfce4-panel: ignoring package upgrade (4.12.2-1 => 4.14.0-1)
warning: xfce4-session: ignoring package upgrade (4.12.1-11 => 4.14.0-2)
warning: xfce4-settings: ignoring package upgrade (4.12.4-2 => 4.14.0-1)
warning: xfconf: ignoring package upgrade (4.12.1-7 => 4.14.1-1)
warning: xfdesktop: ignoring package upgrade (4.12.4-2 => 4.14.1-2)
warning: xfwm4: ignoring package upgrade (4.12.5-1 => 4.14.0-1)

They're going to stay on ignore until the cows come home as far as I care. tongue

I hope the devs figure this out in due time.


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#19 2019-08-14 20:39:06

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

Naw, scratch the above post. That was a bad idea.

I downgraded everything to 4.12 neutral

I need compositing.


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#20 2019-08-15 17:57:40

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

Xfdesktop somehow had upgraded to version 4.13; hence the compositing problem. So I downgraded that to 4.12 with downgrade from the AUR.

I backed everything to that last good day 2019/08/11 and then took a hard look at the packages that were to be installed and their dependencies.

Now I have 37 packages on hold.

IgnorePkg   = xfdesktop mousepad ristretto xfce4-clipman-plugin xfce4-notes-plugin xfce4-notifyd xfce4-terminal xfce4-xkb-plugin exo harfbuzz harfbuzz-icu libxfce4ui libxfce4util pango python-lxml python-lxml-docs thunar thunar-volman xfce4-appfinder xfce4-battery-plugin xfce4-datetime-plugin xfce4-diskperf-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-mpc-plugin xfce4-netload-plugin xfce4-panel xfce4-power-manager xfce4-pulseaudio-plugin xfce4-session xfce4-settings xfce4-smartbookmark-plugin xfce4-systemload-plugin xfce4-time-out-plugin xfce4-wavelan-plugin xfconf xfdesktop xfwm4

Now, I'm back to a usable system. I don't know what is to come. That is part of the fun though right? tongue

At some point I may need to look at what you all did to solve this but, for now I'm good.


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#21 2019-08-18 19:23:24

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,940
Website

Re: [Solved] xfce4 update badly broken

Bumping this thread to note that I don't experience the corruption problems with the Xfce compositor if I enable the TearFree option for xf86-video-amdgpu (Ryzen 5 2500u & Vega 8 graphics). With the TearFree option enabled I can use either the glx or xpresent backends with no problems; without TearFree the glx backend corrupts badly during any screen movements but xpresent does not (but the tearing control isn't brilliant).

@Cavsfan, do you have an AMD card? If so then try enabling the TearFree option. Or perhaps use conky instead:

conky -B --backend glx

That should prevent tearing better than the Xfce compositor (but not as well as xf86-video-amdgpu) and still offer transparency and drop-shadows.

Offline

#22 2019-08-18 20:19:32

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

Head_on_a_Stick wrote:

@Cavsfan, do you have an AMD card?

No I have a Nvidia card:

[cavsfan@ArchLinux ~]$ inxi -G
Graphics:  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] driver: nvidia v: 430.40 
           Display: tty server: X.org 1.20.5 driver: nvidia resolution: 3840x2160 
           OpenGL: renderer: GeForce GTX 980 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 

So, no one has compositing now with the latest Xfce4 update? No one is using Compiz either? Is this correct?


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#23 2019-08-18 22:08:44

grinner
Member
Registered: 2019-06-28
Posts: 23

Re: [Solved] xfce4 update badly broken

I had a seamless update without composition problems - nvidia using compton.  I can't comment about compiz but my understanding of this thread, and one or two others like it, is that the recent composition problems are with the (native) xfwm4 compositor and amdgpu drivers.  Perhaps you have a different problem?

Last edited by grinner (2019-08-18 22:11:00)

Offline

#24 2019-08-19 12:52:28

TheSgtBilko
Member
Registered: 2013-08-13
Posts: 45

Re: [Solved] xfce4 update badly broken

Cavsfan wrote:

So, no one has compositing now with the latest Xfce4 update? No one is using Compiz either? Is this correct?

I have a three monitor system with nvidia gtx780Ti + gtx460 running nouveau drivers with xfce4 compositor enabled. No issues like yours.

Only issue I have is with display settings coredumping most of the time, which is already known and worked upon upstream.

Offline

#25 2019-08-19 15:14:11

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,940
Website

Re: [Solved] xfce4 update badly broken

Cavsfan wrote:

I have a Nvidia card

Try https://wiki.archlinux.org/index.php/NV … en_tearing and see if that fixes things.

Offline

Board footer

Powered by FluxBB