You are not logged in.

#1 2019-08-21 12:40:19

tsj
Member
Registered: 2017-07-06
Posts: 1

Headphone and speaker channels conflated in alsamixer

My system is confused about controls for the headphone and speaker channels. I use pulseaudio, but the behavior I'm about to describe persists after I do `pulseaudio -k` (repeatedly until it's really dead). The settings in alsamixer on startup seem to be ~20% Master (unmuted), 0% Headphone (muted), and 100% Speaker (unmuted). With no headphones plugged in, no sound comes out of the speakers. The speakers are only audible after increasing the level of the Headphone channel. Unmuting/muting of the Headphone channel has no effect. Reducing the Speaker level to 0% has no effect. Muting the Speaker channel, however, mutes the speakers. In short, I have to have >0% volume in Headphone, and unmuted Speaker to hear the speakers. If I plug in headphones, things seem normal: speakers are silent regardless of the Speaker channel, and the Headphone channel (volume and mute/unmute) correctly controls headphone output.

Output of alsa-info.sh is here:
http://alsa-project.org/db/?f=dbe50accc … 82d73efc0f

I'm not familiar with the alsa world, or udev if that's involved. Looking for help, thanks.

Offline

#2 2019-08-21 12:53:04

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,600

Re: Headphone and speaker channels conflated in alsamixer

Because it reads related, try what behaviour you get after setting

amixer -c0 set 'Independent HP',0 'Enabled'

If it works cool, if it doesn't you might get some results with overriding specific jacks using hdajackretask. You will want to have pulse stopped for that (FWIW the proper way to do that is

systemd --user mask pulseaudio.socket #It's the active socket that leads to pulse restarting itself because applications are trying to use pulse
systemctl --user stop pulseaudio
#Do non-pulse stuff...
systemctl --user unmask pulseaudio.socket #Reenable autospawn
systemctl --user start pulseaudio

Offline

Board footer

Powered by FluxBB