You are not logged in.

#26 2019-08-21 15:38:04

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

grinner wrote:

I had a seamless update without composition problems - nvidia using compton.  I can't comment about compiz but my understanding of this thread, and one or two others like it, is that the recent composition problems are with the (native) xfwm4 compositor and amdgpu drivers.  Perhaps you have a different problem?

No, same problem Nvidia card and neither xfwm4 window manager or compiz window manager display compositing correctly; zero opacity, black background, lost my wallpaper and cannot set a wallpaper, etc.
This started when the xfdesktop package wanted to update from 4.12 to 4.13.
See this thread: https://bbs.archlinux.org/viewtopic.php?id=244801
Particularly post #12.

I, and others I believe, had xfdesktop on ignore to keep it at 4.12

Head_on_a_Stick wrote:
Cavsfan wrote:

I have a Nvidia card

Try https://wiki.archlinux.org/index.php/NV … en_tearing and see if that fixes things.

I do not have any tearing issue, just the compositing - black background, losing my wallpaper and not being able to set the wallpaper, etc.


TheSgtBilko wrote:
Cavsfan wrote:

So, no one has compositing now with the latest Xfce4 update? No one is using Compiz either? Is this correct?

I have a three monitor system with nvidia gtx780Ti + gtx460 running nouveau drivers with xfce4 compositor enabled. No issues like yours.

Only issue I have is with display settings coredumping most of the time, which is already known and worked upon upstream.

Not sure what to say. I know that my Nvidia driver is not causing it. Do you have any conkys that work with xfce4 compositor enabled?

openSUSE Tumbleweed has Xfwm4 version 4.12 and there are zero problems of course.

Fedora 30 is using 4.13, which does have a compositing problem with conkys but, it can be worked around by not using override, etc. in the conkyrc file.

I've tried on Arch with 4.14 and nothing changed inside a conky file fixes this problem. I'll keep these 37 files. at 4.12 for as long as I can.

warning: exo: ignoring package upgrade (0.12.7-1 => 0.12.8-1)
warning: harfbuzz: ignoring package upgrade (2.5.3-1 => 2.6.0-1)
warning: harfbuzz-icu: ignoring package upgrade (2.5.3-1 => 2.6.0-1)
warning: libxfce4ui: ignoring package upgrade (4.13.7-1 => 4.14.1-2)
warning: libxfce4util: ignoring package upgrade (4.13.5-1 => 4.14.0-1)
warning: mousepad: ignoring package upgrade (0.4.2-1 => 0.4.2-2)
warning: pango: ignoring package upgrade (1:1.44.3-1 => 1:1.44.5-1)
warning: python-lxml: ignoring package upgrade (4.4.0-1 => 4.4.1-1)
warning: python-lxml-docs: ignoring package upgrade (4.4.0-1 => 4.4.1-1)
warning: ristretto: ignoring package upgrade (0.10.0-1 => 0.10.0-2)
warning: thunar: ignoring package upgrade (1.8.8-1 => 1.8.9-2)
warning: thunar-volman: ignoring package upgrade (0.9.4-1 => 0.9.5-2)
warning: xfce4-appfinder: ignoring package upgrade (4.12.0-5 => 4.14.0-1)
warning: xfce4-battery-plugin: ignoring package upgrade (1.1.2-1 => 1.1.3-1)
warning: xfce4-clipman-plugin: ignoring package upgrade (1.4.3-1 => 1.4.3-2)
warning: xfce4-datetime-plugin: ignoring package upgrade (0.7.1-1 => 0.8.0-1)
warning: xfce4-diskperf-plugin: ignoring package upgrade (2.6.1-2 => 2.6.2-1)
warning: xfce4-fsguard-plugin: ignoring package upgrade (1.1.0-2 => 1.1.1-1)
warning: xfce4-genmon-plugin: ignoring package upgrade (4.0.1-1 => 4.0.2-1)
warning: xfce4-mpc-plugin: ignoring package upgrade (0.5.1-1 => 0.5.2-1)
warning: xfce4-netload-plugin: ignoring package upgrade (1.3.1-2 => 1.3.2-1)
warning: xfce4-notes-plugin: ignoring package upgrade (1.8.1-3 => 1.8.1-4)
warning: xfce4-notifyd: ignoring package upgrade (0.4.4-1 => 0.4.4-2)
warning: xfce4-panel: ignoring package upgrade (4.12.2-1 => 4.14.0-1)
warning: xfce4-power-manager: ignoring package upgrade (1.6.4-1 => 1.6.5-2)
warning: xfce4-pulseaudio-plugin: ignoring package upgrade (0.4.1-1 => 0.4.2-2)
warning: xfce4-session: ignoring package upgrade (4.12.1-11 => 4.14.0-2)
warning: xfce4-settings: ignoring package upgrade (4.12.4-2 => 4.14.0-1)
warning: xfce4-smartbookmark-plugin: ignoring package upgrade (0.5.0-2 => 0.5.1-1)
warning: xfce4-systemload-plugin: ignoring package upgrade (1.2.2-1 => 1.2.3-1)
warning: xfce4-terminal: ignoring package upgrade (0.8.8-1 => 0.8.8-2)
warning: xfce4-time-out-plugin: ignoring package upgrade (1.0.2-3 => 1.0.3-1)
warning: xfce4-wavelan-plugin: ignoring package upgrade (0.6.0-2 => 0.6.1-1)
warning: xfce4-xkb-plugin: ignoring package upgrade (0.8.1-1 => 0.8.1-2)
warning: xfconf: ignoring package upgrade (4.12.1-7 => 4.14.1-1)
warning: xfdesktop: ignoring package upgrade (4.12.4-2 => 4.14.1-2)
warning: xfwm4: ignoring package upgrade (4.12.5-1 => 4.14.0-1)

This thread was marked solved too early IMO because the problem is not fixed.

Arch Linux is the only system that I know of that went to Xfwm4 4.14 and caused this. 

I am aware Arch Linux is bleeding edge but, putting Xfwm4 4.13 and now 4.14 into production was a mistake IMO.
I just hope the devs are aware of it and do something.


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

#27 2019-08-22 21:35:35

TheSgtBilko
Member
Registered: 2013-08-13
Posts: 45

Re: [Solved] xfce4 update badly broken

Cavsfan wrote:
TheSgtBilko wrote:
Cavsfan wrote:

So, no one has compositing now with the latest Xfce4 update? No one is using Compiz either? Is this correct?

I have a three monitor system with nvidia gtx780Ti + gtx460 running nouveau drivers with xfce4 compositor enabled. No issues like yours.

Only issue I have is with display settings coredumping most of the time, which is already known and worked upon upstream.

Not sure what to say. I know that my Nvidia driver is not causing it. Do you have any conkys that work with xfce4 compositor enabled?

I don't use conky.

Offline

#28 2019-08-25 20:23:36

Cavsfan
Member
From: USA
Registered: 2015-07-08
Posts: 91

Re: [Solved] xfce4 update badly broken

I finally figured this out. I had to remove compiz, emerald, fusion-icon, etc. then rebooted.

Then I took everything off ignore and let it update to 4.14 and rebooted. Everything looked great.

Then I reinstalled the stuff I deleted, all of which came from the AUR and rebooted to a nightmare; same exact thing I had - no panel, no cairo dock, no way to logout or restart.
But, that was because I had a startup command of fusion-icon -f which starts all of it

So, I got to TTY2 and removed just the fusion-icon and rebooted. All was swell.

I unchecked fusion-icon from the startup applications, reinstalled the fusion-icon and rebooted.

Everything looked good. I could then start the fusion-icon and it all worked. I just cannot have it auto start.
The Conkys can't use override, etc. anymore but, they work like they did pretty much.

Compiz, Emerald and the Fusion Icon all work perfectly as long as you start them manually.

My problem is also solved now. cool

aCEwNVfm.jpg

Edit: forgot to change the distro name on the one conky. hmm

Last edited by Cavsfan (2019-08-25 22:24:05)


Wiki for Creating a Custom Maintenance Free GRUB2 Screen for Debian based Legacy/MBR and UEFI/GPT systems
Arch Linux Custom Grub is exactly the same with the exception of the font colors and background being in /etc/default/grub.

Offline

Board footer

Powered by FluxBB