You are not logged in.

#1 2019-05-25 17:52:51

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

nvidia 390xx with kernel 5.1.x

Since kernel 5.1 I have problems with the stability of my system. It stops booting most of the time giving an error like

"kernel: [drm:nv_drm_master_drop [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] nv_drm_atomic_helper_disable_all failed with error code -22 !" and

"BUG: unable to handle kernel paging request at ffffe8feb2b9cd88
May 25 19:23:36 arch.localhost kernel: #PF error: [normal kernel read fault]"

My system currently:
nvidia-390xx-dkms  390.116-23
5.1.4-arch1-1-ARCH

Other users experiencing similar problems? I am on an LVM with LUKS and Samsung SSD. However no problems with LUKS-header etc.

Offline

#2 2019-05-26 20:59:29

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

Since installing kernel 5.1.5 the problems have gone.
It most probably had to do with this recent kernel bug - Linux 5.1.5 Kernel Fixes The Latest Data Corruption Bug

Offline

#3 2019-05-28 07:33:08

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

Well, as it turns out I was too quick drawing conclusions. After installing 5.1.5-arch1-2-ARCH the problem returned. I think I'll timeshift back to 5.1.5-arch1-1-ARCH, that seemed to have less problems.

Offline

#4 2019-05-29 22:01:44

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

I figured out the cause of the problem, quite unexpectedly. As it turns out it was caused by the presence of a double user account folder in [var/lib].
One folder was correctly named [AccountsService], but there was a second map called [accountsservice]. It was somehow created in the past. I have no idea if it was created by a program or by myself.

For some reason this caused all the previous kernels not to fail during boot, but 5.1 must be picky.

Offline

#5 2019-05-31 20:54:17

Dextrey1
Member
Registered: 2019-05-31
Posts: 2

Re: nvidia 390xx with kernel 5.1.x

I'm having the exact same problem with same software versions.

Han Vinke wrote:

I figured out the cause of the problem, quite unexpectedly. As it turns out it was caused by the presence of a double user account folder in [var/lib].
One folder was correctly named [AccountsService], but there was a second map called [accountsservice]. It was somehow created in the past. I have no idea if it was created by a program or by myself.

For some reason this caused all the previous kernels not to fail during boot, but 5.1 must be picky.

How did you determine this was the cause of the problem in your case? I don't have AccountsService installed and thus don't have those folders in /var/lib but the kernel is always segfaulting whenever I try to start Xorg.

Offline

#6 2019-06-03 14:13:35

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

@Dextrey1

I thought I was the only one experiencing errors.
I admit I am still having problems, but way less after that change. The usual boot error now has changed to: [cinnamon-session: GLib-GIO-CRITICAL: t+9525.01187s: g_dbus_connection_call_sync_internal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed]. Also  seeing: [kernel: BUG: unable to handle kernel paging request at ffffff0e7d000008]. But those error messages might have changed by upgrading to 5.1.6-arch1-1-ARCH and Cinnamon 4.0.10.

Starting a few times in fallback mode usually helps booting normally. Maybe changing some hooks or modules in mkninitcpio.conf help. Still testing.....

Offline

#7 2019-06-03 16:08:35

Dextrey1
Member
Registered: 2019-05-31
Posts: 2

Re: nvidia 390xx with kernel 5.1.x

Han Vinke wrote:

@Dextrey1

I thought I was the only one experiencing errors.
I admit I am still having problems, but way less after that change. The usual boot error now has changed to: [cinnamon-session: GLib-GIO-CRITICAL: t+9525.01187s: g_dbus_connection_call_sync_internal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed]. Also  seeing: [kernel: BUG: unable to handle kernel paging request at ffffff0e7d000008]. But those error messages might have changed by upgrading to 5.1.6-arch1-1-ARCH and Cinnamon 4.0.10.

Starting a few times in fallback mode usually helps booting normally. Maybe changing some hooks or modules in mkninitcpio.conf help. Still testing.....

It seems to be a problem with either the new kernel versions or the proprietary Nvidia driver.  I downgraded to the 5.0.3-arch1-1-ARCH kernel (with the matching Nvidia driver version) and the system works fine.  Open source Nouveau driver also mitigates the problem even with the latest kernel.

Offline

#8 2019-06-04 06:13:31

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

I am currently testing different settings. The first one with a disabled DRM KMS for nvidia. That seems to work fine. According to NVIDIA its DRM KMS support is still considered experimental.
When on the other hand trying with early KMS enabled, it seems the option drm.edid_firmware=[/PATH-TO_EDID.BIN]/edid.bin in grub is also important. I am still holding my breath but so far, so good.
To create a valid edid.bin for your monitor you can use nvidia-settings.

Offline

#9 2019-06-04 07:11:50

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

Sorry, did not read your last reply carefully. If even nouveau mitigates the problem then it is obviously not an nvidia problem.

Offline

#10 2019-06-04 07:19:29

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

@Dextry1

Did you also test Nouveau with modeset=0 option, by any chance, to disable KMS?

Offline

#11 2019-06-08 21:36:02

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

I have tested again with another (newer gtx1060) video card. With 390xx drivers - same problem. Installed 430.14 driver - not a single boot failed, no errors at all.

So my guess: this Data Loss Bug Due To Overly Aggressive FSTRIM appearing in kernel 5.1 is only solved for the 430.14 driver, but still present in the legacy 390xx series driver.

Offline

#12 2019-06-22 22:42:57

andrejr
Member
Registered: 2018-05-25
Posts: 2

Re: nvidia 390xx with kernel 5.1.x

Any news? Have you tried again after all of the kernel and nvidia updates that came out in the past few days?

Offline

#13 2019-06-23 10:37:14

Han Vinke
Member
Registered: 2017-02-18
Posts: 18

Re: nvidia 390xx with kernel 5.1.x

Actually since now I have a newer nvidia card (NVIDIA Corporation GP106 [GeForce GTX 1060 6GB]), I have sticked to using the 430.xx drivers. Not a single issue with the same configuration as with 390xx. I am currently using kernel 5.1.14-arch1-1-ARCH and nvidia 430.26-1. Unfortunately it is not so easy to go back to the older videocard, so it is not my intend to check whether the problem persists with the 390.xx drivers. Also with this newer card it is possible to install the 390.xx drivers. Will do that after making backup and timeshift. Do not have much time at the moment though.

Offline

#14 2019-07-13 08:55:01

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 496

Re: nvidia 390xx with kernel 5.1.x

Not sure if it is the same problem, but after yesterdays updates (stable branch, nvidia-390xx-dkms got updated from 390.116-35 to 390.116-36) I get artefacts on the screen followed by a complete freeze with the following Xorg.0.log:

[    22.633] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    22.633] 
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[    22.633] Build Operating System: Linux Arch Linux
[    22.633] Current Operating System: Linux photon-desktop 5.2.0-arch2-1-ARCH #1 SMP PREEMPT Mon Jul 8 18:18:54 UTC 2019 x86_64
[    22.633] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=ee1ea990-6c28-415b-a617-7310aec3dcc2 rw quiet iommu=soft
[    22.633] Build Date: 30 June 2019  09:52:01AM
[    22.633]  
[    22.633] Current version of pixman: 0.38.4
[    22.633] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    22.633] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.633] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 13 10:44:17 2019
[    22.639] (==) Using config file: "/etc/X11/xorg.conf"
[    22.639] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    22.639] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    22.641] (==) ServerLayout "Layout0"
[    22.641] (**) |-->Screen "Screen0" (0)
[    22.641] (**) |   |-->Monitor "Monitor0"
[    22.642] (**) |   |-->Device "Device0"
[    22.642] (**) |-->Input Device "Keyboard0"
[    22.642] (**) |-->Input Device "Mouse0"
[    22.642] (==) Automatically adding devices
[    22.642] (==) Automatically enabling devices
[    22.642] (==) Automatically adding GPU devices
[    22.642] (==) Automatically binding GPU devices
[    22.642] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    22.652] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[    22.652] (==) ModulePath set to "/usr/lib/xorg/modules"
[    22.652] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    22.652] (WW) Disabling Keyboard0
[    22.652] (WW) Disabling Mouse0
[    22.652] (II) Module ABI versions:
[    22.652] 	X.Org ANSI C Emulation: 0.4
[    22.652] 	X.Org Video Driver: 24.0
[    22.652] 	X.Org XInput driver : 24.1
[    22.652] 	X.Org Server Extension : 10.0
[    22.653] (++) using VT number 1

[    22.655] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    22.656] (II) xfree86: Adding drm device (/dev/dri/card0)
[    22.656] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[    22.658] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[    22.658] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[    22.659] (--) PCI:*(1@0:0:0) 10de:1200:1462:2382 rev 161, Mem @ 0xf4000000/33554432, 0xe8000000/134217728, 0xf0000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    22.659] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    22.659] (II) LoadModule: "glx"
[    22.660] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[    22.723] (II) Module glx: vendor="NVIDIA Corporation"
[    22.723] 	compiled for 4.0.2, module version = 1.0.0
[    22.723] 	Module class: X.Org Server Extension
[    22.724] (II) NVIDIA GLX Module  390.116  Sun Jan 27 06:24:32 PST 2019
[    22.725] (II) LoadModule: "nvidia"
[    22.733] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    22.744] (II) Module nvidia: vendor="NVIDIA Corporation"
[    22.744] 	compiled for 4.0.2, module version = 1.0.0
[    22.744] 	Module class: X.Org Video Driver
[    22.745] (II) NVIDIA dlloader X Driver  390.116  Sun Jan 27 05:57:42 PST 2019
[    22.745] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    22.746] (II) systemd-logind: releasing fd for 226:0
[    22.747] (II) Loading sub module "fb"
[    22.747] (II) LoadModule: "fb"
[    22.749] (II) Loading /usr/lib/xorg/modules/libfb.so
[    22.751] (II) Module fb: vendor="X.Org Foundation"
[    22.751] 	compiled for 1.20.5, module version = 1.0.0
[    22.751] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    22.751] (II) Loading sub module "wfb"
[    22.751] (II) LoadModule: "wfb"
[    22.751] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    22.753] (II) Module wfb: vendor="X.Org Foundation"
[    22.753] 	compiled for 1.20.5, module version = 1.0.0
[    22.753] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    22.753] (II) Loading sub module "ramdac"
[    22.753] (II) LoadModule: "ramdac"
[    22.753] (II) Module "ramdac" already built-in
[    22.756] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    22.756] (==) NVIDIA(0): RGB weight 888
[    22.756] (==) NVIDIA(0): Default visual is TrueColor
[    22.756] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    22.757] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[    22.757] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[    22.757] (**) NVIDIA(0): Option "Coolbits" "4"
[    22.757] (**) NVIDIA(0): Enabling 2D acceleration
[    23.286] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    23.286] (--) NVIDIA(0):     CRT-0
[    23.286] (--) NVIDIA(0):     CRT-1
[    23.286] (--) NVIDIA(0):     DFP-0
[    23.286] (--) NVIDIA(0):     DFP-1 (boot)
[    23.286] (--) NVIDIA(0):     DFP-2
[    23.287] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 560 Ti (GF114) at PCI:1:0:0 (GPU-0)
[    23.287] (--) NVIDIA(0): Memory: 1048576 kBytes
[    23.287] (--) NVIDIA(0): VideoBIOS: 70.24.11.00.00
[    23.287] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    23.289] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    23.289] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    23.289] (--) NVIDIA(GPU-0): 
[    23.292] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    23.292] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    23.292] (--) NVIDIA(GPU-0): 
[    23.294] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    23.294] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[    23.294] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    23.294] (--) NVIDIA(GPU-0): 
[    23.326] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): connected
[    23.326] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): Internal TMDS
[    23.326] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): 225.0 MHz maximum pixel clock
[    23.326] (--) NVIDIA(GPU-0): 
[    23.329] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    23.329] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    23.329] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    23.329] (--) NVIDIA(GPU-0): 
[    23.331] (==) NVIDIA(0): 
[    23.331] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    23.331] (==) NVIDIA(0):     will be used as the requested mode.
[    23.331] (==) NVIDIA(0): 
[    23.331] (II) NVIDIA(0): Validated MetaModes:
[    23.331] (II) NVIDIA(0):     "DFP-1:nvidia-auto-select"
[    23.331] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[    23.335] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[    23.335] (--) NVIDIA(0):     option
[    23.335] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[    23.335] (II) NVIDIA:     access.
[    23.336] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    23.336] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    23.336] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    23.336] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    23.336] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    23.336] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    23.336] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    23.336] (II) NVIDIA(0):     Config Options in the README.
[    23.350] (II) NVIDIA(0): Setting mode "DFP-1:nvidia-auto-select"
[    23.405] (==) NVIDIA(0): Disabling shared memory pixmaps
[    23.405] (==) NVIDIA(0): Backing store enabled
[    23.405] (==) NVIDIA(0): Silken mouse disabled
[    23.405] (**) NVIDIA(0): DPMS enabled
[    23.405] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[    23.405] (II) Loading sub module "dri2"
[    23.405] (II) LoadModule: "dri2"
[    23.405] (II) Module "dri2" already built-in
[    23.405] (II) NVIDIA(0): [DRI2] Setup complete
[    23.405] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    23.406] (II) Initializing extension Generic Event Extension
[    23.406] (II) Initializing extension SHAPE
[    23.406] (II) Initializing extension MIT-SHM
[    23.406] (II) Initializing extension XInputExtension
[    23.406] (II) Initializing extension XTEST
[    23.406] (II) Initializing extension BIG-REQUESTS
[    23.406] (II) Initializing extension SYNC
[    23.406] (II) Initializing extension XKEYBOARD
[    23.406] (II) Initializing extension XC-MISC
[    23.406] (II) Initializing extension SECURITY
[    23.406] (II) Initializing extension XFIXES
[    23.406] (II) Initializing extension RENDER
[    23.406] (II) Initializing extension RANDR
[    23.406] (II) Initializing extension COMPOSITE
[    23.406] (II) Initializing extension DAMAGE
[    23.406] (II) Initializing extension MIT-SCREEN-SAVER
[    23.406] (II) Initializing extension DOUBLE-BUFFER
[    23.407] (II) Initializing extension RECORD
[    23.407] (II) Initializing extension DPMS
[    23.407] (II) Initializing extension Present
[    23.407] (II) Initializing extension DRI3
[    23.407] (II) Initializing extension X-Resource
[    23.407] (II) Initializing extension XVideo
[    23.407] (II) Initializing extension XVideo-MotionCompensation
[    23.407] (II) Initializing extension XFree86-VidModeExtension
[    23.407] (II) Initializing extension XFree86-DGA
[    23.407] (II) Initializing extension XFree86-DRI
[    23.407] (II) Initializing extension DRI2
[    23.407] (II) Initializing extension GLX
[    23.407] (II) Initializing extension GLX
[    23.407] (II) Indirect GLX disabled.
[    23.407] (II) Initializing extension NV-GLX
[    23.407] (II) Initializing extension NV-CONTROL
[    23.407] (II) Initializing extension XINERAMA
[    23.506] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    23.506] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    23.506] (II) LoadModule: "libinput"
[    23.507] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    23.512] (II) Module libinput: vendor="X.Org Foundation"
[    23.512] 	compiled for 1.20.3, module version = 0.28.2
[    23.512] 	Module class: X.Org XInput Driver
[    23.512] 	ABI class: X.Org XInput driver, version 24.1
[    23.512] (II) Using input driver 'libinput' for 'Power Button'
[    23.513] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 30 paused 0
[    23.513] (**) Power Button: always reports core events
[    23.513] (**) Option "Device" "/dev/input/event1"
[    23.513] (**) Option "_source" "server/udev"
[    23.519] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    23.519] (II) event1  - Power Button: device is a keyboard
[    23.519] (II) event1  - Power Button: device removed
[    23.519] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    23.519] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    23.520] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    23.520] (II) event1  - Power Button: device is a keyboard
[    23.520] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    23.520] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    23.520] (II) Using input driver 'libinput' for 'Power Button'
[    23.521] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 33 paused 0
[    23.521] (**) Power Button: always reports core events
[    23.521] (**) Option "Device" "/dev/input/event0"
[    23.521] (**) Option "_source" "server/udev"
[    23.521] (II) event0  - Power Button: is tagged by udev as: Keyboard
[    23.521] (II) event0  - Power Button: device is a keyboard
[    23.521] (II) event0  - Power Button: device removed
[    23.521] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    23.521] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    23.522] (II) event0  - Power Button: is tagged by udev as: Keyboard
[    23.522] (II) event0  - Power Button: device is a keyboard
[    23.522] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event12)
[    23.522] (II) No input driver specified, ignoring this device.
[    23.522] (II) This device may have been added with another device file.
[    23.523] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event13)
[    23.523] (II) No input driver specified, ignoring this device.
[    23.523] (II) This device may have been added with another device file.
[    23.523] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event14)
[    23.523] (II) No input driver specified, ignoring this device.
[    23.523] (II) This device may have been added with another device file.
[    23.523] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event15)
[    23.523] (II) No input driver specified, ignoring this device.
[    23.523] (II) This device may have been added with another device file.
[    23.524] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/event2)
[    23.524] (**) Logitech USB Laser Mouse: Applying InputClass "libinput pointer catchall"
[    23.524] (II) Using input driver 'libinput' for 'Logitech USB Laser Mouse'
[    23.579] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 34 paused 0
[    23.579] (**) Logitech USB Laser Mouse: always reports core events
[    23.579] (**) Option "Device" "/dev/input/event2"
[    23.579] (**) Option "_source" "server/udev"
[    23.581] (II) event2  - Logitech USB Laser Mouse: is tagged by udev as: Mouse
[    23.581] (II) event2  - Logitech USB Laser Mouse: device set to 1000 DPI
[    23.581] (II) event2  - Logitech USB Laser Mouse: device is a pointer
[    23.581] (II) event2  - Logitech USB Laser Mouse: device removed
[    23.581] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5:1.0/0003:046D:C069.0001/input/input2/event2"
[    23.581] (II) XINPUT: Adding extended input device "Logitech USB Laser Mouse" (type: MOUSE, id 8)
[    23.581] (**) Option "AccelerationScheme" "none"
[    23.581] (**) Logitech USB Laser Mouse: (accel) selected scheme none/0
[    23.581] (**) Logitech USB Laser Mouse: (accel) acceleration factor: 2.000
[    23.581] (**) Logitech USB Laser Mouse: (accel) acceleration threshold: 4
[    23.583] (II) event2  - Logitech USB Laser Mouse: is tagged by udev as: Mouse
[    23.583] (II) event2  - Logitech USB Laser Mouse: device set to 1000 DPI
[    23.583] (II) event2  - Logitech USB Laser Mouse: device is a pointer
[    23.584] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/mouse0)
[    23.584] (II) No input driver specified, ignoring this device.
[    23.584] (II) This device may have been added with another device file.
[    23.585] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event3)
[    23.585] (**) HID 046a:0023: Applying InputClass "libinput keyboard catchall"
[    23.585] (II) Using input driver 'libinput' for 'HID 046a:0023'
[    23.586] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 35 paused 0
[    23.586] (**) HID 046a:0023: always reports core events
[    23.586] (**) Option "Device" "/dev/input/event3"
[    23.586] (**) Option "_source" "server/udev"
[    23.587] (II) event3  - HID 046a:0023: is tagged by udev as: Keyboard
[    23.587] (II) event3  - HID 046a:0023: device is a keyboard
[    23.587] (II) event3  - HID 046a:0023: device removed
[    23.587] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-6/2-6:1.0/0003:046A:0023.0002/input/input3/event3"
[    23.587] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 9)
[    23.589] (II) event3  - HID 046a:0023: is tagged by udev as: Keyboard
[    23.589] (II) event3  - HID 046a:0023: device is a keyboard
[    23.590] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event4)
[    23.590] (**) HID 046a:0023: Applying InputClass "libinput keyboard catchall"
[    23.590] (II) Using input driver 'libinput' for 'HID 046a:0023'
[    23.591] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 36 paused 0
[    23.591] (**) HID 046a:0023: always reports core events
[    23.591] (**) Option "Device" "/dev/input/event4"
[    23.591] (**) Option "_source" "server/udev"
[    23.592] (II) event4  - HID 046a:0023: is tagged by udev as: Keyboard
[    23.592] (II) event4  - HID 046a:0023: device is a keyboard
[    23.592] (II) event4  - HID 046a:0023: device removed
[    23.592] (II) libinput: HID 046a:0023: needs a virtual subdevice
[    23.592] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-6/2-6:1.1/0003:046A:0023.0003/input/input4/event4"
[    23.592] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: MOUSE, id 10)
[    23.592] (**) Option "AccelerationScheme" "none"
[    23.592] (**) HID 046a:0023: (accel) selected scheme none/0
[    23.592] (**) HID 046a:0023: (accel) acceleration factor: 2.000
[    23.592] (**) HID 046a:0023: (accel) acceleration threshold: 4
[    23.594] (II) event4  - HID 046a:0023: is tagged by udev as: Keyboard
[    23.594] (II) event4  - HID 046a:0023: device is a keyboard
[    23.595] (II) config/udev: Adding input device Driving Force GT (/dev/input/event6)
[    23.595] (**) Driving Force GT: Applying InputClass "joystick catchall"
[    23.595] (**) Driving Force GT: Applying InputClass "joystick catchall"
[    23.595] (II) LoadModule: "joystick"
[    23.595] (II) Loading /usr/lib/xorg/modules/input/joystick_drv.so
[    23.596] (II) Module joystick: vendor="X.Org Foundation"
[    23.596] 	compiled for 1.19.1, module version = 1.6.3
[    23.596] 	Module class: X.Org XInput Driver
[    23.596] 	ABI class: X.Org XInput driver, version 24.1
[    23.596] (II) Using input driver 'joystick' for 'Driving Force GT'
[    23.652] (II) systemd-logind: got fd for /dev/input/event6 13:70 fd 37 paused 0
[    23.652] (**) Driving Force GT: always reports core events
[    23.653] (**) Driving Force GT (keys): Applying InputClass "joystick catchall"
[    23.653] (**) Driving Force GT (keys): Applying InputClass "joystick catchall"
[    23.653] (II) Using input driver 'joystick' for 'Driving Force GT (keys)'
[    23.653] (II) systemd-logind: returning pre-existing fd for /dev/input/event6 13:70
[    23.653] (**) Driving Force GT (keys): always reports core events
[    23.653] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-7/2-7:1.0/0003:046D:C29A.0004/input/input6/event6"
[    23.653] (II) XINPUT: Adding extended input device "Driving Force GT (keys)" (type: JOYSTICK, id 11)
[    23.671] (**) Option "Device" "/dev/input/event6"
[    23.672] (**) Option "StartMouseEnabled" "False"
[    23.672] (**) Option "StartKeysEnabled" "False"
[    23.672] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-7/2-7:1.0/0003:046D:C29A.0004/input/input6/event6"
[    23.672] (II) XINPUT: Adding extended input device "Driving Force GT" (type: JOYSTICK, id 12)
[    23.672] (II) Joystick: Driving Force GT. bus 0x3 vendor 0x46d product 0xc29a version 0x111
[    23.672] (II) Joystick: found 5 axes, 21 buttons
[    23.672] JOYSTICK: DebugLevel set to 0
[    23.672] (**) Driving Force GT: (accel) keeping acceleration scheme 1
[    23.672] (**) Driving Force GT: (accel) acceleration profile 0
[    23.672] (**) Driving Force GT: (accel) acceleration factor: 2.000
[    23.672] (**) Driving Force GT: (accel) acceleration threshold: 4
[    23.672] (II) config/udev: Adding input device Driving Force GT (/dev/input/js0)
[    23.672] (II) No input driver specified, ignoring this device.
[    23.672] (II) This device may have been added with another device file.
[    23.672] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event10)
[    23.672] (II) No input driver specified, ignoring this device.
[    23.672] (II) This device may have been added with another device file.
[    23.673] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event11)
[    23.673] (II) No input driver specified, ignoring this device.
[    23.673] (II) This device may have been added with another device file.
[    23.673] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event7)
[    23.673] (II) No input driver specified, ignoring this device.
[    23.673] (II) This device may have been added with another device file.
[    23.673] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event8)
[    23.673] (II) No input driver specified, ignoring this device.
[    23.673] (II) This device may have been added with another device file.
[    23.673] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event9)
[    23.673] (II) No input driver specified, ignoring this device.
[    23.673] (II) This device may have been added with another device file.
[    23.674] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[    23.674] (II) No input driver specified, ignoring this device.
[    23.674] (II) This device may have been added with another device file.
[    23.676] (**) HID 046a:0023: Applying InputClass "libinput keyboard catchall"
[    23.677] (II) Using input driver 'libinput' for 'HID 046a:0023'
[    23.677] (II) systemd-logind: returning pre-existing fd for /dev/input/event4 13:68
[    23.677] (**) HID 046a:0023: always reports core events
[    23.677] (**) Option "Device" "/dev/input/event4"
[    23.677] (**) Option "_source" "_driver/libinput"
[    23.677] (II) libinput: HID 046a:0023: is a virtual subdevice
[    23.677] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-6/2-6:1.1/0003:046A:0023.0003/input/input4/event4"
[    23.677] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 13)
[    24.565] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    24.565] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    24.565] (--) NVIDIA(GPU-0): 
[    24.568] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    24.568] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    24.568] (--) NVIDIA(GPU-0): 
[    24.570] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    24.570] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[    24.570] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    24.570] (--) NVIDIA(GPU-0): 
[    24.603] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): connected
[    24.603] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): Internal TMDS
[    24.603] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): 225.0 MHz maximum pixel clock
[    24.603] (--) NVIDIA(GPU-0): 
[    24.605] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    24.605] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    24.605] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    24.605] (--) NVIDIA(GPU-0): 
[    24.662] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    24.662] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    24.662] (--) NVIDIA(GPU-0): 
[    24.665] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    24.665] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    24.665] (--) NVIDIA(GPU-0): 
[    24.683] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    24.683] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[    24.683] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    24.683] (--) NVIDIA(GPU-0): 
[    24.720] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): connected
[    24.720] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): Internal TMDS
[    24.720] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): 225.0 MHz maximum pixel clock
[    24.720] (--) NVIDIA(GPU-0): 
[    24.723] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    24.723] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    24.723] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    24.723] (--) NVIDIA(GPU-0): 
[    24.890] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    24.890] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    24.890] (--) NVIDIA(GPU-0): 
[    24.895] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    24.895] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    24.895] (--) NVIDIA(GPU-0): 
[    24.906] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    24.906] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[    24.906] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    24.906] (--) NVIDIA(GPU-0): 
[    24.939] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): connected
[    24.939] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): Internal TMDS
[    24.939] (--) NVIDIA(GPU-0): FUS P22W-5 (DFP-1): 225.0 MHz maximum pixel clock
[    24.939] (--) NVIDIA(GPU-0): 
[    24.946] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    24.947] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    24.947] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    24.947] (--) NVIDIA(GPU-0): 
[   368.707] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   368.707] (EE) NVIDIA(0):     recover...
[   368.794] (II) NVIDIA(0): Error recovery was successful.
[   368.794] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   368.794] (EE) NVIDIA(0):     recover...
[   372.894] (II) NVIDIA(0): Error recovery was successful.
[   372.894] (II) event2  - Logitech USB Laser Mouse: SYN_DROPPED event - some input events have been lost.
[   372.895] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   372.895] (EE) NVIDIA(0):     recover...
[   372.915] (II) NVIDIA(0): Error recovery was successful.
[   372.918] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   372.918] (EE) NVIDIA(0):     recover...
[   372.997] (II) NVIDIA(0): Error recovery was successful.
[   372.998] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   372.998] (EE) NVIDIA(0):     recover...
[   373.007] (II) NVIDIA(0): Error recovery was successful.
[   373.896] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   373.896] (EE) NVIDIA(0):     recover...
[   374.475] (II) NVIDIA(0): Error recovery was successful.
[   374.476] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   374.476] (EE) NVIDIA(0):     recover...
[   374.514] (II) NVIDIA(0): Error recovery was successful.
[   374.514] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   374.514] (EE) NVIDIA(0):     recover...
[   378.591] (II) NVIDIA(0): Error recovery was successful.
[   378.591] (II) event2  - Logitech USB Laser Mouse: SYN_DROPPED event - some input events have been lost.
[   378.592] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   378.592] (EE) NVIDIA(0):     recover...
[   382.651] (II) NVIDIA(0): Error recovery was successful.
[   382.651] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   382.652] (EE) NVIDIA(0):     recover...
[   382.662] (II) NVIDIA(0): Error recovery was successful.
[   382.662] (II) event2  - Logitech USB Laser Mouse: SYN_DROPPED event - some input events have been lost.
[   382.663] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   382.663] (EE) NVIDIA(0):     recover...
[   391.730] (II) NVIDIA(0): Error recovery was successful.
[   391.731] (II) event2  - Logitech USB Laser Mouse: SYN_DROPPED event - some input events have been lost.
[   391.731] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.731] (EE) NVIDIA(0):     recover...
[   391.740] (II) NVIDIA(0): Error recovery was successful.
[   391.740] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.740] (EE) NVIDIA(0):     recover...
[   391.750] (II) NVIDIA(0): Error recovery was successful.
[   391.751] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.751] (EE) NVIDIA(0):     recover...
[   391.760] (II) NVIDIA(0): Error recovery was successful.
[   391.760] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.760] (EE) NVIDIA(0):     recover...
[   391.771] (II) NVIDIA(0): Error recovery was successful.
[   391.772] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.772] (EE) NVIDIA(0):     recover...
[   391.781] (II) NVIDIA(0): Error recovery was successful.
[   391.781] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.781] (EE) NVIDIA(0):     recover...
[   391.791] (II) NVIDIA(0): Error recovery was successful.
[   391.793] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.793] (EE) NVIDIA(0):     recover...
[   391.803] (II) NVIDIA(0): Error recovery was successful.
[   391.803] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.803] (EE) NVIDIA(0):     recover...
[   391.813] (II) NVIDIA(0): Error recovery was successful.
[   391.813] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.813] (EE) NVIDIA(0):     recover...
[   391.823] (II) NVIDIA(0): Error recovery was successful.
[   391.824] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.824] (EE) NVIDIA(0):     recover...
[   391.834] (II) NVIDIA(0): Error recovery was successful.
[   391.835] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[   391.836] (EE) NVIDIA(0):     recover...
[   394.839] (EE) NVIDIA(GPU-0): Failed to initialize DMA.
[   394.840] (EE) NVIDIA(0): Failed to allocate push buffer
[   394.840] (EE) NVIDIA(0): Error recovery failed.
[   394.840] (EE) NVIDIA(0):  *** Aborting ***
[   394.840] (EE) 
Fatal server error:
[   394.840] (EE) Failed to recover from error!
[   394.840] (EE) 
[   394.840] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   394.840] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   394.840] (EE) 
[   394.840] (EE) 
[   394.840] (EE) Backtrace:
[   394.840] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x4d) [0x5646c1df669d]
[   394.840] (EE) 1: /usr/lib/Xorg (0x5646c1d44000+0xa8be8) [0x5646c1decbe8]
[   394.840] (EE) 2: /usr/lib/libc.so.6 (0x7f8f73d65000+0x3a7e0) [0x7f8f73d9f7e0]
[   394.840] (EE) 3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f6edee000+0xcd609) [0x7f8f6eebb609]
[   394.840] (EE) 4: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f6edee000+0xcd6ff) [0x7f8f6eebb6ff]
[   394.840] (EE) 5: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f6edee000+0xb936d) [0x7f8f6eea736d]
[   394.840] (EE) 6: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f8f6edee000+0x61dcc2) [0x7f8f6f40bcc2]
[   394.840] (EE) 
[   394.840] (EE) Segmentation fault at address 0xc
[   394.840] (EE) 
FatalError re-entered, aborting
[   394.840] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   394.840] (EE) 

Using an nVidia GTX 560Ti, no such problems occured before today. Any thoughts?

edit: Scratch it, looks like my video card just died, the problems now appear even in the GRUB screen...

Last edited by PhotonX (2019-07-14 08:02:58)


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#15 2019-08-28 04:46:27

runninghorse
Banned
Registered: 2019-07-20
Posts: 10
Website

Re: nvidia 390xx with kernel 5.1.x

Now Nividia version is 391xx

Offline

Board footer

Powered by FluxBB