You are not logged in.

#1 2006-08-14 17:01:35

MrBackhand
Member
From: Texas, USA
Registered: 2006-05-26
Posts: 33

LogiTech QuickCam webcam does not create /dev/video0

I have followed the Arch Webcam Wiki, and read numerous posts to get my QuickCam working and I can not seem to get it to create the /dev/video0 .

dmesg sees that it is connected:

usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice

I am using the spca5xx driver which I got from http://mxhaard.free.fr/spca5xx.html and I was able to compile and install it with no problem.

lsmod | grep spca shows:

lsmod | grep spca
spca5xx               672208  0
videodev                7808  1 spca5xx
usbcore               113796  3 uhci_hcd,spca5xx

lsusb shows:

Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 046d:092e Logitech, Inc.
Bus 001 Device 002: ID 05e3:0606 Genesys Logic, Inc.
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000

I tried recompiling the kernel as it was suggested in a few of the WebCam posts in this forum but I still do not get /dev/video0.  Any ideas??

Thank you.

Offline

#2 2006-08-14 22:31:48

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 786
Website

Re: LogiTech QuickCam webcam does not create /dev/video0

Exactly which quickcam is it?

Offline

#3 2006-08-14 23:38:39

MrBackhand
Member
From: Texas, USA
Registered: 2006-05-26
Posts: 33

Re: LogiTech QuickCam webcam does not create /dev/video0

It is a Logitech Quickcam Chat and listed as 'Test' on the spcaa website. 

Thanks.

Offline

#4 2006-08-15 00:32:15

user
Member
Registered: 2006-03-29
Posts: 465

Re: LogiTech QuickCam webcam does not create /dev/video0

Specific model name is important when you installing logitech quickcam into linux-2.6.

mostly pwc module works fine with linux-2.4.x, but in 2.6 still in unstable release
http://www.saillard.org/linux/pwc/

Philips USB Webcam == logitech


good luck!


I removed my sig, cause i select the flag, the flag often the target of enemy.

SAR brain-tumor
[img]http://img91.imageshack.us/img91/460/cellphonethumb0ff.jpg[/img]

Offline

#5 2006-08-18 03:35:47

mac57
Member
From: St. Somewhere
Registered: 2006-01-06
Posts: 302
Website

Re: LogiTech QuickCam webcam does not create /dev/video0

I have been using a Logitech Quickcam Pro 4000 with Arch 0.7.1 and 2.6 kernel for some time now. Works great! However, I have no idea if the PWC module is the right one for the Quickcam Chat.


Cast off the Microsoft shackles Jan 2005

Offline

#6 2006-08-18 15:43:45

MrBackhand
Member
From: Texas, USA
Registered: 2006-05-26
Posts: 33

Re: LogiTech QuickCam webcam does not create /dev/video0

Thanks for your help.  I took the webcam back and exchanged it for a QuickCam Fusion.  This cam uses the the USB Video class drivers available at http://linux-uvc.berlios.de/ and I was able to get the webcam to work, but only in Ekiga, no other apps support it at this time.  I will just wait until applications are updated and support it. 

Thank you.[/url]

Offline

Board footer

Powered by FluxBB