You are not logged in.

#1 2019-09-11 10:26:32

a_manthey
Member
Registered: 2017-08-21
Posts: 13

[Solved] keepass does not start after upgrade of mono to 6.0.0.327-1

running from console gives this:

keepass
* Assertion at aot-runtime.c:2564, condition `is_ok (error)' not met, function:decode_cached_class_info, Image out of date


=================================================================
	Native Crash Reporting
=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================
/proc/self/maps:
41200000-41210000 rwxp 00000000 00:00 0 
41767000-41777000 rwxp 00000000 00:00 0 
560ab5e0d000-560ab5e39000 r--p 00000000 fe:03 5280880                    /usr/bin/mono-sgen
560ab5e39000-560ab615f000 r-xp 0002c000 fe:03 5280880                    /usr/bin/mono-sgen
560ab615f000-560ab62a1000 r--p 00352000 fe:03 5280880                    /usr/bin/mono-sgen
560ab62a2000-560ab62a9000 r--p 00494000 fe:03 5280880                    /usr/bin/mono-sgen
560ab62a9000-560ab62ae000 rw-p 0049b000 fe:03 5280880                    /usr/bin/mono-sgen
560ab62ae000-560ab62c5000 rw-p 00000000 00:00 0 
560ab67a4000-560ab6907000 rw-p 00000000 00:00 0                          [heap]
7f05ec000000-7f05ec021000 rw-p 00000000 00:00 0 
7f05ec021000-7f05f0000000 ---p 00000000 00:00 0 
7f05f08cb000-7f05f0943000 r--p 00000000 fe:03 7871247                    /usr/lib/mono/gac/System.Drawing/4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
7f05f0943000-7f05f0c4a000 r--p 00000000 fe:03 7995532                    /usr/lib/mono/gac/System.Xml/4.0.0.0__b77a5c561934e089/System.Xml.dll
7f05f0c4a000-7f05f0ec7000 r--p 00000000 fe:03 7995535                    /usr/lib/mono/gac/System/4.0.0.0__b77a5c561934e089/System.dll
7f05f0ec7000-7f05f118b000 r--p 00000000 fe:03 7995503                    /usr/lib/mono/gac/System.Windows.Forms/4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
7f05f118b000-7f05f118c000 r--p 00000000 fe:03 7080379                    /usr/share/keepass/KeePass.exe.so
7f05f118c000-7f05f145a000 r-xp 00001000 fe:03 7080379                    /usr/share/keepass/KeePass.exe.so
7f05f145a000-7f05f150b000 r--p 002cf000 fe:03 7080379                    /usr/share/keepass/KeePass.exe.so
7f05f150b000-7f05f150c000 r--p 0037f000 fe:03 7080379                    /usr/share/keepass/KeePass.exe.so
7f05f150c000-7f05f150d000 rw-p 00380000 fe:03 7080379                    /usr/share/keepass/KeePass.exe.so
7f05f150d000-7f05f1531000 rw-p 00000000 00:00 0 
7f05f1531000-7f05f1832000 r--p 00000000 fe:03 7080371                    /usr/share/keepass/KeePass.exe
7f05f1832000-7f05f1833000 ---p 00000000 00:00 0 
7f05f1833000-7f05f1834000 rw-p 00000000 00:00 0 
7f05f1834000-7f05f183c000 ---p 00000000 00:00 0 

=================================================================
	Basic Fault Adddress Reporting
=================================================================
Memory around native instruction pointer (0x7f05f4861755):0x7f05f4861745  d2 4c 89 ce bf 02 00 00 00 b8 0e 00 00 00 0f 05  .L..............
0x7f05f4861755  48 8b 84 24 08 01 00 00 64 48 33 04 25 28 00 00  H..$....dH3.%(..
0x7f05f4861765  00 75 24 44 89 c0 48 81 c4 18 01 00 00 c3 0f 1f  .u$D..H.........
0x7f05f4861775  44 00 00 48 8b 15 f1 16 18 00 f7 d8 41 b8 ff ff  D..H........A...

=================================================================
	Native stacktrace:
=================================================================
	0x560ab5f3a00a - mono : (null)
	0x560ab5ec817e - mono : (null)
	0x7f05f4a17d00 - /usr/lib/libpthread.so.0 : (null)
	0x7f05f4861755 - /usr/lib/libc.so.6 : gsignal
	0x7f05f484c851 - /usr/lib/libc.so.6 : abort
	0x560ab5e39c13 - mono : (null)
	0x560ab613a8b6 - mono : (null)
	0x560ab6154e0f - mono : (null)
	0x560ab61553cd - mono : monoeg_assertion_message
	0x560ab5eb20c5 - mono : (null)
	0x560ab5eb8207 - mono : (null)
	0x560ab5fd3417 - mono : (null)
	0x560ab608f4c4 - mono : (null)
	0x560ab608f810 - mono : (null)
	0x560ab608fa76 - mono : (null)
	0x560ab609a978 - mono : mono_method_verify
	0x560ab5f3c38e - mono : (null)
	0x560ab5f3f153 - mono : (null)
	0x560ab5f413e5 - mono : (null)
	0x560ab5e4276b - mono : (null)
	0x560ab5ecba7f - mono : (null)
	0x560ab5ecc619 - mono : (null)
	0x41767393 - Unknown

=================================================================
	Telemetry Dumper:
=================================================================
Pkilling 0x7f05f1a32700 from 0x7f05f4822780
Entering thread summarizer pause from 0x7f05f4822780
Finished thread summarizer pause from 0x7f05f4822780.

Waiting for dumping threads to resume

=================================================================
	External Debugger Dump:
=================================================================
mono_gdb_render_native_backtraces not supported on this platform, unable to find gdb or lldb

=================================================================
	Managed Stacktrace:
=================================================================
	  at <unknown> <0xffffffff>
	  at KeePass.Program:Main <0x0003a>
	  at <Module>:runtime_invoke_void_object <0x00091>
=================================================================
Abgebrochen (Speicherabzug geschrieben)

downgrade of mono to 6.0.0.319-1 fixed it.

kind regards Andreas

Last edited by a_manthey (2019-09-11 23:01:51)

Offline

#2 2019-09-11 11:56:03

sammiev
Member
Registered: 2018-12-22
Posts: 19

Re: [Solved] keepass does not start after upgrade of mono to 6.0.0.327-1

Yes I notice this this morning. Using Keepassxc until Keepass releases their update.

Edit: It seems the update is out and I can confirm it works.

Last edited by sammiev (2019-09-11 14:59:29)

Offline

#3 2019-09-11 16:59:05

a_manthey
Member
Registered: 2017-08-21
Posts: 13

Re: [Solved] keepass does not start after upgrade of mono to 6.0.0.327-1

after upgrade of keepass to 2.42.1-4 i could upgrade mono to 6.0.0.327-1. Keepass is working as usual.

Offline

#4 2019-09-11 17:32:30

sammiev
Member
Registered: 2018-12-22
Posts: 19

Re: [Solved] keepass does not start after upgrade of mono to 6.0.0.327-1

You really should mark this thread as been Solved.

Offline

Board footer

Powered by FluxBB