You are not logged in.

#1 2019-09-11 18:45:02

pcattori
Member
Registered: 2019-09-11
Posts: 10

[SOLVED] "irq 48: nobody cared" shows before login

I got Arch installed on my ThinkPad X1 Extreme Gen 2 but I see the following once the system has booted up:

Arch Linux 5.2.12-arch1-1-ARCH (tty1)

mercury login: [    4.311145] irq 48: nobody cared (try booting with the "irqpoll" option)
[    4.311199] handlers:
[    4.311207] [<000000004ef86164>] tis_int_handler [tpm_tis_core]
[    4.311220] Disabling IRQ #48

(mercury is the name of my host)

I can usually press enter to get another prompt for my login and login in works normally.

I saw a similar post (https://bbs.archlinux.org/viewtopic.php?id=133327) that suggested looking at:

  • /proc/interrupts file

  • files in /proc/irq/48

  • output of lspci -vv

Output from /proc/interrupts

# cat /proc/interrupts | grep 48:
  48:     0     0     0     0     0     0     0     0     0     100000     0     0  IR-IO-APIC    48-fasteoi    tpm0

^not sure how to interpret this...



Not sure what I should be looking for within /proc/irq/48




lspci -vv doesn't show anything matching irq 48:

# lspci -vv | grep "IRQ 48"

(^ no output)

How can I address this message and stop it from appearing?

Last edited by pcattori (2019-09-11 20:43:12)

Offline

#2 2019-09-11 19:11:11

Swiggles
Member
Registered: 2014-08-02
Posts: 145

Re: [SOLVED] "irq 48: nobody cared" shows before login

So what happens when you enable "irqpoll"? The issue points to a faulty firmware or driver and it might help.

Offline

#3 2019-09-11 20:42:55

pcattori
Member
Registered: 2019-09-11
Posts: 10

Re: [SOLVED] "irq 48: nobody cared" shows before login

I noticed when enabling "irqpoll" that I had nomodeset i915.modeset=0 nouveau.modeset=0 Kernel parameters set from a previous install. I removed those kernel parameters and that fixed the issue.

Offline

Board footer

Powered by FluxBB